1. mtb1's Avatar
    The Start button vibrates when pushed, The power button does nothing,. It has a full charge. Same thing happened too my refurbished 925 last night.. Now this, no response on the 2520 whatsoever.. They both just died. The 2520 is completely stock as opposed too the 925 running 8.1.. suggestions? Thanks.
    04-25-2014 11:50 AM
  2. gapost's Avatar
    Did you hold down power and volume down button for about 15-20 seconds to reset it? You can go to device manager and change the power settings of the two usb ports listed to not go into power save mode and that should fix your problem on the 2520
    mtb1 likes this.
    04-25-2014 01:13 PM
  3. mtb1's Avatar
    Did you hold down power and volume down button for about 15-20 seconds to reset it? You can go to device manager and change the power settings of the two usb ports listed to not go into power save mode and that should fix your problem on the 2520
    Thank You, Very much! This did the trick. I will now find the device manager and make the changes you recommended.. Thanks again...
    04-25-2014 02:54 PM
  4. ChumsFuture's Avatar
    I blame the buyout
    mtb1 likes this.
    04-25-2014 04:53 PM
  5. frankelweeze's Avatar
    There's a fix for this problem.
    It's apparently a driver issue.
    Go into Control Panel on desktop, then Device Manager
    at the bottom you'll see "Universal Serial Bus Controllers" and expand that
    for each device or HUB listed, click the property and any "Power Management" tab un-tick "Allow computer to turn off this device to save power"

    The hit on overall battery is minimal and the black screen or frozen device problem goes away.
    Enjoy your tablet!
    mtb1 likes this.
    04-29-2014 10:07 AM
  6. bgrabert's Avatar
    This fix above still didn't work. Any other suggestions?
    08-29-2014 12:08 PM
  7. AdilY's Avatar
    This fix above still didn't work. Any other suggestions?
    Make sure your display is okay. You can connect a monitor via HDMI and see if the tablet works.
    09-16-2014 07:17 PM
  8. Senordingdong2K's Avatar
    Mine is acting up now.
    The tablet is not charging and the charger does appear to worth as the Green light comes on.
    When I got the power button, the screen comes on but all it displays is the Red battery icon then shuts itself off again.

    Can't get the soft reset to work either.
    Any suggestions?
    05-05-2015 02:11 PM
  9. Jonathan57's Avatar
    Try holding down both the power button and the Windows start button for a few seconds. Then check the start button. Once it no longer vibrates press the power button and it should boot up. This works for me.
    05-16-2015 03:14 PM
  10. Senordingdong2K's Avatar
    That got it. Was using wrong buttons for restart.
    05-17-2015 12:58 PM
  11. Guwu's Avatar
    Hie
    How can l go to the control panel if its not displaying at all, mine is only showing the green light. If l press the power+volume up it turns off, if l press the power+volume down it blinks and turns on again. Please help..
    02-21-2017 11:58 PM

Similar Threads

  1. PSA Dont install Windows Phone 8.1 on the Samsung ATIV SE on Verizon
    By WindowsCentral.com in forum Samsung ATIV SE
    Replies: 112
    Last Post: 05-02-2015, 07:03 PM
  2. Store Problem - Says Game is Installed, but Game isn't listed on my phone?
    By dorelse in forum Windows Phone 8.1 Preview for Developers
    Replies: 16
    Last Post: 05-28-2014, 01:55 PM
  3. Twitter beta for Windows Phone 8.1 being disabled on some devices, you could be next
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 04-27-2014, 10:53 AM
  4. WP 8.1, what is next to the wifi symbol on the home screen?
    By baseballbert in forum Windows Phone 8
    Replies: 5
    Last Post: 04-25-2014, 10:27 AM
  5. PSA Dont install Windows Phone 8.1 on the Samsung ATIV SE on Verizon
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-25-2014, 10:10 AM
LINK TO POST COPIED TO CLIPBOARD