1. gotenks82's Avatar
    Hi everyone,
    i just recently (yesterday) purchased a Lumia 520. I did the initial setup with my wifi at home, and it downloaded the first set of apps i guess.
    I still have not put my Sim card in, i tried to browse the web with my wifi with IE 10 and i stumbled on the impossibility of streaming videos...
    i tried:
    -youtube both desktop and mobile site both with the desktop or mobile IE10 mode
    -vimeo both desktop and mobile mode
    -many embedded videos on forums or facebook, in both modes
    and i ALWAYS get the same message, "Cannot play this file on the phone" (i translated from my italian phone so it may not be exactly phrased like this).
    I tried an alternative browser, UC Browser and i get the same message.
    I know the phone does not have a flash player, but all of this should work in html5, all this videos i can watch without problems in my iphone4 which does not have a flash player either...
    is it possible that the initial setup did not download some codecs?
    what else can i try?
    thanks
    08-28-2013 05:42 AM
  2. crash1989's Avatar
    Hi,

    Youtube works absolutely fine on my device. I suggest you to get the apps related to the services. UC Browser uses the same browser engine as IE so the problem propagates to it too.HTML 5 videos are supported by windows phone. I am not exactly sure why they are not working on 520. (maybe someone with a 520 can also comment)

    For YouTube I suggest MetroTube, MyTube, PrimeTube. (The official app from Microsoft is sitcom waiting to be produced)

    For Vimeo there is an official app in the WP strore
    08-28-2013 05:53 AM
  3. gotenks82's Avatar
    thanks for the prompt reply :P

    Ok, but it's not a "solution"... i mean
    i tried to do the exact same thing that this guy did on his video:


    after he completed the initial setup, as me, he could play youtube videos right from the start.
    I tried to go the same website and open the same video, with the same result as before...

    Is there a way to do a full software reset? maybe something got broken during the initial setup... the only difference from the video is that he did the initial setup after putting the sim card and an sd card... but then accesses the web through a wifi, so i can't see why that would make a difference...
    08-28-2013 05:58 AM
  4. gotenks82's Avatar
    i found the procedure to do a factory reset... i'll try it maybe tonight and see what happens... otherwise i think i got a broken phone...fortunately amazon has a very good return policy...
    08-28-2013 07:51 AM
  5. gotenks82's Avatar
    I tried just now to hard reset the device... i did the first setup all over e tried the same website... still not working...
    08-28-2013 10:35 AM
  6. crash1989's Avatar
    I tried just now to hard reset the device... i did the first setup all over e tried the same website... still not working...
    Youtube in web browser is still a problem? weird. I think if it is easier to replace you should go for a new 520, playing HTML5 vids should never be a problem/
    08-28-2013 01:40 PM
  7. Hna's Avatar
    Any non prehistoric smartphone will run Youtube off of the browser no problem.
    So I think you're either missing something very obvious or your 520 is one of a kind.
    Click on the video and it should open on the phones' own media player.
    08-29-2013 02:29 PM
  8. gotenks82's Avatar
    Hi Hna,
    i sincerely hoped i missed something very obvious, but believe me i've had my share of smartphones :P
    anyway i have a "strange" update.
    Today i tried again, i did another full reset, but before trying to browse the web, i installed the microsoft youtube app.
    I opened the app and it just woudn't work, it kept telling me that some error had occurred (red box on the top half of the screen if i remember correctly) and it wouldn't let me even browse for videos.
    Then i opened IE10 and youtube worked... so i uninstalled the youtube app and tried IE again, and youtube worked again.
    So i thought, "ok the third reset worked, i may not have to return the phone" and used it for twenty minutes, mostly getting back contacts with the transfer app and adding fb and gmail profiles. Then i put the phone in stand by with the right central button and went to prepare dinner... the phone would not wake up again. I thought that i had drained the battery (although i remembered it to be at 80% still after all the transfers) so i connected it to the power adapter. I kept trying to wake the phone up both by briefly pressing the on button or holding it for a long time. At last i removed the back cover, took off the battery and put it back. THEN the phone woke up.
    I tried another hard reset, and this time without installing anything nor connecting any profile i tried youtube and it worked.
    I swear that i tried anything before the 3 hard reset and videos wouldn't work, now this deep sleep problem... I'm leaving it sleeping a bit just now to see if it does it again...
    But now i cannot return it as a faulty unit with the same "motive" because now videos work... i guess i can always return it with a "changed my mind" motive and pay the shipping back to amazon... but i can tell that it has some erratic behaviors and i have to get rid of it now that i still can...
    08-29-2013 02:52 PM
  9. Hna's Avatar
    The official Youtube application for Windows Phone isn't working because Google blocked it from Microsoft's services.
    I thought you knew this.

    About the phone not wanting to wake up again, it happened to me two times already, and it will only power up/wake up again after a battery pull so I'll give you that.
    08-30-2013 04:00 PM

Similar Threads

  1. HDR Photo Camera - any users?
    By Shredcow in forum The Photography Lounge
    Replies: 11
    Last Post: 01-09-2014, 09:44 AM
  2. 6tag Video Upload from Library?
    By ProFilmLA in forum Applications
    Replies: 4
    Last Post: 12-29-2013, 01:23 PM
  3. Any suggestion for ToDo List app with Win8 version?
    By kokola95 in forum Applications
    Replies: 8
    Last Post: 12-17-2013, 04:15 PM
  4. Nokia Music problems
    By manas16 in forum Windows Phone 8
    Replies: 2
    Last Post: 09-23-2013, 07:27 AM
LINK TO POST COPIED TO CLIPBOARD