The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. lin0x's Avatar
    I updated my lumia 520 to amber 2 days ago.i searched for local radio stations , but couldn't find any. Again that night i searched and found only 2(in 7) radio stations. But there is a problem while listening, like the volume going up and down with increasing noise, and i cant listen while driving, or walking... I have to stand still on the same spot to hear clearly.. I tried using my friend's fm radio on his android and it picked up all radio stations and worked perfectly. I used other headphones too, still the same problem.

    Anyone having the same problem?
    10-02-2013 04:40 PM
  2. montsa007's Avatar
    Soft reset, might help.
    10-03-2013 01:15 AM
  3. Aravind Mohanadoss's Avatar
    I have exactly the same problem. My phone doesn't fetch all stations. Even the tuned stations are not clear.
    I am from India and I noticed that the settings in radio doesn't show all the regions... Only "World, Japan & America" is displayed. Is that same with everyone?

    wp_ss_20131003_0001-1-.png
    10-03-2013 02:20 AM
  4. lin0x's Avatar
    I'm also from India dude..i googled and found some other(not only 520) users having the same problem..
    10-03-2013 05:45 AM
  5. Aravind Mohanadoss's Avatar
    I did a soft reset, but no use...
    Guys, Is FM Radio working fine in your handsets? Or is it a common issue?
    10-08-2013 05:20 AM
  6. Vikas Dwivedi's Avatar
    dear i m also from india and i have got updated my lumia and fm is working fine with my phone. so u cn resrart ur phone and then try again
    10-11-2013 09:22 AM
  7. lumiadeb's Avatar
    Same problem.After Amber update,the RADIO section has been added to the Music +Video hub.but the radio catches no fm station at all.



    Sent from my RM-914_im_india_269 using Tapatalk
    10-18-2013 05:24 PM
  8. yentenebcc_1's Avatar
    I have exactly the same problem. My phone doesn't fetch all stations. Even the tuned stations are not clear.
    I am from India and I noticed that the settings in radio doesn't show all the regions... Only "World, Japan & America" is displayed. Is that same with everyone?

    Click image for larger version. 

Name:	wp_ss_20131003_0001[1].png 
Views:	8 
Size:	23.7 KB 
ID:	44918
    Select region as World and seach or tune station. yea, i am able to receives different radio but only few. however i could able to received my local radio FM
    10-18-2013 10:18 PM
  9. Selvin Rajkumar Jennison R's Avatar
    Same problem with mine too...
    10-19-2013 12:19 PM
  10. Ganggaram Jamnaani's Avatar
    There are so many FM options. Let me know which application is for Mumbai India
    10-25-2013 11:20 AM
  11. don44's Avatar
    Same thing with our 520. Mainly white noise with just the hint of hearing some audio as you search through the FM band. Is this a known issue with the 520? We are in the UK and it is set to 'world'.
    10-28-2013 05:46 AM
  12. gwinegarden's Avatar
    Works fine on my 520 here, in Canada. Have you tried the different settings? The difference may be whether you use odd or even frequencies. The fact that you hear static and some music makes me think you may be using even frequencies where you should be using odd, or vice versa. If so, you would always be .1 off the correct frequency.
    10-28-2013 07:50 AM
  13. don44's Avatar
    Hi. What different settings are you referring to? I don't understand your 'odd or even frequencies' comment either, so could you please elaborate. I searched through the FM band from (88 to 104 very approx) and it should be 'packed' with stations.

    May have to try a reset, although was hoping not to have to do that (and it didn't help someone earlier in this thread anyway).
    Last edited by don44; 10-28-2013 at 09:34 AM.
    10-28-2013 09:21 AM
  14. jonathan sink's Avatar
    Hi. What different settings are you referring to? I don't understand your 'odd or even frequencies' comment either. I searched through the FM band from (88 to 104 very approx) and almost entirely white. noise. I may have to try a reset, although was hoping not to have to do that (and it didn't help someone earlier in this thread anyway).
    I have same problem. Search through every station but only 1 doesn't have white noise.
    10-28-2013 09:23 AM
  15. gwinegarden's Avatar
    Hi. What different settings are you referring to? I don't understand your 'odd or even frequencies' comment either, so could you please elaborate. I searched through the FM band from (88 to 104 very approx) and it should be 'packed' with stations.

    May have to try a reset, although was hoping not to have to do that (and it didn't help someone earlier in this thread anyway).
    In North America, our frequencies are odd numbers (101.1, 99.5, etc.). In other regions, they are even (101.2, 99.6, etc.). So, for example, if you were in a region using even frequencies, (e.g. Japan) and you set your FM region incorrectly, it may be off on the frequency (e.g. 99.5 instead of 99.6). When you scan, do you see odd or even frequencies?

    All I am really saying is try the other region settings to see if it helps. Other than that, I cannot understand why you cannot get reception. I get tons.
    10-28-2013 12:15 PM
  16. don44's Avatar
    thanks. Will try other regions
    10-28-2013 01:36 PM
  17. Aruns5's Avatar
    Hi guys does updating ur phone deletes the previously installed apps?
    10-29-2013 03:24 AM
  18. don44's Avatar
    If by update you mean 'reset', yes, they will all disappear. Just make a list of them beforehand and then download and re-install them again after the reset. You won't have to repay for the ones you paid for previously (the app detects if you already paid for it)
    Aruns5 likes this.
    10-29-2013 05:09 AM
  19. Aruns5's Avatar
    Tks for the rply don.....
    10-29-2013 07:58 AM
  20. dhavalcoholic's Avatar
    I use "FM Radio" and it works perfectly. I have never seen this "North America / Japan / World" screen in it. Which app are you using? I am also assuming that you might not have chosen "India" in "language+region" setting. I can only see Indian regions and Cities in my app.
    11-02-2013 01:18 PM
  21. Aravind Mohanadoss's Avatar
    I use "FM Radio" and it works perfectly. I have never seen this "North America / Japan / World" screen in it. Which app are you using? I am also assuming that you might not have chosen "India" in "language+region" setting. I can only see Indian regions and Cities in my app.
    Hi... I have selected India only in "Language + Region" settings. No issues with it.... Try a long hold after you open FM Radio... You will see settings. Just under the settings, I find "North America / Japan / World"
    11-04-2013 01:41 AM
  22. vatsal28gmail's Avatar
    I'm facing same problem.. FM station signal are not cleared
    11-24-2015 12:17 AM
  23. bhawanis's Avatar
    I just bought a 640 XL in India . I am not able to get the FM Radio to catch any FM channels. I see the same setting screen where there are only 3 options World/North America/Japan. Is this App restricted to only these regions or does this cater to India as well ? Has anyone faced the same problem and been able to fix it ?
    12-30-2015 01:11 PM
  24. anand Kumar22's Avatar
    I updated my mobile Lumina 650 but F ,M radio is apps missing , give me how to recover fm app my mobile 9884156696
    09-12-2016 12:11 PM

Similar Threads

  1. LUMIA 510 - problems and tweaks (please help) (win 7.8)
    By heisenberg90 in forum Windows Phone 7
    Replies: 3
    Last Post: 11-23-2013, 09:34 AM
  2. Text and live tile problems
    By donebrasko in forum Nokia Lumia 928
    Replies: 6
    Last Post: 10-25-2013, 06:53 PM
  3. CR-200 Charging Problems - Normal or Defective?
    By GraniteStateColin in forum Cases & Accessories
    Replies: 2
    Last Post: 10-06-2013, 12:57 PM
  4. Nokia Muisc app Problem !
    By fonzejaa in forum Nokia Lumia 720
    Replies: 4
    Last Post: 10-04-2013, 12:32 AM
  5. Biggest problem in wp7 ever..
    By chataddicted in forum Windows Phone 7
    Replies: 1
    Last Post: 10-01-2013, 09:37 AM
LINK TO POST COPIED TO CLIPBOARD