1. Prashant Parapurath's Avatar
    Recently I brought lumia 520 but am facing problem with internet connectivity.

    Am using internet through my service provider....

    The problem is the connection to edge gets disconnected after every 5 minutes, in order to restore the connection either i need to switch off my device or switch on & off flight mode. It works for another 5 to 10 minutes thats it.

    Is this a software issue or issue with the phones hardware or am i missing something in terms of settings.


    Regards,
    Prashant
    10-05-2013 02:30 AM
  2. DBDev's Avatar
    That sounds strange, and I haven't heard of it before, so it's probably not a issue with all phones. It could be a hardware or software issue with your phone, but it could also be something wrong with your simcard.
    10-05-2013 02:54 AM
  3. Prashant Parapurath's Avatar
    Thanks dev....

    There is one more thing the status on top of my phones screen shows as edge active all the time.
    10-05-2013 04:52 AM
  4. rakesh1995's Avatar
    Recently I brought lumia 520 but am facing problem with internet connectivity.

    Am using internet through my service provider....

    The problem is the connection to edge gets disconnected after every 5 minutes, in order to restore the connection either i need to switch off my device or switch on & off flight mode. It works for another 5 to 10 minutes thats it.

    Is this a software issue or issue with the phones hardware or am i missing something in terms of settings.


    Regards,
    Prashant
    if you are a docomo or a vodafone user then there net server are down right now in some states
    10-05-2013 02:25 PM
  5. LAtM's Avatar
    Gosh this is happening to my nokia Lumia 720 as well. I have to switch off my phone and start it again, hoping to get a wifi signal. My internet connection is going great with devices like my laptops. It is very unsettling to switch off the mobile every 5 minutes.

    Thanks,
    LAtM
    12-20-2013 09:08 AM
  6. Joy Alexander's Avatar
    nokia lumia 520 internet connection not getting
    03-27-2014 10:20 AM
  7. Stacey Leigh Diedericks's Avatar
    Have internet connection problems on Cell C network from time to time.. What are the correct APN settings I've got 2.. Cell c witch was standard after black update and Cell C internet witch I was told to create... Confused please HELP 🙈


    Sent from my RM-914_im_south_africa_242 using Tapatalk
    04-01-2014 04:30 AM
  8. Ranjith Kannankattil's Avatar
    How to Turn Your Windows 8.1 Device Into a WiFi Access Point

    This method worked for me without any softwares :)
    07-29-2014 01:04 AM
  9. Sanket Samant's Avatar
    Everything was fine when my 520 was running on windows phone 8. I think there is a problem in developer's preview of windows phone 8.1 .
    07-29-2014 01:12 AM
  10. Sarang68's Avatar
    One of my friend with a 520 has this problem where at home she is asked for a log in every time to connect to Wi-Fi
    07-29-2014 01:13 AM
  11. ivdza's Avatar
    I had exactly the same problem with my 520,i tried everything,APN settings,turning off and on data connection,soft reset,deleting some recently added apps but nothing. Then i did hard reset and its ok now. My ohone is sim free without carrier contract,i am on prepaid.
    07-29-2014 01:25 AM

Similar Threads

  1. Replies: 2
    Last Post: 08-21-2014, 01:50 PM
  2. lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 07-29-2014, 05:25 PM
  3. 520 8.1
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-2014, 12:36 AM
  4. A very serious youtube problem!
    By Asher Ratnam in forum Nokia Lumia 520
    Replies: 5
    Last Post: 07-29-2014, 12:13 AM
  5. AT&T / T-Mobile Lumia 635 plus Fitbit Flex starting at $149 at Microsoft Stores
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-28-2014, 10:00 PM
LINK TO POST COPIED TO CLIPBOARD