1. dwrrhd's Avatar
    We've been struggling with a problem with our wonderful windows phones. My husband and I both have International Factory Unlocked Lumia 520s. We can't seem to get anything other than Edge (we've traveled to different states-checking for 3g on the drive, no luck- and live in a largish city where 4g is widely available). We'd like to at least get 3g, only because Edge seems to be causing sound interference wherever we go (that static interference sound on radios, phones, etc.). We have to stop using our phones, turn them off or onto airplane mode to get the static sound to stop, which can be a problem since my husband uses his phone for work.

    So, is there a problem with Straight Talk and these phones? Or a problem with Straight Talk and having International phones? Or unlocked phones?

    I've called & chatted with Straight Talk about the problem probably 20+ times and with Nokia about 5 times. Both of which say it's the other's fault, of course. We currently have the Straight Talk AT&T sim cards and have tried a Straight Talk T-Mobile sim as well.

    We've also restored our phones to the factory settings a couple times, also to no avail. We both have the Amber update, but we weren't getting 3g before the update either. We can send/receive MMS fine.

    Under cellular our settings are:
    Data connection: on
    Data roaming options: don't roam (data doesn't seem to work if we're on roam)
    Highest connection speed: 3G (the only options are 2G & 3G-is that normal?)
    Network selection: automatic (If I search for networks it only has two options other than automatic. Both are "Home" and speeds of 2G.)

    I don't know enough about cell phone stuff to know if this is a cellular issue or a data issue (I'm guessing cellular, but would apn setting affect this?)

    Our current APN settings are:

    Internet APN
    Access Point Name: tfdata
    Username: (empty)
    Password: (empty)
    Proxy Address: (empty)
    Proxy Port: (empty)
    Network type: IPv4
    Authentication Type: none

    MMS APN
    MMS Access Point Name: tfdata
    Username: (empty)
    Password: (empty)
    Proxy Address: mms3.tracfone.com
    Proxy Port: 80
    MMSC Address: http://mms-tfdata.net
    Network Type: IPv4
    Authentication Type: none

    I've searched all over the net trying to find any answers or if anyone else has this same problem that found a resolution, but haven't found anything that has helped so far. So if anyone can help with this, that would be AWESOME! I've really hit a dead end and can't afford different phones at the moment (don't even know if they'd work with Straight Talk anyway and can't afford another carrier that would be better/more dependable.)

    Thanks!
    12-16-2013 06:26 PM
  2. Corepc's Avatar
    What is the Model number of your phone? if you are only getting edge speeds then you may be missing a band (850 in particular ) that is needed for it work properly on AT&T Network HSPA Network.

    The model number can be found underneath the battery or via settings->extra's info->more info example: mine is rm-917_nam_usa_100.
    dwrrhd likes this.
    12-16-2013 06:46 PM
  3. tgp's Avatar
    Try replacing tfdata with att.mvno If that doesn't work, try wap.tracfone

    Sent from my Nexus 5 using Tapatalk
    12-16-2013 07:05 PM
  4. dwrrhd's Avatar
    Mine says "Manufacturer Name" instead of Model number (we have model: Lumia 520). My Manufacturer Name is: RM-914_apac_malaysia_307. My husband's is RM-914_eu_euro1_327.
    12-16-2013 07:24 PM
  5. dwrrhd's Avatar
    I tried replacing tfdata with att.mvno and restarted, but still got Edge and data didn't work. I tried wap.tracfone as well with the same result. Thanks for the effort, wish it had worked. :(
    12-16-2013 07:50 PM
  6. Corepc's Avatar
    Rm-914 does not have WCDMA 850/1900 bands that are needed for AT&T networks hate to say this. Best you are going to get is Edge Speeds once again.

    Nokia Lumia 520 Specifications - Nokia

    You alternative could be trying flashing your phone with RM-915 Rom but that may brick your phone, and may not work at all then.

    Try changing the access point name to att.mvno see if that helps any, reboot the phone.

    but, I believe it is issue of missing bands once again.
    dwrrhd likes this.
    12-16-2013 07:52 PM
  7. dwrrhd's Avatar
    Okay, thanks Corepc. I'll call Nokia again tomorrow and see if I can get a replacement or something. Otherwise, I'll be reading up on how to flash my phone and praying for success. Thanks for the input. I'll post more if Nokia comes up with a solution and/or if I'm successful at flashing my phone.
    12-16-2013 08:15 PM
  8. tgp's Avatar
    I tried replacing tfdata with att.mvno and restarted, but still got Edge and data didn't work. I tried wap.tracfone as well with the same result. Thanks for the effort, wish it had worked. :(
    I'm not surprised. I believe the 3 different data settings are for if you aren't getting data at all. My wife had to change hers to get any data. But since you are getting data I didn't expect it would make a difference. But hey, you had to try something, correct?
    12-16-2013 08:26 PM
  9. dwrrhd's Avatar
    So after talking with Nokia again and from info about the missing bands from Corepc, we’ve figured out the problem. Apparently because we have the International version of these phones (We thought they’d be better and from what I remember, there weren’t any other unlocked options we could afford at the time.) it will work with Straight Talk, but just not as well in the US. “Work” being the operative word. Sure, they work, but only getting Edge really interferes with the electronics around you.

    So we bought new Lumia 520’s that are locked to AT&T (the Go Phones). And amazingly THEY GET 4G! We just put in our Straight Talk sims, the charged batteries of our International phones and started them up. (Sadly, we were past our return date on Amazon and couldn’t return the International ones and ironically had bought the new 520’s just two days before the Gold Box Deal on Amazon where they were $20 off. Sigh.)

    But, at least the phones work on 4G now (we would have taken 3G, so we’re VERY HAPPY!) And our kids will be happy since they’ll be getting our old International ones for Christmas.
    You know life has been turned on it’s head when Amazon won’t give you a good deal and your kids phones are more expensive than your own. 

    Hopefully this info will help anyone else out there looking to use Straight Talk with international phones.

    Thanks everyone for your help and input!
    12-21-2013 04:58 PM
  10. Cody Moses's Avatar
    did you have to change your APN settings on the new 520's using your straight talk service. which I have.
    03-25-2014 08:06 PM

Similar Threads

  1. Using a Logitech mouse on the Encore
    By AndyCalling in forum Toshiba Encore
    Replies: 3
    Last Post: 02-09-2014, 09:12 PM
  2. "Focus Light Only" option missing
    By techiedude007 in forum Nokia Lumia 1020
    Replies: 5
    Last Post: 12-20-2013, 01:49 PM
  3. 8.1, will we get it?
    By cmore675 in forum Nokia Lumia 1520
    Replies: 37
    Last Post: 12-18-2013, 07:14 PM
  4. Any news on a Google Voice app?
    By boneycat in forum Applications
    Replies: 4
    Last Post: 12-18-2013, 11:39 AM
  5. SOLD: UNLOCKED Nokia Lumia 822 - Black
    By worldspy99 in forum Marketplace Archive
    Replies: 3
    Last Post: 12-17-2013, 03:09 PM
LINK TO POST COPIED TO CLIPBOARD