1. Sid61's Avatar
    Since having GDR3 on my 520 there have been no problems until yesterday.

    My battery suddenly drained very quickly and now will not charge or boot up, all I get is a screen like this:

    faulty-battery.jpg

    But the strange part is that if I put this battery in my old phone, a Nokia 5800, this boots and charges fine.

    If I put the Nokia 5800 battery in the Lumia 520 then that boots and charges!

    I have done a hard reset of the 520 and its original battery still does not work even though it works fine in the 5800.

    Any ideas what is causing this?
    12-20-2013 06:43 AM
  2. Cheewii Poon's Avatar
    Hi Sid!

    I'm not exactly sure the root of this problem is, but may I ask if you have stopped using your 520 for relatively long amount of time before? (eg. 2 weeks)

    This might not be the case, for you, but when my Lumia 720 was sent in for servicing and they forgot to inform me that my device was ready for collection, it was left there about 25 days, and when I got it back I got the same problem as you. Later when I brought it back the staff told me the battery voltage had dropped due to it not being used for a long period of time, and that they had to take the battery out and charge it externally for it to work again. I'm not sure this is the same problem you're experiencing, because my phone has a integrated battery that is not removable. However it could be that case, which means that it works in your old phone because that requires a lower voltage to power on/run.

    This is a very bad and unacceptable problem that I never knew existed before (especially since 25 days is not long at all), but it seems I can't do anything about it, and it sucks that I won't be able to come back to my phone if I switch to a new phone.

    In any case you should try to send it back (whether to Nokia Care or your carrier) and see if they can charge the battery externally/do other things about it. Good luck!
    12-20-2013 07:13 AM
  3. Sid61's Avatar
    Hi Cheewii
    Thanks for your reply.
    No my Lumia 520 has been in continual use.
    When the battery is put in the 5800 it charges fully but still doesn't work in the 520

    Sent from my RM-914_eu_euro1_327 using Tapatalk
    12-20-2013 07:23 AM
  4. badcat's Avatar
    Have you inspected the connector pins? It sounds like one of the pins isn't making contact. Could be either the phone or battery side. Try taking a look at them and see if anything looks borked.
    12-20-2013 07:56 AM
  5. Sid61's Avatar
    Hi badcat
    Thanks for your help, that seems to have been the problem.
    There was no obvious damage to the contacts on the battery. However I squeezed the contacts together more and now it works.
    The connector pins on the 5800 must be slightly wider and so were making good contact with the battery but the 520's, being a bit thinner, weren't.
    Thanks for the suggestion, because I could see no obvious damage I didn't give it much thought.
    12-20-2013 08:17 AM
  6. badcat's Avatar
    Hi badcat
    Thanks for your help, that seems to have been the problem.
    There was no obvious damage to the contacts on the battery. However I squeezed the contacts together more and now it works.
    The connector pins on the 5800 must be slightly wider and so were making good contact with the battery but the 520's, being a bit thinner, weren't.
    Thanks for the suggestion, because I could see no obvious damage I didn't give it much thought.
    Awesome! I figured it was worth a try. Glad it worked for you.
    12-20-2013 09:18 AM
  7. mafuko mafuko's Avatar
    I had the same problem, squeezing of battery pins solve the problem. Many thanks !!!
    12-30-2013 03:34 PM
  8. badcat's Avatar
    I had the same problem, squeezing of battery pins solve the problem. Many thanks !!!
    Cool. I'm glad it worked for you too.
    12-31-2013 11:15 AM

Similar Threads

  1. Will Updating my nokia lumia 520 to WP8.1 OS slow my phone??
    By Luis Forkey in forum Nokia Lumia 520
    Replies: 24
    Last Post: 01-26-2015, 01:18 PM
  2. Nokia lumia 920 only sound issue
    By cocoto4 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 07-18-2014, 03:03 AM
  3. Lumia 1020 post Black update
    By niel27 in forum Nokia Lumia 1020
    Replies: 90
    Last Post: 03-19-2014, 02:55 PM
  4. How can I get battery percentage
    By wps81 in forum Microsoft Surface 2
    Replies: 4
    Last Post: 12-20-2013, 05:20 PM
  5. My battery life experience on T-Mobile Lumia 925
    By shykhan16 in forum Nokia Lumia 925
    Replies: 1
    Last Post: 12-19-2013, 11:21 PM
LINK TO POST COPIED TO CLIPBOARD