1. carlson03's Avatar
    So I have an odd issue with my Lumia 520 that maybe some people can help me with...I bought the phone in November upgrading from HTC Titan running WP 7.8....well I use my phone, all is well, until I go to turn off the screen...I press the button to turn off the screen and the screen goes black, I can see it is still lit, nothing displaying, but doesn't quite shut off. I know it doesn't shut off, because if I immediately press the power button to light up the screen again, it doesn't show anything until the back-light goes off...this only happens every so often and only lasts seconds, but still can get annoying at times. Has anyone else had this problem? I have tried to remove all applications that I could think of, disabled a lock screen application, but hasn't helped.

    I am running the developer preview on the phone, don't remember if it did it before because I upgraded it almost as soon as I got it.

    Thank you!
    01-18-2014 08:24 PM
  2. Himanshu Chowdhary's Avatar
    my mom(520 user) complaints about this issue, I couldn't find what the issue was. Hope black update will fix this bug.
    01-18-2014 11:27 PM
  3. windoors's Avatar
    This is normal, Lumia 520 screen remains lit for 4-5 seconds after pressing power button. If you press power button again during this time it will not work!
    01-18-2014 11:28 PM
  4. Himanshu Chowdhary's Avatar
    This is normal, Lumia 520 screen remains lit for 4-5 seconds after pressing power button. If you press power button again during this time it will not work!
    this is not normal , my Lumia 920 does not suffer from this so why Lumia 520, there is hole left in the software and may be,black will fix this up.
    01-18-2014 11:40 PM
  5. shmsnh's Avatar
    This does happen occasionally on my 520. Personally, I don't find it too disturbing. Don't worry about it.
    01-19-2014 02:19 AM
  6. carlson03's Avatar
    Thanks all, I won't worry about it since others have the same issue!
    windoors likes this.
    01-19-2014 09:19 AM
  7. AxeparadoX's Avatar
    I have same issue too. We will see if black update could fix this.
    01-21-2014 11:18 AM
  8. Asskickulater's Avatar
    its a bug, the way you trigger it is by turning the screen of, then on again real quick, basically to avoid the issue, wait a few seconds before trying to turn the screen on again (atleast thats my issue with a L521)
    01-30-2014 08:41 PM
  9. AxeparadoX's Avatar
    After black update this issue is gone, no more screen stay on bug for me.
    01-31-2014 02:08 AM
  10. Asskickulater's Avatar
    you got black you lucky sob!

    great to know thats fixed, its never really been a huge issue for me, but its nice to have that minor annoyance gone! thanks for the heads up
    01-31-2014 03:21 PM
  11. anon(8407492)'s Avatar
    Im really glad black fixes this. I use my phone alot in the dark and since we don't have such a fancy amoled its kinda ugly. Luckily black is "coming soon" for my country.
    01-31-2014 03:42 PM
  12. Cryio's Avatar
    In Amber, the screen used to stay a 1s awake after I've hit the lockscreen button. I just thought that the interface was quicker to react than the display itself.
    01-31-2014 04:37 PM
  13. Asskickulater's Avatar
    its actually an interesting issue, it seems more like the display hangs, when I watch it happen to mine in the dark, I can see it vaguely flicker, as if the software keeps telling it to shut off but it keeps kicking back on
    01-31-2014 09:06 PM
  14. avigyan's Avatar
    I too had the issue but after the Black update, my phone has got it resolved.
    AxeparadoX likes this.
    01-31-2014 09:20 PM
  15. windoors's Avatar
    Black update has fixed it!
    02-06-2014 03:32 AM
  16. carlson03's Avatar
    Black update has fixed it!
    I just wanted to say that I can confirm this as well! Never happened again since update!
    02-19-2014 12:01 PM
  17. MameTozhio's Avatar
    This happened to me after I updated to dev preview.
    02-19-2014 01:57 PM
  18. vvi's Avatar
    please give me solution to recover from this problem...!!!
    plzz plzz...
    05-20-2014 12:15 AM
  19. shmsnh's Avatar
    please give me solution to recover from this problem...!!!
    plzz plzz...
    This bug has been fixed with the Lumia Black firmware. Update your device.
    05-20-2014 04:13 AM

Similar Threads

  1. Odds Of Getting WP8.1 On AT&T Lumia 920 This Year??
    By WP8fan in forum Nokia Lumia 920
    Replies: 4
    Last Post: 09-08-2014, 06:03 PM
  2. Nokia Lumia 1520 mini on the way (Nokia Lumia 1520v)
    By sisqo88 in forum Upcoming & Rumored Phones
    Replies: 42
    Last Post: 01-27-2014, 10:44 PM
  3. cant logon to facebook on app or explore
    By SimonWurtz in forum Microsoft Surface for Windows RT
    Replies: 10
    Last Post: 01-19-2014, 11:51 AM
  4. Play Video from SD card on Windows Phone 7.5
    By wp75_user in forum Windows Phone 7
    Replies: 1
    Last Post: 01-19-2014, 06:32 AM
  5. Tonight On Kinect: Jace Rode uses his Xbox One to record a cooking show
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-18-2014, 06:50 PM
LINK TO POST COPIED TO CLIPBOARD