1. Ihsaan96's Avatar
    Hi guys, got a phone off one of my friends and basically I put in a T-Mobile / EE simcard in at first and the phone made calls. I took it out, put the sim back in and for some reason now it won't make calls but the T-Mobile/EE name comes up plus I get signal. Just to test if it's the phone being locked I put a GiffGaff ( O2 network ) simcard in and the phone makes and accepts calls. Any solutions to this? I know the sim isn't damaged as I put the sim in my Nexus 4 and it works fine.

    Cheers :)
    05-20-2014 05:30 PM
  2. ven07's Avatar
    This might be considered a stupid question, but did you try a soft reset?
    05-20-2014 06:26 PM
  3. Ihsaan96's Avatar
    Yeah already did the Phone reset in the About settings part. Done it a couple of times. Won't let me sign in with a Microsoft account either. Was thinking if I've been given a barred phone or something but doesn't seem like it if my giffgaff sim works.
    ven07 likes this.
    05-20-2014 06:34 PM
  4. ven07's Avatar
    Weird.. You might have to go back to the shop.. I would recommend you go personally, because the help-line isn't always helpful lol
    05-20-2014 07:04 PM

Similar Threads

  1. Lumia 630 Cortana problem
    By lynch7 in forum Nokia Lumia 630
    Replies: 25
    Last Post: 09-11-2015, 12:33 AM
  2. 37mm lens case for Lumia 920
    By ulyssesdraco in forum Nokia Lumia 920
    Replies: 1
    Last Post: 05-21-2014, 04:19 PM
  3. If there's a Mini, we prob won't see it till Surface 3
    By fc000 in forum Upcoming and Rumored Tablets
    Replies: 1
    Last Post: 05-21-2014, 03:05 AM
  4. Lumia Icon doesn't come with 8.1?
    By KennyJohnson in forum Nokia Lumia Icon
    Replies: 8
    Last Post: 05-21-2014, 01:21 AM
  5. Confused - Is pen Wacom or N-triq?
    By Great deal in forum Microsoft Surface Pro 3
    Replies: 2
    Last Post: 05-20-2014, 05:35 PM
LINK TO POST COPIED TO CLIPBOARD