1. phstratton's Avatar
    I registered my account and my Nokia 520 as a developer phone, but when I go to settings and check for update it just says "Checking for updates..." and never returns that it did or didn't find one. Any idea what's up?
    06-06-2014 03:29 PM
  2. SSgt Bruskowiz's Avatar
    You must download/install the app "preview for developers" from the store.
    In that app you have to check "enable preview for developers" and tick on "done".
    After that, your good to go and you can check your updates again.
    06-06-2014 07:19 PM
  3. phstratton's Avatar
    I had done that already man. Worked great on my ATIV S Neo but not on my 520. Any ideas?
    06-07-2014 03:35 PM
  4. troylytle's Avatar
    Soft reset?
    06-07-2014 03:43 PM
  5. phstratton's Avatar
    Yup, funny this is that when you use the power button to turn it off it sticks on "Goodbye".

    I also performed a factory reset. Same problem.
    06-07-2014 03:44 PM
  6. troylytle's Avatar
    Let the battery completely die and keep turning it on till it does nothing when you try.
    06-07-2014 03:47 PM
  7. phstratton's Avatar
    Let the battery completely die and keep turning it on till it does nothing when you try.
    Okay will do
    06-07-2014 03:53 PM
  8. SSgt Bruskowiz's Avatar
    Why not remove the battery instead?

    But wait. Your other phone ?
    Is that phone stil registered as a developersphone?
    You can't have two unlocked devices on a free account.
    06-07-2014 04:04 PM
  9. phstratton's Avatar
    Why not remove the battery instead?

    But wait. Your other phone ?
    Is that phone stil registered as a developersphone?
    You can't have two unlocked devices on a free account.
    Nope, 2 different accounts.

    and I have removed the battery.
    06-07-2014 04:27 PM
  10. SSgt Bruskowiz's Avatar
    Personaly i dont think pulling the battery or soft reset would help here,
    couse you already stated that you did a hardreset.

    you got the procedure right?
    Create a developers account ( with a other than your old one, because you otherwise lose the unlock on the other phone )
    With that same account you'r logged in on and registered your 520
    and you downloaded the developers preview app, and checked enable ( in the app ).

    What can possible go wrong with that.
    you already did it once with your older Phone
    you are shure you logged in withe the same account, your created the developersacount with?
    06-07-2014 04:56 PM
  11. phstratton's Avatar
    Personaly i dont think pulling the battery or soft reset would help here,
    couse you already stated that you did a hardreset.

    you got the procedure right?
    Create a developers account ( with a other than your old one, because you otherwise lose the unlock on the other phone )
    With that same account you'r logged in on and registered your 520
    and you downloaded the developers preview app, and checked enable ( in the app ).

    What can possible go wrong with that.
    you already did it once with your older Phone
    you are shure you logged in withe the same account, your created the developersacount with?
    Yeah I setup a new account for the 520 as a developer the same way I did for my first phone. Downloaded the app and checked everything. Still just says checking for update.
    06-07-2014 05:06 PM
  12. Makm's Avatar
    I guess Nokia care might be your last hope :P

    Anyways hopefully it will be fixed by itself... I know these things are really frustrating. But some technical problems happen in every phones man :/ Nothin to do...
    06-07-2014 05:16 PM
  13. phstratton's Avatar
    I guess Nokia care might be your last hope :P

    Anyways hopefully it will be fixed by itself... I know these things are really frustrating. But some technical problems happen in every phones man :/ Nothin to do...
    Yeah I know. Honestly for an $80 dollar phone that I've had for about a year. If it blew up tomorrow, I've definitely gotten my money's worth.
    06-07-2014 05:30 PM
  14. SSgt Bruskowiz's Avatar
    Ok, its a long haul....but maybe.
    just a idea

    Try to reflash with nokia care suit a fresh WP version, set it up ( i know... again ) and try it from there.
    06-07-2014 05:51 PM

Similar Threads

  1. WP 8.1 for 520
    By Kiko Randa in forum Nokia Lumia 520
    Replies: 1
    Last Post: 06-06-2014, 03:11 PM
  2. Here's how to (mostly) enable Nokia's 'Living Images' on your PureView Lumia
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2014, 02:42 PM
  3. Nokia Storyteller updated to add support for Living Images and more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2014, 02:00 PM
  4. Next Xbox Music update for Windows Phone 8.1 delayed until next week
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2014, 01:42 PM
  5. ZEN & TECH 67: How to get and stay motivated for #mobilefit
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-06-2014, 01:42 PM
LINK TO POST COPIED TO CLIPBOARD