1. unknow91's Avatar
    Hi guys! My father's 520 can't connect to 3G and I can't change between 2G and 3G, the setting is disabled! I tried a factory resetting with no luck! I even installed the 8.1 dev preview hopping that it will be fixed and I got no luck! I bought the phone on amazon.com and it's from EE UK! So I wanted to know if this is a hardware problem or is EE's problem? Thanks for reading this! (I'm from Venezuela and I'm not sure if his carrier is WP-friendly! Maybe that's the problem?)

    P.D: I tried with 2 additional sim cards but nothing happened! (Yes, he can browse the web but only in 2G/E)
    08-27-2014 07:16 PM
  2. Zachary Boddy's Avatar
    The problem is most likely your provider. Some providers, even if they provide good service in a location, doesn't make it consistent. It's probably just a spout of lowered service. Wait a few more hours.
    08-27-2014 09:04 PM
  3. unknow91's Avatar
    I've been waiting for like a month or more :S and I tried with another provider (the one I use and it works) and the issues is still there!
    08-29-2014 09:58 AM
  4. xandros9's Avatar
    What carrier are you using it with?
    It could be that the band used for 3G by the provider doesn't match up well with the phone's.
    08-29-2014 10:02 AM
  5. unknow91's Avatar
    Actually you may be right! I didn't check which bands are used here! The 520 is on Movilnet Venezuela! I will try to find that information!
    08-30-2014 07:13 PM
  6. unknow91's Avatar
    I checked and apparently it should work! The provider works with GSM 850 and 3G 1900 MHz so...
    08-30-2014 07:19 PM
  7. Jarkoulis's Avatar
    Had the same problem with mine. Bought the phone in UK and tried to use it in Canada. No 3G.
    There is no solution, as this is a hardware problem. There are 3 different versions of the 520 sold around the world. RM-914, RM-915 and RM-917. All models are compatible with your 2G network.
    The UK (European version) here is the RM 914 and uses 900 & 2100 for 3G, and therefore wouldn't be compatible with your 3G network. The other two (RM-915 and RM-917) would word with our 3G network.
    So most probably, you have the RM 914.

    Hope this helps
    unknow91 likes this.
    09-06-2014 06:07 PM
  8. unknow91's Avatar
    I'll check which RM is :S! Thanks for the info!
    09-19-2014 09:11 AM

Similar Threads

  1. WTS 1520 (RM-940) yellow unopened with unlock code
    By weisman87 in forum Marketplace Archive
    Replies: 10
    Last Post: 10-20-2014, 11:39 AM
  2. New phone, new problem - Office 365
    By lparsons21 in forum HTC One (M8) for Windows
    Replies: 21
    Last Post: 10-19-2014, 08:50 PM
  3. Replies: 3
    Last Post: 09-06-2014, 01:24 PM
  4. New Icon owner with a Windows 8 question
    By raqball in forum Nokia Lumia Icon
    Replies: 7
    Last Post: 08-29-2014, 06:37 PM
  5. Which performs better, CYAN or CYAN with GDR1?
    By aziouazrayes in forum Nokia Lumia 520
    Replies: 4
    Last Post: 08-28-2014, 08:26 AM
LINK TO POST COPIED TO CLIPBOARD