1. sashikumar7's Avatar
    I am in India and have a Lumia 520 8.1. When I call my contacts who are out of India, they do not see my number, but get it as private number. I went through a lot of threads that directed me to Settings -> Apps -> Phone and then I should get the option to show or hide my caller id. But apparently on my phone I dont have any option to show or hide my caller id. So can someone please help. This does not happen when I call my contacts within India.
    10-20-2014 01:58 PM
  2. AnestisL820's Avatar
    may it is something from your call provider...
    sashikumar7 likes this.
    10-20-2014 03:14 PM
  3. Alienhead95's Avatar
    There is no setting to change this for international calling. There is only one global setting for local and international calls. It depends on what service you use to call outside your country. You need to call the service provider and tell them to fix it.
    sashikumar7 likes this.
    10-20-2014 03:16 PM

Similar Threads

  1. Nokia Lumia 730 release in pakistan ?
    By Seasmy in forum Nokia Lumia 730 & 735
    Replies: 1
    Last Post: 10-24-2014, 02:31 AM
  2. What and when will be the next update for Lumia 625?
    By Narada93 in forum Microsoft News & Rumors
    Replies: 1
    Last Post: 10-21-2014, 03:03 AM
  3. On my 3rd Lumia 1520
    By Westarmy in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 10-20-2014, 10:46 PM
  4. Why can't I get my HTC Radar to send pictures on Straight Talk?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-20-2014, 05:00 PM
  5. Replies: 0
    Last Post: 10-20-2014, 12:59 PM
LINK TO POST COPIED TO CLIPBOARD