1. mogelijk's Avatar
    Basically, I plug in my phone and it starts charging but, after some variable length of time (somewhere between 2 minutes and 2 hours) I get the beep noise as if the charger has been disconnected. Often, after another variable length of time, it beeps again as if the charger has been reconnected. Most of the time, if I just leave the phone alone, it will fully charge.

    The big issue is recently the phone isn't charging. I'll plug the phone in and it will appear to start charging and often I'll get the beeps that the charger has been disconnected/reconnected. I'll leave it alone for awhile but, when I go back to check, the battery charge is lower than when I started to charge it. Additionally, while the icon will claim it is charging it doesn't appear to actually be charging.

    Most of the time, but not always, if I turn the device off and reseat the battery it will start charging again -- though often it still will only charge halfway before quitting. Sometimes, though, it won't even do that. I'm not completely sure if it is merely turning off the phone or reseating the battery that sometimes helps -- the fact that it only intermittently fixes it makes it difficult to diagnose.

    I've never been able to use a non-Nokia charger on this phone. I am using a different charger now, the charger from my Nokia 630 has the same issues as the charger that came with my 520. I've tried using thick paper to help ensure the battery is not "loose" -- though that seems like a long shot with how it starts and stop charging without the phone being touched.

    Any thoughts on what may be causing this/how to fix it would be appreciated. This phone is out of warranty and, with the cost of replacing it cheaper than servicing, I can't see the point of taking it to a service center.
    10-21-2014 01:39 PM
  2. worldspy99's Avatar
    Change the cable and see if the problem persists. Use the OEM Nokia Cable and charger if possible. Lastly the USB port might be crapping out in which case you might as well get a new phone.
    10-21-2014 01:47 PM
  3. mogelijk's Avatar
    Change the cable and see if the problem persists. Use the OEM Nokia Cable and charger if possible. Lastly the USB port might be crapping out in which case you might as well get a new phone.
    As I mentioned, I used a different charger (cable is built into the charger, so can't swap it out) and have the exact same issue.
    10-21-2014 01:58 PM
  4. worldspy99's Avatar
    As I mentioned, I used a different charger (cable is built into the charger, so can't swap it out) and have the exact same issue.
    Okay then most likely it is a USB port issue. I have certain chargers that don't charge my Lumia 810 and then certain ones that do and hence the recommendation to try a Nokia OEM to see if the issue still persisted. If it does then I am afraid you have a bad USB port.
    10-21-2014 02:29 PM

Similar Threads

  1. Is the call and network issue solved for Lumia 730?
    By WPCentral Question in forum Ask a Question
    Replies: 16
    Last Post: 12-25-2017, 02:05 PM
  2. Replies: 3
    Last Post: 11-04-2014, 09:35 AM
  3. Replies: 9
    Last Post: 10-29-2014, 08:51 AM
  4. WhatsApp Issue & Extras+Info Issue
    By grgcharan in forum Windows Phone 8.1
    Replies: 5
    Last Post: 10-24-2014, 06:40 AM
  5. Alarm Issue NL635
    By Z97E in forum Nokia Lumia 635
    Replies: 0
    Last Post: 10-20-2014, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD