1. sofj2167's Avatar
    I bought my nokia lumia 520 one month ago. Internet worked perfectly. For about 3 weeks now, my internet doesnt work properly:

    My browser (internet explorer) doesnt work, the store either, Im not able to send images in whatsapp, nor can I download them. I JUST CAN SEND AND RECEIVE TEXT MASSAGES WITH WHATSAPP.

    Ive got the same problem with normal Internet and Wifi. So Internet works, but my phone doesnt get it...

    Have anyone had a similar problem or does anyone know a solution? Thank you!!!
    11-16-2014 03:38 PM
  2. thatdennis's Avatar
    Well your best bet for a sureproof way is to backup your files, then reset your phone. Might be an OS bug.
  3. thatdennis's Avatar
    Well your best bet for a sureproof way is to backup your files, then reset your phone. Might be an OS bug.
    11-26-2014 02:09 AM
  4. WinampLlama's Avatar
    I had this problem when I was abroad and bought a local SIM card. Data worked fine for a while but then suddenly only whatsapp would send/receive messages and I couldn't pull up websites/facebook/etc. Turns out I ran out of data and when I added credit to my SIM account, all was back to normal
    12-10-2014 09:37 PM

Similar Threads

  1. Replies: 2
    Last Post: 11-27-2014, 10:14 AM
  2. When will SuperBeam app for Windows Phone be available?
    By rohitsars in forum Ask a Question
    Replies: 1
    Last Post: 11-26-2014, 01:36 AM
  3. Replies: 1
    Last Post: 11-26-2014, 01:13 AM
  4. Pole extender for Lumia 1020 w/ Camera Grip attached?
    By astroXP in forum Nokia Lumia 1020
    Replies: 0
    Last Post: 11-26-2014, 12:26 AM
LINK TO POST COPIED TO CLIPBOARD