1. lesterando's Avatar
    I tried the windows 10 on my 520 and it did not worked well , then I went to hard reset using " Windows Phone Recovery Tool " and my phone turned off while the restore was working, so I turned on the phone and the red appeared screen with " Nokia " and then the phone went off again ... So after this things , the phone stopped to turn on , and I already tried the Windows Phone Recovery Tool , the Lumia recovery tool software without success . Now the computer recognize the phone plugged on the USB " QHSUSB_DLOAD " ...

    If anyone have some tips to fix it , i will appreciate it , I have seen a lot of people with the same problem , but without any tips to fix , so please help!

    Thanks!
    04-13-2015 01:57 PM
  2. Abhishek Mullick's Avatar
    You will have to go to nokia care man. no other option. it happened with me some time back and they said some hardware problem causes this during recovery.
    Wattz Imchen8 likes this.
    04-13-2015 02:11 PM
  3. drushtant's Avatar
    I tried the windows 10 on my 520 and it did not worked well , then I went to hard reset using " Windows Phone Recovery Tool " and my phone turned off while the restore was working, so I turned on the phone and the red appeared screen with " Nokia " and then the phone went off again ... So after this things , the phone stopped to turn on , and I already tried the Windows Phone Recovery Tool , the Lumia recovery tool software without success . Now the computer recognize the phone plugged on the USB " QHSUSB_DLOAD " ...

    If anyone have some tips to fix it , i will appreciate it , I have seen a lot of people with the same problem , but without any tips to fix , so please help!

    Thanks!
    this helped me
    MyOwnSteps: [FIX] YOUR HARDBRICKED LUMIA PHONES [Only for QHSUSB_DLOAD lumia (black screen, no vibration)]
    05-24-2015 11:10 AM

Similar Threads

  1. Where to Get Lumia 1520 repaired?
    By Ian Legarda in forum Nokia Lumia 1520
    Replies: 22
    Last Post: 06-02-2015, 01:26 AM
  2. How do I transfer a pdf file from my Mac to my Lumia 435 via usb?
    By Windows Central Question in forum Microsoft Lumia 435
    Replies: 3
    Last Post: 04-27-2015, 09:11 PM
  3. Microsoft Band frequent disconnects after TP WP10
    By Rhoyz in forum Microsoft Band & Band 2
    Replies: 7
    Last Post: 04-16-2015, 10:31 AM
  4. GDR2 on Lumia 930 - can't get it -- Help!
    By Kimberly Dougherty in forum Windows Phone 8.1
    Replies: 4
    Last Post: 04-15-2015, 03:56 PM
  5. Lumia 530 app problem after resetting the phone..
    By guru don in forum Ask a Question
    Replies: 1
    Last Post: 04-13-2015, 03:28 PM
LINK TO POST COPIED TO CLIPBOARD