1. Windows Central Question's Avatar
    hi my lumia 520 is about a year old to me and was running well, until last night. last night my battery got low so i charged it without switching it off, after a few minutes i came back to check if its full charged... when i tried to press the power button it doesnt respond so i remove it from charging and i tried to open it but it only vibrates and show the "nokia" logo but it doesnt show the light blue screen with the windows logo on it and it goes black already!!! i tried everything i tried the hard reset and its just the same! it wont restart what should i do????!!! and a while ago i tried opening it again and it opened! when i opened it, it is in airplane mode so i go to settings to turn that off, when i was turning it off, the screen turns black again!! it wont restart what should i do????!!! help plsssss
    04-21-2015 06:35 AM
  2. gpobernardo's Avatar
    Welcome to Windows Central.

    It sounds like a battery problem, as a result either of "draining" or of overcharging the battery. Did you notice how much battery % it had when it turned on (before it died while you were trying to change the airplane mode)?

    You can take it to a service center and try to have the battery checked or replaced.

    You may need to create a Windows Central account in order to respond to this thread.
    Kate Dela Cruz likes this.
    04-21-2015 06:52 AM
  3. Kate Dela Cruz's Avatar
    when i saw it its still in 66%
    gpobernardo likes this.
    04-21-2015 07:38 AM
  4. Kate Dela Cruz's Avatar
    i just check it and when i opened it the "nokia" logo remains there it dosnt shut down already....
    04-21-2015 07:40 AM
  5. gpobernardo's Avatar
    The L520 has a removable battery - have you tried removing the battery for around 15 minutes, and then returning it?
    04-21-2015 08:29 AM
  6. Kate Dela Cruz's Avatar
    Yes id try it all day without putting back the battery
    04-21-2015 07:37 PM
  7. gpobernardo's Avatar
    How long have you waited for the Nokia logo to disappear after turning your phone on?

    Also, have you tried connecting your phone to your PC and let the Windows Phone Recovery Tool (or Lumia Software Recovery Tool) detect it? You might to re-install the OS if the problem still persists.
    04-22-2015 01:20 PM

Similar Threads

  1. Lumia 930 jingle while calling..
    By doggis85 in forum Nokia Lumia 930
    Replies: 1
    Last Post: 04-21-2015, 02:51 PM
  2. Shovel Knight is digging its way onto your Xbox One next week
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-21-2015, 04:50 AM
  3. Replies: 0
    Last Post: 04-21-2015, 04:38 AM
  4. Why do I have to reinstall drivers every time a new build is pushed?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 04-21-2015, 04:15 AM
LINK TO POST COPIED TO CLIPBOARD