1. WasteSomeTime's Avatar
    Hi. I have straight talk. The data is working. It can load websites, check the weather. For example weather flow checks for the weather. But most apps don't work on the data connection. I don't know why. I got the mms and internet apn setup.

    These are the apps that don't work or have not found to be working without a WiFi connection.

    Tell me MS service ( when searching the internet )
    Xbox live updates ( meaning updating achievements )
    Store - can't download apps.
    Outlook - can't retrieve email.
    Here maps - can't locate or load maps.
    YouTube doesn't work.
    WPcentral doesn't load anything.
    Some games like Texas holdem poker don't work either.

    But all websites load.

    Thanks in advance.
    08-19-2013 07:34 PM
  2. xandros9's Avatar
    Post-GDR2 right?

    I'll post back here soon because I think my sister might have something similar.
    08-19-2013 08:14 PM
  3. Corepc's Avatar
    How many apps do you have running in background?

    I gave up straight talk because of data issues in general. Somedays it would work fine, somedays it would not. Since switching to t-mobile not one signal data issue at all even at 2g speeds. Only lost data connection once due to network issue.
    08-19-2013 08:21 PM
  4. WasteSomeTime's Avatar
    5 apps. asphalt 7 heat, extras + info, weather flow, wpcentral and runtastic. I know 5 apps can't be the problem and I don't have a problem with the web pages loading slowly. They load fast.
    08-19-2013 09:13 PM
  5. Corepc's Avatar
    Extra and info is a background service for me. Not sure why. Asphalt 7 I always turn off. Wpcentral no problems. Runtastic I do not have.

    Have you powered on and off, tried turning cellular on and off.
    08-19-2013 09:24 PM
  6. WasteSomeTime's Avatar
    08-19-2013 11:03 PM
  7. WasteSomeTime's Avatar
    So does anyone have any ideas?
    08-21-2013 04:20 PM
  8. Corepc's Avatar
    APN are setup correct right under Access Point, and under Cellular What Network is selected ?

    Have you tried a soft reset yet holding down the volume down key and the power button. Keep holding until the phone reboots
    08-21-2013 04:28 PM
  9. WasteSomeTime's Avatar
    wp_ss_20130305_0001.pngwp_ss_20130305_0002.pngwp_ss_20130305_0003.pngwp_ss_20130305_0004.pngwp_ss_20130305_0005.pngwp_ss_20130821_0001.pngwp_ss_20130821_0002.png
    xandros9 likes this.
    08-21-2013 07:13 PM
  10. WasteSomeTime's Avatar
    Well this is what I have. Also here maps doesn't work however I download Gmaps from the MS store and that works fine.
    08-21-2013 07:14 PM
  11. Corepc's Avatar
    Try the alternate apn settings and see if that make a difference

    Name
    straight talk

    APN
    wap.tracfone

    Proxy
    216.155.165.40

    Port
    8080

    MMSC
    http://mms.tracfone.com

    MMS Proxy
    216.155.165.40

    MMS Port
    8080
    WasteSomeTime and xandros9 like this.
    08-21-2013 07:23 PM
  12. WasteSomeTime's Avatar
    Alright I will thanks.
    08-21-2013 08:04 PM
  13. Dustin Hodges's Avatar
    Click image for larger version. 

Name:	wp_ss_20130305_0001.png 
Views:	1 
Size:	49.2 KB 
ID:	40849Click image for larger version. 

Name:	wp_ss_20130305_0002.png 
Views:	2 
Size:	43.2 KB 
ID:	40850Click image for larger version. 

Name:	wp_ss_20130305_0003.png 
Views:	1 
Size:	37.6 KB 
ID:	40851Click image for larger version. 

Name:	wp_ss_20130305_0004.png 
Views:	1 
Size:	41.5 KB 
ID:	40852Click image for larger version. 

Name:	wp_ss_20130305_0005.png 
Views:	1 
Size:	39.9 KB 
ID:	40853Click image for larger version. 

Name:	wp_ss_20130821_0001.png 
Views:	1 
Size:	41.6 KB 
ID:	40854Click image for larger version. 

Name:	wp_ss_20130821_0002.png 
Views:	1 
Size:	61.1 KB 
ID:	40855
    I think I see the problem. According to Straight Talk's BYOD Settings Page for TMobile Phones, the proxy address (for data and mms) and port (for mms, not data) is supposed to be blank for smart phones, while yours has "wap.tracfone" and "8080".

    Field Smartphone Other Phones
    APN Name straight talk straight talk
    APN wap.tracfone wap.tracfone
    proxy Leave Blank 216.155.165.40
    Port 8080 8080
    MMSC http://mms.tracfone.com http://mms.tracfone.com
    MMS Proxy Leave Blank 216.155.165.40
    MMS Port Leave Blank 8080
    08-21-2013 08:58 PM
  14. WasteSomeTime's Avatar
    wp_ss_20130822_0003.pngwp_ss_20130822_0004.png

    This is what happens when I try to delete the fields your talking about. I tried to leave them blank before but the phone wouldn't allow me too. The check mark at the bottom becomes grayed out and it tells me I have to put something for the high lighted fields. I tried to put the word " blank " and 8080 but them the internet through IE stops.
    08-22-2013 04:54 PM
  15. WasteSomeTime's Avatar
    Try the alternate apn settings and see if that make a difference

    Name
    straight talk

    APN
    wap.tracfone

    Proxy
    216.155.165.40

    Port
    8080

    MMSC
    http://mms.tracfone.com

    MMS Proxy
    216.155.165.40

    MMS Port
    8080
    Thank you these settings have worked. I called ST and apparently the straight talk network does not recognize the Lumia 521 as a smartphone. In any case. Thanks for the settings. So far the email works which is the main thing really.
    08-22-2013 05:40 PM
  16. blegs38552's Avatar
    'lI have a similar problem. Battery app sbows Wifi as turned off even though settings show wifi as turned on. Also, PC Remote app shows wiii as turned off when I try to connect to a computer on my network. This problem appears to have started ater my upgrade to GDR_2.
    08-22-2013 07:50 PM
  17. Corepc's Avatar
    'lI have a similar problem. Battery app sbows Wifi as turned off even though settings show wifi as turned on. Also, PC Remote app shows wiii as turned off when I try to connect to a computer on my network. This problem appears to have started ater my upgrade to GDR_2.
    Sounds like you have different issues.

    I do not use PC Remote, Try out SplashTop Streamer (grab it while it free) nice Pc remote app.

    Battery App's I just recently started using Insider
    08-22-2013 09:25 PM
  18. Corepc's Avatar
    Thank you these settings have worked. I called ST and apparently the straight talk network does not recognize the Lumia 521 as a smartphone. In any case. Thanks for the settings. So far the email works which is the main thing really.
    Glad those worked, some people have problem with getting Windows Phone to work on Net10/StraightTalk since they switched to using T-Mobile, but, they are selling at&t sim once again.
    Still no switching, I like my pc tethering.
    08-22-2013 09:35 PM
  19. WasteSomeTime's Avatar
    Well when I had the at&t sim I barely had any service so I don't care much about that. Also thanks to Dustin and others that commented.
    08-22-2013 10:10 PM
  20. WasteSomeTime's Avatar
    'lI have a similar problem. Battery app sbows Wifi as turned off even though settings show wifi as turned on. Also, PC Remote app shows wiii as turned off when I try to connect to a computer on my network. This problem appears to have started ater my upgrade to GDR_2.
    I didn't get that update yet.
    08-22-2013 10:11 PM

Similar Threads

  1. [APP] Then & Now (beta)
    By Jayson Ragasa in forum App Spotlight
    Replies: 13
    Last Post: 02-01-2014, 11:13 AM
  2. 199 surface rt and apps
    By donebrasko in forum Microsoft Surface for Windows RT
    Replies: 10
    Last Post: 08-22-2013, 09:38 PM
  3. Looking for Around Me App that's better.....
    By cristianocr7 in forum Nokia Lumia 928
    Replies: 2
    Last Post: 08-19-2013, 08:17 PM
  4. Replies: 1
    Last Post: 08-19-2013, 07:30 PM
  5. YouTube new app not working
    By mark nt in forum Applications
    Replies: 3
    Last Post: 08-19-2013, 04:43 PM
LINK TO POST COPIED TO CLIPBOARD