1. MikeSo's Avatar
    I've had my 521 for about 3 months now, with no issues. I finally bought an SD card a few days ago (Lexar class 6 16 GB). I use it for music storage only. It worked fine for a few days.

    Today, it started giving messages that my SD card is ejected. When I reboot the phone, it shows (in the storage section in settings) that it's there, but as soon as I try and play music, it gives the error and no longer shows up anywhere. Anyone else have issues, or should I get a new card?
    09-05-2013 12:40 AM
  2. DBDev's Avatar
    Have you tried if the card works in a computer or another phone?
    09-05-2013 03:35 PM
  3. MikeSo's Avatar
    Unfortunately I don't have any other device that can read micro SD cards.
    09-05-2013 05:44 PM
  4. DBDev's Avatar
    I think that it sounds most like it's a problem with your SD card, but I'm not sure.
    09-06-2013 12:51 AM
  5. MikeSo's Avatar
    After browsing the interwebs, I would say that's the most likely explanation too. Didn't find too many people having this issue, at least not enough to suspect that it's a problem with the phone or WP8. Hoping the store will exchange the card.
    09-06-2013 10:14 AM
  6. Smyrna5's Avatar
    Anytime I boot my phone it tells me that its having trouble with my SD card. Its an old 8G card from my Blackberry. Funny thing is once it tells me that, it reads and writes to the card fine. In another thread others were having the same problem, so I think these Lumias are very picky about SD cards.
    09-07-2013 12:58 PM
  7. MsBuzzman's Avatar
    I have had a bad sd card before. So that' not unusual. Mine was a cheap $5 card though. If you have receipts, return the card and get it replaced. It's always helpful to have an sd full size adapter so a computer can read the micro sd card. They are cheap, and sometimes comes with the smaller cheaper sd cards.
    09-07-2013 05:28 PM
  8. MikeSo's Avatar
    Thanks for the input.

    I borrowed a USB adapter, and have connected it to the computer without any issue. All the data is still on the micro SD card, and it works with no problems in the PC (Windows 7).
    So maybe it's not a problem with the card, but with how it functions in the phone, maybe it's picky. I wonder why it worked fine for several days though.

    I'm going to wipe it out and reformat it, and see if that allows it to be used again.
    09-09-2013 12:10 PM
  9. DBDev's Avatar
    Thanks for the input.

    I borrowed a USB adapter, and have connected it to the computer without any issue. All the data is still on the micro SD card, and it works with no problems in the PC (Windows 7).
    So maybe it's not a problem with the card, but with how it functions in the phone, maybe it's picky. I wonder why it worked fine for several days though.

    I'm going to wipe it out and reformat it, and see if that allows it to be used again.
    Well, then it seems more like you have a problem with your phone. If it doesn't help to format it, you could try a hard reset, but it will delete all your data on your phone. If that doesn't help it's probably a hardware issue.
    09-09-2013 01:14 PM
  10. MikeSo's Avatar
    I did wipe and format the card, inserted it into the phone, and then formatted it again using the phone. I copied a bunch of music files back onto it, and it's working again so far (knock on wood).

    I don't remember that I actually formatted the card before use (though I might have) so maybe it's a possibility that it was caused by that. Either way, I will use it and see how it goes now. :)
    09-09-2013 02:58 PM
  11. MsBuzzman's Avatar
    I did wipe and format the card, inserted it into the phone, and then formatted it again using the phone. I copied a bunch of music files back onto it, and it's working again so far (knock on wood).

    I don't remember that I actually formatted the card before use (though I might have) so maybe it's a possibility that it was caused by that. Either way, I will use it and see how it goes now. :)
    Glad you got it working. Also was gonna suggest to format in the phone, but you had the foresight to do that! Good job there. Sometimes that makes the difference. You should be good to go now! :)

    I haven't put music on my sd card yet. Do you just put on your mp3 files? Loose, or in folders (within the main music folder of course!)? and how does it sound? Thanks.
    09-09-2013 03:30 PM
  12. Jeremiah Druiz's Avatar
    I have the same problem. Everytime I turn my phone on there's a message saying that there's a problem with the SD card, I've formatted and everything and it seems to work fine for a few days when the message is back again!! Plus, my phone turns off and on and doesn't charge!! :( I just hate Windows Phones :( or is it that I'm the only one having so many problems with my phone?
    03-17-2014 01:39 AM
  13. Francis Ellis's Avatar
    I too get a message after rebooting. That states I have a SD problem, please test in your computer. But yet the phone and SD card show no problems.
    02-08-2015 06:46 AM

Similar Threads

  1. Replies: 9
    Last Post: 09-10-2013, 10:48 AM
  2. Lost WiFi Calling With T-Mobile GDR2 Update
    By Eric J F in forum HTC 8X
    Replies: 5
    Last Post: 09-06-2013, 09:03 PM
  3. store not showing updates
    By Mohd Fadil A in forum Nokia Lumia 620
    Replies: 1
    Last Post: 09-05-2013, 01:27 AM
  4. Replies: 2
    Last Post: 09-04-2013, 07:11 PM
LINK TO POST COPIED TO CLIPBOARD