1. thepolicecall911fordetails's Avatar
    Hi Guys,
    I am having a speed/performance problem with my Nokia Lumia 521. I thought it was because of the developer's preview for 8.1, but after the recent tmobile update to the official version of 8.1 for tmobile and cyan, there has been no real improvement. The phone constantly lags on start up and in use. Examples, Cortana takes 10 seconds to load and sometimes crashes when loading it after the start up for the first time, multitasking via back button lags terribly, SD card apps take 2 minutes to load on start-up, scrolling down the start screen lags the live tiles, camera takes 20 seconds to load and lags considerably when taking a picture, lock screen lags, waking the phone lags, gameplay is lags a bit, etc. I don't know what the problem exactly and my phone with 8 was working way faster than it is now. It's getting slower by the day. Any ideas? I am really disliking my phone currently.

    521 user
    11-08-2014 02:31 AM
  2. HoosierDaddy's Avatar
    Don't have any of those problems with the 521 I loan to people to try Windows. Its between loans so I tried all those except loading an app from the SD card since I don't pre-load apps for people to the card since apps will always load faster from phone storage than SD. I would only put apps there when phone storage was used up. The phone was purchased the 1st day the 521 was available. It was on DP for a long time and now on Cyan WP 8.1 from T-Mobile.

    Anyway, as I said none of those problems. For example it takes 2 seconds from camera button push to ready to snap a picture.

    I would do a hard reset to see if that fixes things.
    11-08-2014 08:27 AM
  3. mj0's Avatar
    It might be the SD card. I've had some serious trouble with MixRadio after I'd moved it to the SD card. More often than not it took two to three minutes for it to start and even more often than that it crashed during startup. Have you moved all of your apps to your SD card? If so try moving them back to your phone's internal storage, safely remove the SD card and see if the problem persists.
    11-09-2014 06:23 AM
  4. wuiyang's Avatar
    your SD card level is low, buy at least level 7
    11-09-2014 09:10 AM
  5. thepolicecall911fordetails's Avatar
    I have a level 4 on it...
    11-09-2014 06:40 PM
  6. ians18's Avatar
    Remember, the 521 is the lowest end WP with only 512MB of RAM. Cortana is resource heavy so...
    11-09-2014 06:52 PM
  7. mj0's Avatar
    I have a 635 with 512MB of RAM and Cortana takes somewhere between 1-3s to load and wait for my commands. 10s is definitely too long.
    ML10 likes this.
    11-10-2014 01:55 AM
  8. thepolicecall911fordetails's Avatar
    your SD card level is low, buy at least level 7
    I got a class 10 recently for my phone...IT STILL LAGS?!?!!
    12-13-2014 10:47 PM
  9. Visa Declined's Avatar
    I got a class 10 recently for my phone...IT STILL LAGS?!?!!
    Factory reset it. My little 520 has 8.1 with Cyan, and it has absolutely zero problems.
    12-14-2014 12:55 AM
  10. thepolicecall911fordetails's Avatar
    Factory reset it. My little 520 has 8.1 with Cyan, and it has absolutely zero problems.
    That's the problem. My friend's 520 doesn't lag but apparently only the 521's are experiencing this problem...
    12-14-2014 04:01 PM
  11. jimh12345's Avatar
    8.1 on my 521 is like death warmed over - without the 'warmed over' part. Endless "loading..." and "resuming...". Touch something, nothing happens, wait a while, touch again, wait a while. Today while talking to someone I tried to pull up my calendar and let's just say he did not get a very favorable impression of Windows Phone as we stood there waiting. And forget all about Cortana - I don't have time.
    12-22-2014 05:06 PM
  12. Eric J F's Avatar
    We had lots of hanging and crashing issues early on and I tried everything with no improvement, until I took out the SD card. Now it works great even with 8.1.
    Guytronic likes this.
    12-23-2014 08:29 PM

Similar Threads

  1. Lumia 735 at Expansys... anyone use it on LTE in the US?
    By onlysublime in forum Nokia Lumia 730 & 735
    Replies: 37
    Last Post: 12-28-2014, 02:31 PM
  2. Replies: 4
    Last Post: 11-08-2014, 10:24 PM
  3. Why can't I edit the ip address in Nokia Lumia 630 dual SIM?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-08-2014, 02:43 AM
  4. Replies: 3
    Last Post: 11-08-2014, 01:49 AM
  5. Alleged Lumia 535 with Microsoft branding leaked in China
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-08-2014, 01:00 AM
LINK TO POST COPIED TO CLIPBOARD