1. Xaxinian's Avatar
    My issue is two-fold. One is I believe since the update, I cannot connect phone to PC. It will charge the phone, but no data. I tried this on my PC and Laptop running 7 and 8 respectively with the same result, Only charges, cant explore phone at all.

    I have the dev preview installed prior to the new version being released for the T-Mobile 521. Can anyone confirm I am up to date? If not I may have to reset the phone because it is telling me my phone is up to date. Below are the Version numbers. Any help would be appreciated.

    OS Version: 8.10.12382.878
    Firmware Version 3056.40000.1404.0034 (Note when I look online it shows 4000 instead of 40000 on my phone.

    Thanks in advance.
    11-30-2014 03:19 PM
  2. mathsisbest's Avatar
    Sometimes try blowing the dust off the usb port. Try all usb ports. For me it sometimes takes time for pc to recognise phone. Also make sure when you connect it to use your phone. If you use it, it fastens the process (in my experience)
    Guytronic likes this.
    11-30-2014 03:42 PM
  3. Dneil46's Avatar
    Same issue here. Have a 521 and just got a brand new Dell with Windows 8.1. Downloaded the app for the PC to connect to my phone but it just sits there on the screen telling me to connect my phone. Phone is charging, both phone and computer chime to indicate their connected, but doesn't initiate any features to explore my phones files. Tried my wife's phone, which is not updated to Windows 8.1 and it sees it just fine. Very frustrated with this. Have you had any success with resolving this?
    01-06-2015 06:16 PM
  4. realwarder's Avatar
    Assuming that it is not locked with PIN?

    Try a different cable?
    01-06-2015 06:41 PM
  5. rhapdog's Avatar
    After I did a phone update, my phone suddenly had a new "USB" section under Settings. In it, you can check to have it ask you if you want to use the USB as a data connection. If I don't answer the prompt quickly enough, I don't get to use it as a data connection. If I uncheck the box, then it will automatically use it as data connection.

    Check the setting to see if you're needing to do something when plugging in the cable. Can't hurt to look. May not help, but if the phone is getting a charge, it is properly connected. This is the most likely culprit that I can think of at the moment.
    01-06-2015 07:33 PM
  6. ntice_521's Avatar
    As far as I know, it's a bug in WP8.1.
    01-21-2015 02:06 PM

Similar Threads

  1. T-Mobile Sales Rep Calls Windows Phone the worst Phone ever
    By indkal in forum Carrier Discussion Lounge
    Replies: 56
    Last Post: 04-08-2015, 08:05 PM
  2. What Windows phone offers all of the features I want?
    By dharma teja1 in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 12-05-2014, 11:12 PM
  3. Windows Phone on track of LAGGINESS ????
    By lamblumo in forum Windows Phone 8.1
    Replies: 18
    Last Post: 12-02-2014, 07:39 PM
  4. Flightradar24 Free now available for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-30-2014, 12:11 PM
  5. Replies: 1
    Last Post: 11-30-2014, 11:19 AM
LINK TO POST COPIED TO CLIPBOARD