1. Dneil46's Avatar
    I've got a Lumia 521 that was recently (about a month or so ago) updated to 8.1. For Christmas we got a brand new Dell Inspiron 20 running 8.1 with the touchscreen. I was excited to plug my phone into it and see how it worked with file management and syncing but they won't talk at all. I downloaded the Windows Phone app for the computer and when I launch it, it tells me to plug in my phone. I plug it in via USB and both phone and computer chime to indicate they're connected, the phone will start charging, but that's it. No progress after that. When I look in the file explorer it doesn't show it as a drive or anything. Tried it with my son's phone, which is also a 521 running 8.1 and same result. Tried it with my wife's Nokia Lumia 810, not updated to 8.1, but running 8.0...and it launched right into it. She was able to use the app to explore and transfer files.
    Why won't the 521 work? Anyone else experiencing issues with this. Here's the specs for my phone:

    Nokia Lumia 521
    OS version 8.10.12400.899
    Firmware revision number: 3058.50000.1439.0042
    01-06-2015 06:33 PM
  2. ven07's Avatar
    Try connecting to a laptop running W7.. But I think we've already established that the problem is the laptop running 8.1 isn't reading your 8.1 phone.

    Did you try removing the dev prev app and checking?

    If that doesn't help I would say jump online and search for drivers for your phone and install them on the laptop
    Dneil46 likes this.
    01-06-2015 06:41 PM
  3. Corepc's Avatar
    It takes a while sometimes for my win7 PC to see my 521 with official 8.1 not dev.

    Did you try different ports and USB cables?
    ven07 and Dneil46 like this.
    01-06-2015 06:46 PM
  4. ven07's Avatar
    Did you try different ports and USB cables
    Good point! A user on a different thread (can't remember the name) did try a different cable and that worked
    01-06-2015 06:50 PM
  5. Dneil46's Avatar
    I never installed the dev prev app. I waited for the official release. Haven't tried plugging it into a Windows 7 machine yet. Don't have any around. You've given me an idea though... I haven't tried plugging it into one of the other Windows 8.1 machines in my house. My wife has a tablet and my daughter has a computer from school that's 8.1. Might try those and see if the app works. That would narrow it down to whether the issue is with the phone or this computer. Will look for updates to the computer too.
    ven07 likes this.
    01-06-2015 07:33 PM
  6. Dneil46's Avatar
    Just tried with a different USB cable but no luck.
    01-06-2015 07:33 PM
  7. ven07's Avatar
    Will look for updates to the computer too
    Don't think those updates will help.. I had some problems with my 925 on cyan.. had to go online and manually search for drivers for my 925
    Dneil46 likes this.
    01-06-2015 07:36 PM
  8. Dneil46's Avatar
    Tried connecting both my mine and my son's 521's to a Samsung ATIV tablet running 8.1 via USB, same app, and got the same results. Will not connect with either, but my wife's 8.0 Lumia 810 connected right up. So it's something to so with just the 521.
    So you're saying look for Lumia 521 drivers for the computer? Or do you mean download drivers to my phone? Not sure how to dl drivers to the phone.
    ven07 likes this.
    01-06-2015 11:56 PM
  9. Dneil46's Avatar
    so I tried connecting both my son's and my 521 to my wife's Samsun ATIV tablet that is running 8.1 and same results...neither would connect. But my wife's Lumia 810 running 8.0 connects no problem. So it's definitely something with just the 521's.
    So you're saying to download Lumia 521 drivers for the computer? Or do you me download drivers to the phones? Not sure how to dl drivers to the phones. If you mean for the computer...any suggested sites. I'll try googling it too. Thanks.
    ven07 likes this.
    01-07-2015 12:01 AM
  10. ven07's Avatar
    Not to the phone :p Sorry should have been clearer I guess. A simple search via Google will get you the right results. I would have to check my browser history to give you the precise link, but as you can imagine, that would require a lot of scrolling lol
    01-07-2015 01:45 PM
  11. ntice_521's Avatar
    I've had this problem since WP8.1. WP8.0 always connected.
    01-21-2015 02:00 PM
  12. ColbyJvonBrown's Avatar
    so I tried connecting both my son's and my 521 to my wife's Samsun ATIV tablet that is running 8.1 and same results...neither would connect. But my wife's Lumia 810 running 8.0 connects no problem. So it's definitely something with just the 521's.
    So you're saying to download Lumia 521 drivers for the computer? Or do you me download drivers to the phones? Not sure how to dl drivers to the phones. If you mean for the computer...any suggested sites. I'll try googling it too. Thanks.
    OK so to everyone in this thread this is a issue on all devices running 8.1, but it may show up on someone else's lumia device but not the other person's lumia device. Basically the new 8.1 is on your phone doesn't act the same as the previous 8.0 os. For some reinstalling the drivers work, but for others go into add devices section and look for windows phone and delete it or unknown mtp device and reattach your phone. Then click refresh to find the device again and update the connection to the windows phone device if recognized, or update the connection for the unknown mtp device. Then make sure you windows phone desktop app is up to date and your phone has the latest firmware. You can check in setting on updates to see if you do or try the Nokia software recovery tool and it should show you too? And here's a link to some more things you can try to fix it if what I suggested doesn't work. I really hope this issue is addressed and resolved in windows phone 10 os and windows 10 for the pc!!!! http://support.microsoft.com/kb/2749484

    Posted via the Windows Central App for Android
    01-31-2015 11:22 PM

Similar Threads

  1. Lumia 1530 with windows 10
    By sosan in forum General Phone Discussion
    Replies: 65
    Last Post: 01-13-2015, 05:22 PM
  2. OneDrive sync to my phone glitch
    By Mr Lebowski in forum Nokia Lumia 830
    Replies: 19
    Last Post: 01-09-2015, 05:17 PM
  3. A brick works better than my Lumia 635...
    By rhapdog in forum The "Off Topic" Lounge
    Replies: 28
    Last Post: 01-08-2015, 07:47 PM
  4. Will the New XPS 15 from Dell offer the 1 terabyte solid state drive?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-06-2015, 07:04 PM
  5. How do I program my Windows screen to go off after 2 minutes?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2015, 06:45 PM
LINK TO POST COPIED TO CLIPBOARD