1. Artur Aye's Avatar
    Hi, I have Lumia 610, I like phone & what it has but for some reason I have many problems searching internet.
    Beginning with:

    --- WiFi - My internet speed is 12-15 mb but when I taste wifi/internet speed on Lumia 610 (with QIP Speed Test) results are 1-3mb (sometimes 5). I though its routers problem but I have laptop & he has 12-15mb like my PC. I tasted in other places & I have same slow speed.

    --- YouTube - 1st Problem: I downloaded apps like "Metrotube" or "YouTube HD" in order to watch videos in HD resolution. What happens is next, with those apps I can watch only videos in 360p because in 720p resolution, video & sound are not synchronized, if sound is in (time) 12:45 then video is, always behind, in 12:38. Also searching things via those apps also is slow.

    --- YouTube - 2nd Problem: When I go to YouTube normally, via Internet Explorer or Bing, its a PAIN, what happens is next: I go to YouTube, I write something to search (for example: Rob Dougan), if I click on "Enter" button (last button) then, instead of searching it always delete what was written & never seeks so I always must click on loupe/magnifier bottom to have what I want. After that another thing happens, I write something "mgs" & I click on loupe, ok I have results that fine but if I click (after that) again something new to search or even same thing then it will always bring me to home page (reloading page doesn't help ether), this happens every time when I search for the second time something, watched video or not it goes to YouTube homepage. In other words: I write-> search-> got results-> write again-> I don't have results, instead of this I've been taken to home page -> I must write again in order to have what I need-> search-> got results -> write again-> I dont have results, instead of... always searches something only form homepage.

    --- 3rd Problem: in this phone, WP never goes in right order to back/last opened pages in internet, for example, I'm on 5th page (I passed through google, site, then some link...) & when I click to go back, it takes me sometimes to 3rd page, sometimes instantly to initial page (google), or sometimes to 2nd page, not always but mostly it goes randomly.

    PLEASE what I should do? I searched in google those problems but I didn't find any solution. If you want me to record video where I show all those problems then I can do that. Im not English, so sorry for possible mistakes in text. (WP is updated, switching off & on phone or "plane mod" doesn't help ether)
    12-15-2013 12:19 PM

Similar Threads

  1. Why does my Nokia Lumia 520 restart itself, or power off?
    By Jan Dacion in forum Nokia Lumia 520
    Replies: 9
    Last Post: 05-31-2014, 07:17 AM
  2. We want 3 Columns in Lumia 820
    By geoghotas in forum Nokia Lumia 820
    Replies: 17
    Last Post: 12-17-2013, 12:39 AM
  3. Lumia as MP3 player
    By kc77 in forum Microsoft News & Rumors
    Replies: 8
    Last Post: 12-16-2013, 12:10 AM
  4. Trouble when I connect my lumia 620 in the computer
    By JoselitoJunio in forum Nokia Lumia 620
    Replies: 0
    Last Post: 12-15-2013, 10:12 AM
  5. Saxowebtrader/Internet Exporer
    By SundayEveryDay in forum Nokia Lumia 1020
    Replies: 2
    Last Post: 12-15-2013, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD