06-17-2015 08:39 PM
26 12
tools
  1. gr0ber's Avatar
    I recently purchased a Lumia 620 unlocked for my wife. Problem is as follows:
    When connected to WIFI, internet works fine, however cannot add Facebook account, message is that there is no connection and to try again.

    Once I turn off WIFI, I notice the phone connects to 3G data and it successfully adds the Facebook account and syncs. People app and facebook app all work correctly.

    Once added, whenever I turn on WIFI I am again unable to see any Facebook updates through people app or even facebook app. It just refuses to connect.

    Can anyone help with this issue? It's damn frustrating.
    05-02-2013 06:27 PM
  2. Man Kit Ching's Avatar
    I have exactly the same problem with my 920. I have also asked around on xda forum but with no help. Which wireless router are you using?
    05-02-2013 06:49 PM
  3. Dazzi's Avatar
    I recently purchased a Lumia 620 unlocked for my wife. Problem is as follows:
    When connected to WIFI, internet works fine, however cannot add Facebook account, message is that there is no connection and to try again.

    Once I turn off WIFI, I notice the phone connects to 3G data and it successfully adds the Facebook account and syncs. People app and facebook app all work correctly.

    Once added, whenever I turn on WIFI I am again unable to see any Facebook updates through people app or even facebook app. It just refuses to connect.

    Can anyone help with this issue? It's damn frustrating.
    I'm a bit confused here -- do you mean, you can not add you Facebook account to your phone in the settings?
    05-02-2013 07:22 PM
  4. pbroy's Avatar
    Might be a router problem. Try going to some other place with WiFi and see if it still occurs.
    05-02-2013 07:26 PM
  5. gr0ber's Avatar
    I'm a bit confused here -- do you mean, you can not add you Facebook account to your phone in the settings?
    Thanks for replying Dazzi. Correct, I cannot add my facebook account to my phone in the settings successfully UNLESS I am not connected to any wifi networks and I use 3G data.
    05-02-2013 07:27 PM
  6. gr0ber's Avatar
    Might be a router problem. Try going to some other place with WiFi and see if it still occurs.
    Thanks for replying pbroy. Definitely a good idea to try, problem is my windows phone 7.8 has never had this problem on same router, nor has my wife's previous windows phone 7.8.
    05-02-2013 07:28 PM
  7. gr0ber's Avatar
    I have exactly the same problem with my 920. I have also asked around on xda forum but with no help. Which wireless router are you using?
    Hi Man Kit Ching. I'm using Linksys E3000. However, my phone (windows 7.8) and my wife's previous phone (windows 7.8) both work flawlessly on this router.
    05-02-2013 07:29 PM
  8. Dazzi's Avatar
    Thanks for replying Dazzi. Correct, I cannot add my facebook account to my phone in the settings successfully UNLESS I am not connected to any wifi networks and I use 3G data.
    No worries mate -- So you are having to add your Facebook account in the settings everytime you are on 3G?
    05-02-2013 07:54 PM
  9. gr0ber's Avatar
    No worries mate -- So you are having to add your Facebook account in the settings everytime you are on 3G?
    No. Once I have added the Facebook account and successfully synchronized using 3G, the account will stay. However, once the phone connects to WIFI Facebook is unable to sync and won't update at all. Facebook will ONLY work via 3G, never via WIFI. Hope that clears it up.
    05-02-2013 11:58 PM
  10. Man Kit Ching's Avatar
    I'm using a Linksys router too. It seems their router doesn't play well with Lumia...
    05-03-2013 05:58 AM
  11. Dazzi's Avatar
    No. Once I have added the Facebook account and successfully synchronized using 3G, the account will stay. However, once the phone connects to WIFI Facebook is unable to sync and won't update at all. Facebook will ONLY work via 3G, never via WIFI. Hope that clears it up.
    Try searching for a phone update. If that doesn't work, then backup your phone, and try resetting it -- if nothing works then take it back to your retailer, as it shouldn't be doing that. I hope you get it sorted, good luck.
    05-03-2013 06:37 AM
  12. Thomas_kc's Avatar
    I have the exact same problem on my 1 day old Lumia 620! everyone works, facebook too (and the new facebook beta app) when on 3G ! as soon as i turn on my wifi! BOOM facebook totally dies, can't get any data. The rest works fine, twitter, internet etc no problems! but facebook is totally dead, and I mean totally.. website, app everything.

    I have 3 laptops, an Iphone and an Ipad on the same wireless network and there is no problems. There is something seriously going wrong on the phone.
    05-03-2013 08:38 AM
  13. Dazzi's Avatar
    I have the exact same problem on my 1 day old Lumia 620! everyone works, facebook too (and the new facebook beta app) when on 3G ! as soon as i turn on my wifi! BOOM facebook totally dies, can't get any data. The rest works fine, twitter, internet etc no problems! but facebook is totally dead, and I mean totally.. website, app everything.

    I have 3 laptops, an Iphone and an Ipad on the same wireless network and there is no problems. There is something seriously going wrong on the phone.
    When you turn Wifi on is 3g still on at the same time?
    05-03-2013 08:46 AM
  14. Thomas_kc's Avatar
    You never turn 3g off? wifi naturally overtakes all data.
    05-03-2013 08:48 AM
  15. Dazzi's Avatar
    You never turn 3g off? wifi naturally overtakes all data.
    Why not try and see if your problem stops if you turn 3g off, it could be a bug -- I'm only trying to help
    05-03-2013 03:10 PM
  16. Thomas_kc's Avatar
    Ah don't get me wrong trial and error is all we can, and I actually did try it right away.

    The reason for my reply is just it would no sense since everything else works. It is literally only facebook that has this issue when on Wifi.

    And yeah 2G + wifi fb still won't work.

    Not sure what to do about it.

    EDIT: Sort of found a solution!!

    Turns out that the lumia 620 really does not like my apple Airport Extreme! I tried to setup my old old Dynalink router + wifi instead and tadaaa!! facebook works on wifi now. really not good... but at least it's narrowed down.
    Last edited by Thomas_kc; 05-04-2013 at 03:39 AM.
    05-03-2013 10:12 PM
  17. Dazzi's Avatar
    Glad you got it sorted mate
    05-04-2013 04:52 AM
  18. pbroy's Avatar
    Another thing to try is to see if a new firmware is out that may fix the WiFi issue. Use Nokia Software Updater for Retail to check. If firmware doesn't fix it, your router is most likely at fault. Try going through router settings to see if there are any conflicts or just get another router.
    05-04-2013 07:27 AM
  19. gr0ber's Avatar
    EDIT: Sort of found a solution!!

    Turns out that the lumia 620 really does not like my apple Airport Extreme! I tried to setup my old old Dynalink router + wifi instead and tadaaa!! facebook works on wifi now. really not good... but at least it's narrowed down.
    Very interesting! Am yet to find the time to sit down and test this myself, but gives me hope.
    05-05-2013 05:51 PM
  20. simi_id's Avatar
    Hello,

    I have same issues with a Lumia 925 and a Belkin N+ Enhanced router.
    While I can connect to all accounts on wi-fi: gmail, linked, microsoft, etc ... I can't connect to facebook account, it says no connection.
    If I stop wi-fi connection, on 3G it works to set-up the facebook account.
    What might cause this issue ? Is there a solution ?

    Thanks
    11-17-2013 04:22 AM
  21. Levi Soha's Avatar
    Hello,

    I have the same problem on my Lumia 920. Connected to Linksys E3000 Facebook wont run. I've connected a Wireless TP-Link router wired to the Linksys E3000. After that I am able to reach Facebook while connected to my wireless TP-Link router. It's weird that it wont work with the E3000. Don't know what issue it could be.
    03-16-2014 07:35 AM
  22. jashwink's Avatar
    I solved this issue by selecting proxy in Linksys wifi router setting.
    06-28-2014 01:53 PM
  23. Armoogum Teeven's Avatar
    actually i have the same probleme i cant get acess to facebook n wifi when using wifi...am using an htc desire 616 can anyone help me?
    12-12-2014 11:56 AM
  24. prasath1234's Avatar
    For me it is opposite only connects on WiFi not 3g so I use Facebook metro app.it is good
    12-12-2014 12:12 PM
  25. 1rg's Avatar
    *Sorry for major bump-no other forums seem to have a thread of this*
    I have this problem its rather annoying and i end up using all my 3g up...
    This happens to me on Game Apps on my IPhone and laptop[pertically certain ones i.e clash of clans etc but java ones work](allowed via 3g but not wifi) yets on everyone elses phones/laptops etc it works fine but isnt working on mine ive reset router but didnt do anything unfortuanately any other suggestions??
    Thanks inadvance
    01-07-2015 10:54 AM
26 12

Similar Threads

  1. Lumia 820 - only able to connect to Internet via wifi
    By wake6 in forum Windows Phone 8
    Replies: 11
    Last Post: 08-01-2013, 03:50 AM
  2. Replies: 6
    Last Post: 07-03-2012, 03:04 PM
  3. Replies: 2
    Last Post: 04-17-2012, 10:10 PM
  4. Problem connecting to Marketplace through WiFi...
    By roffleswaffles in forum Windows Phone 7
    Replies: 0
    Last Post: 01-17-2012, 08:09 PM
  5. Windows Phone cannot connect to some WiFi networks
    By neiltc13 in forum Windows Phone 7
    Replies: 5
    Last Post: 05-21-2011, 10:25 AM
LINK TO POST COPIED TO CLIPBOARD