1. rockinguy's Avatar
    Whenever i try to flash my Nokia Lumia 620 (product code 059N7C6) i get an error as soon it starts to flash the phone . I have tried to flash with rom with other product codes as i cannot find any rom with this product code , but everytime i get the same error saying " Signature of FFU files failed " I have attached the pic of the same. please help as i cannot update my phone.
    Attached Thumbnails screenshot.jpg  
    08-14-2013 03:42 AM
  2. Zac Nguyen's Avatar
    I think the promble cause is the name of the FFU file... Are you sure it's name starts with RM846? Have you change any character in this file-name?
    08-14-2013 06:06 AM
  3. Jawwad Ahmed's Avatar
    try packge given in this thread...
    HERE
    08-14-2013 07:00 AM
  4. rockinguy's Avatar
    I think the promble cause is the name of the FFU file... Are you sure it's name starts with RM846? Have you change any character in this file-name?
    I have checked the file and da name starts with RM 846 only..also i havent changed any character..the problem is common with all the packages that i have downloaded..so i dont think this is the reason..
    08-14-2013 09:09 AM
  5. rockinguy's Avatar
    try packge given in this thread...
    HERE
    Hey tried with the package...got the same result...any other solution..???
    08-15-2013 05:52 AM
  6. Jawwad Ahmed's Avatar
    Hey tried with the package...got the same result...any other solution..???
    then its problem with ur care suite..check given version here..
    HERE
    08-15-2013 08:51 AM

Similar Threads

  1. Replies: 5
    Last Post: 04-26-2014, 12:30 PM
  2. why the contact picture does not show up while talking?
    By dfeghali in forum Windows Phone 8
    Replies: 2
    Last Post: 08-17-2013, 02:50 AM
  3. manually flashing rom and paid apps
    By abhishake620 in forum Nokia Lumia 620
    Replies: 7
    Last Post: 08-13-2013, 12:02 PM
  4. Problem while restoring
    By rohithrjn in forum Nokia Lumia 720
    Replies: 7
    Last Post: 08-13-2013, 10:59 AM
  5. $ symbol missing while txting
    By Prashanth P in forum Nokia Lumia 1020
    Replies: 2
    Last Post: 08-13-2013, 08:04 AM
LINK TO POST COPIED TO CLIPBOARD