1. RetroMan71's Avatar
    As the title says, my Lumia 620 has recently decided that it won't play videos with any apps. Whether it be YouTube; MetroTube or any video app... They just wont play!
    There's no error message or anything, I simply click PLAY icon which seems to respond to my touch but nothing else.

    Just curious to know if anyone else has had a similar issue and hopefully fixed it?

    Thanks!
    09-11-2013 05:31 AM
  2. montsa007's Avatar
    Tried soft reset?

    Are you on a 2G plan? (If so, it'll take ages to load a few secs of the video)
    09-11-2013 05:40 AM
  3. RetroMan71's Avatar
    Not tried soft reset, how do I do this?

    This is over my Wireless at home.. I've never had this problem before, just recently!
    09-11-2013 05:46 AM
  4. montsa007's Avatar
    Hold down volume down + power button, screen will go off, release the buttons and it'll reboot, try then.

    Try a different wifi/3G connection.

    Remember - A soft reset is the first and most common solution to most of the problems.
    RetroMan71 likes this.
    09-11-2013 05:57 AM
  5. RetroMan71's Avatar
    Mmm! Soft reset didn't work.. I'm at work and using the WiFi and still the same problem, even using my phones network!
    09-11-2013 06:00 AM
  6. montsa007's Avatar
    Remove and reinstall the application?

    Can you scroll on the page in metrotube once you open a video?
    09-11-2013 06:08 AM
  7. RetroMan71's Avatar
    Yeah it lets me scroll and search for videos, but clicking on the PLAY icon won't play the video.
    09-11-2013 06:12 AM
  8. RetroMan71's Avatar
    Just restored my phone and still videos wont play.. Frustrating!!!
    09-11-2013 03:07 PM
  9. montsa007's Avatar
    I'm out of ideas :/
    09-11-2013 11:50 PM
  10. diktea's Avatar
    To check whether the phone /apps are problematic or not, just load some videos to your phone itself locally and try to play it (if it does not play then it could be some new apps you downloaded messing it up, if it plays well it could very well be the network connection)

    try recalibrate the network connection by deleting the wifi connection on your phone and re-search it and reconnect it. (if you have not done it)
    If GDR2 with Data Sense did you limit your data usage ?

    I dont know the solution but that might just help... All the best
    09-12-2013 01:04 AM
  11. RetroMan71's Avatar
    Mmm! Thanks for your input guys, but after some headbanging, it seems that certain videos will play that don't say VEVO on them. Also if I go to the YouTube website and try to play the same video, it says "This video is not available on mobile. Add to playlist to watch it later on a PC"...

    So there you go...
    09-12-2013 02:29 AM
  12. montsa007's Avatar
    Try to play a different video on youtube mobile app, I use metrotube and never had this error "Not avl. for mobile"

    As for VEVO thing, never heard of that :/
    09-12-2013 02:32 AM
  13. RetroMan71's Avatar
    Try to play a different video on youtube mobile app, I use metrotube and never had this error "Not avl. for mobile"

    As for VEVO thing, never heard of that :/
    To be honest, I've been using MetroTube for a while also and never had these issues before. Only in the last week or so has it been acting weird.

    The VEVO logo appears on the video before you click on it to play...

    vevo.jpg

    Any video that has this won't play... others play fine.
    09-12-2013 07:32 AM
  14. RetroMan71's Avatar
    Just to update.. Been using mytube, didn't know about this app, very good by the way. Anyhoo, was fine for a while but sure enough again in having issues playing certain music vids. Some that where playing before suddenly have stopped working.. Really bizarre, very frustrating!!!!!!!
    09-12-2013 05:32 PM
  15. montsa007's Avatar
    To be honest, I've been using MetroTube for a while also and never had these issues before. Only in the last week or so has it been acting weird.

    The VEVO logo appears on the video before you click on it to play...

    Click image for larger version. 

Name:	vevo.jpg 
Views:	75 
Size:	48.6 KB 
ID:	42977

    Any video that has this won't play... others play fine.
    If you're head is still not leaking blood by constantly banging it somewhere, I'd like to inform that I can't play this thing either, I'd shoot myself ifI saw that video anyway after seeing a bunch of her pics at VMA performance on 9gag.
    09-14-2013 01:51 AM
  16. RetroMan71's Avatar
    If you're head is still not leaking blood by constantly banging it somewhere, I'd like to inform that I can't play this thing either, I'd shoot myself ifI saw that video anyway after seeing a bunch of her pics at VMA performance on 9gag.
    Haha! thanks mate. She went all weird right? I read somewhere that it has something to do with adverts that should play before the video starts on vevo videos??
    Anyway, I've recently switched over to mytube and all is great with that now after purchasing.
    09-16-2013 09:28 AM
  17. Shuvro Sudipta Saha's Avatar
    now the same problem is happening in my 720....
    neither YouTube nor FB vids are playing on my phone ( since last 2 weeks )
    says "Sorry, we can't play this file on your phone."
    no idea what suddenly went wrong.
    03-20-2014 02:23 PM
  18. pavan mojala's Avatar
    same here....did u get any solution??
    07-07-2014 10:18 PM
  19. Ahsen Nazir's Avatar
    Following method worked for me:
    Clear up some space (at least 100mb) of Your phone(not SD card)
    04-04-2015 05:40 AM
  20. Bernard Moyo's Avatar
    my phone is also refusing to play vedios that i download and those i take using my cam and also refusing to open photos that i shoot using my phone..it says format not supported
    04-27-2016 04:33 PM

Similar Threads

  1. Playing HD Videos in Youtube mobile
    By Rahul Poddar in forum Nokia Lumia 720
    Replies: 6
    Last Post: 11-23-2013, 02:16 PM
  2. Replies: 11
    Last Post: 09-12-2013, 05:50 AM
  3. Will Lumia 1520 use 1200P resolution
    By maverick786us in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 09-11-2013, 08:36 AM
  4. Can I stop Lumia 720 data drain?
    By samand71 in forum Nokia Lumia 720
    Replies: 3
    Last Post: 09-11-2013, 03:19 AM
  5. NO Sound No vibration on my Lumia 920
    By hyperthermia in forum Nokia Lumia 920
    Replies: 1
    Last Post: 09-11-2013, 02:12 AM
LINK TO POST COPIED TO CLIPBOARD