Shop HP’s Memorial Day Sale:Save up to 61% on PCs and more!
01-06-2015 11:13 AM
42 12
tools
  1. Raviraj Halarnekar's Avatar
    Hi guys,
    I am facing a couple of issues with my Nokia Lumia 620 and i want you'll to help me resolve these issues.
    The first issue i am facing is connecting my phone to my PC running windows 8 pro x86.
    After updating to cyan, my PC failed to detect my phone{But my phone is charging once connected to PC}.First i thought it was a driver issue, so i reinstalled the drivers but failed to connect. So i tried using a different PC/USB Cable combination but no luck. I even did a factory reset but there was no luck.
    I have already posted regarding this issue: How do I connect my Nokia Lumia 620 to my PC?

    I even discussed regarding this in the Microsoft community Forum: Nokia Lumia 620 not getting connected to PC - Microsoft Community

    But even after trying all the valuable suggestion the problem persist.

    The second issue i am facing is regarding battery.
    I am getting roughly around 4-5hrs battery backup on full charge.
    I am facing this issue after updating to cyan.

    Before updating to cyan i was on Dev Prev and was not able to update to cyan because Microsoft was paused seeding Cyan to Dev Prev devices due to Bitlocker and some other issues.
    Please guide me as this is my only Windows phone.I don't have a secondary windows phone or WP.1 device for that matter.
    Please help me as i am suffering from "Nomophobia".
    Last edited by Guytronic; 01-06-2015 at 11:53 AM.
    10-16-2014 02:32 PM
  2. kenovi's Avatar
    i have the same issue too for my Lumia 620. it is not recognised by win7 pc via usb. i have no problem connecting lumia 1520 to the same pc. what went wrong?
    10-17-2014 08:03 AM
  3. Raviraj Halarnekar's Avatar
    i have the same issue too for my Lumia 620. it is not recognised by win7 pc via usb. i have no problem connecting lumia 1520 to the same pc. what went wrong?
    I noticed that the battery is draining fast so i decided to do a hard reset.I wanted to backup my stuff before hard reset so i connected my phone PC to discover that its not getting detected:(..
    Did u resolve your issue??
    10-17-2014 08:46 AM
  4. styeffo69's Avatar
    Had the same issue and read that taking the Sd card may help, it did!

    However reinserting the card brought the same issue, UNTIL i formatted it again with the same phone.....then plugged it back in with same USB and it was fine, hope that helps!
    Raviraj Halarnekar likes this.
    10-17-2014 03:26 PM
  5. Raviraj Halarnekar's Avatar
    Had the same issue and read that taking the Sd card may help, it did!

    However reinserting the card brought the same issue, UNTIL i formatted it again with the same phone.....then plugged it back in with same USB and it was fine, hope that helps!
    I tried without memory card but no luck.
    10-18-2014 01:04 AM
  6. anon8855939's Avatar
    This may be due to driver in your PC.
    Right click my computer and select manage and then find driver for you phone delete them and restart your PC reconnect your phone.
    10-18-2014 06:38 AM
  7. Raviraj Halarnekar's Avatar
    This may be due to driver in your PC.
    Right click my computer and select manage and then find driver for you phone delete them and restart your PC reconnect your phone.
    Already tried it..but the phone is not listed under device manager ,portable devices or any other category for that matter. Even reinstalled windows phone drivers,tried Nokia software recovery tools but no luck.I guess its better to handover it to Nokia Care.
    10-18-2014 10:49 AM
  8. Raviraj Halarnekar's Avatar
    Now I am facing another problem, My phone is getting discharged very fast.
    I charged it to 100% and within 6hrs the battery percentage dropped to 0%(Phone turned OFF automatically due to low battery).
    Please Help!!
    10-23-2014 01:29 AM
  9. SOCMOB's Avatar
    Do you have the Windows Phone app installed on your pc? I don't know whether it will make a difference for you, but I use that app and Windows 8.1 on my pc, and my Lumia 620 and 521 both are recognized fine.
    10-23-2014 01:51 AM
  10. Raviraj Halarnekar's Avatar
    Do you have the Windows Phone app installed on your pc? I don't know whether it will make a difference for you, but I use that app and Windows 8.1 on my pc, and my Lumia 620 and 521 both are recognized fine.
    yes i have the windows phone app.
    10-23-2014 10:17 AM
  11. colinkiama's Avatar
    The lumia 620 has a poor battery (1300mAh) for what it can do. Also try deleting the use drivers for the device while your 620 is plugged in.
    10-28-2014 04:14 AM
  12. Raviraj Halarnekar's Avatar
    The lumia 620 has a poor battery (1300mAh) for what it can do. Also try deleting the use drivers for the device while your 620 is plugged in.
    I tried it but it does not seem to connect and regarding battery life:
    wp_ss_20131207_0001.png
    This is an old screen shot but ya i was still getting a similar battery backup before cyan.
    Last edited by Raviraj Halarnekar; 10-28-2014 at 04:45 AM.
    10-28-2014 04:23 AM
  13. colinkiama's Avatar
    I tried it but it does not seem to connect and regarding battery life:
    Click image for larger version. 

Name:	wp_ss_20131207_0001.png 
Views:	18 
Size:	70.8 KB 
ID:	85864
    This is an old screen shot but ya i was still getting a similar battery backup before cyan.
    Since 8.1 apps are free to run in the background. Disable apps that you don't use or need to run in the background in the battery sense app.
    10-28-2014 06:27 AM
  14. satrus08's Avatar
    Just a thought, sometimes it takes a really long time to get discovered by a PC. Like my 520, for example, once took 15 min to get picked up! So try waiting it out and see what happens. Hopefully it will work. Best of luck :)
    10-28-2014 06:35 AM
  15. colinkiama's Avatar
    Just a thought, sometimes it takes a really long time to get discovered by a PC. Like my 520, for example, once took 15 min to get picked up! So try waiting it out and see what happens. Hopefully it will work. Best of luck :)
    Yeah sometimes it's installing drivers
    10-28-2014 06:56 AM
  16. Raviraj Halarnekar's Avatar
    Yeah sometimes it's installing drivers
    I kept my phone connected for an hour or so,nothing happens..only its getting charged :(
    10-28-2014 09:40 AM
  17. Raviraj Halarnekar's Avatar
    Since 8.1 apps are free to run in the background. Disable apps that you don't use or need to run in the background in the battery sense app.
    Thanks ,but I tried disabling the apps, still no improvement :(
    10-28-2014 09:42 AM
  18. VaraPrasad18's Avatar
    When nothing goes easy use "easy transfer" app
    10-28-2014 10:00 AM
  19. her3814's Avatar
    In cyan you have the option to select what your phone does when you connect a USB.. Under All settings-> USB select the "ask me before using USB data" our something like this so when you connect to the PC it'll ask you what to do... Good luck pal..
    10-28-2014 10:04 AM
  20. Raviraj Halarnekar's Avatar
    In cyan you have the option to select what your phone does when you connect a USB.. Under All settings-> USB select the "ask me before using USB data" our something like this so when you connect to the PC it'll ask you what to do... Good luck pal..
    I am unable to find "Usb select " option under settings.Is that feature available for US only??
    10-28-2014 10:56 AM
  21. her3814's Avatar
    That's how it should appear

    10-28-2014 10:58 AM
  22. Raviraj Halarnekar's Avatar
    Thank you so much but still my phone does not show "USB" option.
    I even changed my region to US but no luck :(.
    I guess this particular setting is available for only x30 devices.
    wp_ss_20141028_0002.png
    10-28-2014 12:10 PM
  23. Raviraj Halarnekar's Avatar
    When nothing goes easy use "easy transfer" app
    The reason i want to connect my phone to PC is to downgrade from wp8.1 to wp8 and then upgrade to wp8.1 again.
    I know it sounds stupid but i guess doing so will also solve my battery issue along with connectivity problem.
    10-28-2014 12:14 PM
  24. her3814's Avatar
    Did you tried connecting your phone in another PC?? Sometimes happens that the OS goes crazy and doesn't detects some hardware when you connect it... That used to happen with an Android Sony Ericsson I had a year ago

    Ps.. Now I'm better with my 630 :D
    10-28-2014 12:23 PM
  25. her3814's Avatar
    That option should be available with WP 8.1 now I'm at college.. Later I'll try to give you better feedback... Luck 🍀
    Raviraj Halarnekar likes this.
    10-28-2014 12:25 PM
42 12

Similar Threads

  1. Why isn't my music working after upgrading to 8.1?
    By WPCentral Question in forum Ask a Question
    Replies: 4
    Last Post: 10-25-2014, 04:03 PM
  2. How do I fix Waze crashing on Lumia 930?
    By dda_k in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2014, 02:21 PM
  3. Why aren't my new purchase working on my Nokia Lumia 520?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2014, 02:17 PM
  4. Verizon Lumia 735 not scheduled until early 2015
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-16-2014, 02:11 PM
  5. AT&T Lumia 830 comes with two dual-use Qi/PMA wireless charging covers in green, black
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-16-2014, 01:11 PM
LINK TO POST COPIED TO CLIPBOARD