1. Vattipalli Nikhil's Avatar
    Hello guys,

    I've purchased lumia 625 about 3 weeks ago. Ever since I've purchased there seems to be a glitch with the 3.5mm jack. I was pretty happy with its performance until one day I was able to listen to music/watch vidoes only through one earbud(left). Restarting the phone seems to solve the malfunction temporarily until it persists again. It happens every second day. I can't help it but to restart almost every day. It is really frustrating. I'm not really sure if it is a hardware or a software issue as restarting the phone is solving it temporarily.
    Can anyone help me out analyzing what the glitch is?
    Is anyone else facing the same problem with Lumia 625?
    09-28-2013 09:14 PM
  2. Laura Knotek's Avatar
    Hi Vattipalli and welcome to WPCentral.

    Have you tried quickly inserting and removing the headphones several times? Sometimes that will do the trick to make them work properly.
    09-28-2013 09:23 PM
  3. Vattipalli Nikhil's Avatar
    Will give it a shot the next time it occurs.
    I've tried different pair of earphones too. Back to square one.
    09-28-2013 09:37 PM
  4. Vattipalli Nikhil's Avatar
    Also, it takes 2-3 seconds to load the song I select to play. Basically, there's a 2-3 second lag between selecting a song and loading it.
    Help please?
    09-28-2013 09:39 PM
  5. jatin wadhwa's Avatar
    Hi,
    I had bought this phone 2 days ago and since day 1 I am facing this issue with the jack, left headphone is not at all working. It works fine after restart but its is frustating, as everytime I have to restart the phone to listen songs/radio. :X
    Please let me know the solution if any, otherwise I will return this phone to the dealer.
    10-23-2013 11:30 AM
  6. Akash Raj 235's Avatar
    dude.I've purchased the same phone and I've got the same problem since the first day... Did you found any solutions??
    01-02-2014 08:46 AM
  7. outdoorguy25's Avatar
    I've got the same glitch on my 925. The only thing that seems to work is a restart.
    05-23-2014 08:42 AM

Similar Threads

  1. Share your 6tag glitches
    By uopjo6 in forum Applications
    Replies: 20
    Last Post: 10-12-2013, 10:07 AM
  2. Headphone jack faulty?
    By iop777 in forum General Desktop, Laptop & Tablet Discussion
    Replies: 5
    Last Post: 09-29-2013, 04:19 PM
  3. Video of my Lumia 928 Glitches
    By Nogitsune Micah in forum Nokia Lumia 928
    Replies: 3
    Last Post: 09-14-2013, 03:02 AM
  4. Sound disappeared, heaphone jack issue...
    By Yev91 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 09-01-2013, 04:05 PM
  5. WPcentral App Glitch
    By Nogitsune Micah in forum Windows Central for Windows Phone - App Support
    Replies: 3
    Last Post: 08-31-2013, 10:56 AM
LINK TO POST COPIED TO CLIPBOARD