1. pravin_625's Avatar
    I am having Lumia 625 with preinstalled amber update. When I turn on/off data connection (from Settings->Mobile Network->Data Connection) then facing strange issue of connectivity like unable to make/receive calls, can't send/receive SMS, no connectivity with internet and almost phone gets dead! but most surprising thing is phone shows proper signal range, working fine with offline apps and almost look in normal state. So workaround is restart and get back in normal state. For quick solution I reset my phone but no luck. This is random behavior, many times my friends informing me that your phone is not reachable so restart it and back in normal state. Anybody facing similar type of issue? Is this related to 625 only?
    01-17-2014 12:06 PM
  2. Himanshu Chowdhary's Avatar
    Chances are your phone is receiving poor signal. Is your data set on 2g or 3G , if it is 3G then is very common , here in India. The networks for 3G are up and down depending on area. Don't restart your phone,instead just try to put your phone in airplane mode and then turn airplane mode of, it will make sim to scan for signals.
    Also try to use another carrier, sim and if the problem still persist,try taking your phone to Nokia care centre, your antenna might be faulty. They will replace it if it's under warranty.
    pravin_625 likes this.
    01-17-2014 12:35 PM
  3. pravin_625's Avatar
    My data set is 3G. I also tried with another sim but same problem. I'll try with airplane mode and update my status
    01-17-2014 09:56 PM
  4. haree's Avatar
    My data set is 3G. I also tried with another sim but same problem. I'll try with airplane mode and update my status
    hi
    if ur not gona use data change the connection to 2G and things should be fine i dont use data and mine is on 2G only and all is fine for me try it
    pravin_625 likes this.
    01-18-2014 09:31 AM
  5. pravin_625's Avatar
    Small update

    I did visit to Nokia care for this problem. Unfortunately there was 2G range so could not duplicate problem. So after long discussion with executive he convinced me problem will be solved with new "Black" update. So now phone is updated with "Black" update but still problem persist. So next move is submit hardware with Nokia care for further analysis.
    01-25-2014 10:32 PM

Similar Threads

  1. Not sure whether to buy 520 - questions
    By Must-cat in forum Nokia Lumia 520
    Replies: 11
    Last Post: 03-12-2014, 08:36 AM
  2. DLNA/Play to receiver devices
    By KINGINI LABS in forum Nokia Lumia 920
    Replies: 2
    Last Post: 01-21-2014, 01:15 AM
  3. BIng news not working properly
    By Andresco in forum Applications
    Replies: 2
    Last Post: 01-18-2014, 11:13 AM
  4. Path beta social-network officially strolls on to Windows Phone 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-17-2014, 09:30 AM
  5. Nokia releases update for Play To, addressing issues with GDR3 Developer Preview
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-17-2014, 08:30 AM
LINK TO POST COPIED TO CLIPBOARD