1. Deyirn Skysand's Avatar
    i dont have lag or stuttering, but my app store app is the one lagging - when im downloading one app and i tap "install" on another, it takes a while before it displays the loading animation and "check progress"

    sometimes resuming apps doesnt work and i have to start them over

    i tried minion rush and its almost impossible to play it, at some point the game froze, i could only hear the sound and i had to remove my battery to get back on track

    i tried to install asphalt 8 airborne and the details in the app store say its a total of ~900mb, on my phone i hav 1.7gb free and on my sd card i have more than 3gb free, ive set my apps to install on the sd card, but when i try to install the game, it tells me i dont have enough space

    my phone was the last one in the store and it was originally put on display, so the first thing i did when i got home was to do a factory reset

    i have checked for updates and got the latest cyan update
    i have installed no more than 20 apps and i dont understand why am i experiencing those issues, please help me out
    07-26-2014 11:55 AM
  2. Sonu K's Avatar
    i dont have lag or stuttering, but my app store app is the one lagging - when im downloading one app and i tap "install" on another, it takes a while before it displays the loading animation and "check progress"

    sometimes resuming apps doesnt work and i have to start them over

    i tried minion rush and its almost impossible to play it, at some point the game froze, i could only hear the sound and i had to remove my battery to get back on track

    i tried to install asphalt 8 airborne and the details in the app store say its a total of ~900mb, on my phone i hav 1.7gb free and on my sd card i have more than 3gb free, ive set my apps to install on the sd card, but when i try to install the game, it tells me i dont have enough space

    my phone was the last one in the store and it was originally put on display, so the first thing i did when i got home was to do a factory reset

    i have checked for updates and got the latest cyan update
    i have installed no more than 20 apps and i dont understand why am i experiencing those issues, please help me out
    About Asphalt 8, even though it is just 900mb file to download, it need around 2.7GB free space on phone memory i heard. Its just for the installation. After the installation, the file size (in SD card in your case) will be around 1.5GB or so. I haven't installed it yet. But i read it in the forum itself. Just do a little bit search and you will find your answer.
    07-27-2014 09:43 AM
  3. Deyirn Skysand's Avatar
    what about the rest then? it shouldnt be like this at all
    07-30-2014 03:16 AM
  4. Narathan's Avatar
    what about the rest then? it shouldnt be like this at all
    Are you by chance using a Kingston SD card? I had the same problems like you describe. Also had apps locking up on resume (or not starting), Skype for example being very laggy/unresponsive while typing or not showing any contacts, tiles not updating or turning blank... Phone rebooting as well.

    I changed the Kingston Class 10 SD card with my Samsung Class 10 and everything works smooth. Friend of mine had the same with his HTC 8S - changed his Kingston for another brand SD card and it solved the issues.

    Hope this helps you.
    07-30-2014 10:53 AM
  5. Deyirn Skysand's Avatar
    Are you by chance using a Kingston SD card? I had the same problems like you describe. Also had apps locking up on resume (or not starting), Skype for example being very laggy/unresponsive while typing or not showing any contacts, tiles not updating or turning blank... Phone rebooting as well.

    I changed the Kingston Class 10 SD card with my Samsung Class 10 and everything works smooth. Friend of mine had the same with his HTC 8S - changed his Kingston for another brand SD card and it solved the issues.

    Hope this helps you.
    i thought it was kingston when you mentioned, but its TOSHIBA 4GB
    08-01-2014 07:47 AM
  6. Narathan's Avatar
    i thought it was kingston when you mentioned, but its TOSHIBA 4GB
    Sound like an old card. Remember WP8.1 requires at least a class 6 card and I'm not sure what class that Toshiba card is, but pretty sure it is class 4 - which is too slow. Have you tried using the phone withouth SD card? Big chance it solves your problems by getting a newer class 8-10 card of 8 gb > more. They are not so expensive these days :)
    08-01-2014 09:18 AM
  7. Deyirn Skysand's Avatar
    yeah, its class 4, i will be getting a new one

    and i just tried it without the SD card and so far it seems lightning fast, like a completely different experience, im set on getting a new SD card then

    thanks everyone, i think my problem is solved
    LumiaWorld likes this.
    08-03-2014 04:38 AM

Similar Threads

  1. Never ending hard reset problem with nokia lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 01-25-2016, 01:29 AM
  2. Lumia 1525
    By phlamethrowre in forum Upcoming & Rumored Phones
    Replies: 16
    Last Post: 07-30-2014, 08:02 PM
  3. lumia 630 3g
    By Chandan Chandu in forum Ask a Question
    Replies: 6
    Last Post: 07-26-2014, 02:51 PM
  4. What is my user name in WPCentral?
    By Ivan Moronta in forum Ask a Question
    Replies: 1
    Last Post: 07-26-2014, 11:31 AM
  5. Royal Revolt 2 review Nearly the best raiding game on Windows Phone and Windows 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-26-2014, 09:42 AM
LINK TO POST COPIED TO CLIPBOARD