1. Windows Central Question's Avatar
    I joined the insider program and two days ago I finally updated the phone to win 10 preview version. And since then its not really working. Keeps shutting down, and now its not booting for last 4 hours. I tried to hard reset the phone and still no light. When I plug in the charger, there is no signal either. Like totally dead. Can somebody please help???
    06-15-2015 04:45 AM
  2. Harrie-S's Avatar
    Probably your battery is totally flat. Keep your phone connected to the charger for several hours.
    If it's charged again I would recommend to roll back to WP8.1

    If you need more assistance please register and reply on this post.
    06-15-2015 06:20 AM

Similar Threads

  1. Why doesn't my Lumia 925 respond or reboot?
    By Windows Central Question in forum Nokia Lumia 925
    Replies: 0
    Last Post: 06-15-2015, 03:27 AM
  2. SF2 boot red boot screen?
    By tmn0 in forum Microsoft Surface Pro 2
    Replies: 1
    Last Post: 06-15-2015, 02:42 AM
  3. forgot lockscreen password in lumia 520 but i remember live id
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 06-15-2015, 02:26 AM
  4. Why isn't the Windows Store opening on my Lumia 540?
    By Windows Central Question in forum Microsoft Lumia 540
    Replies: 1
    Last Post: 06-15-2015, 02:07 AM
  5. How can I connect my Lumia 640 to tablet OTA?
    By Windows Central Question in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 06-15-2015, 01:55 AM
LINK TO POST COPIED TO CLIPBOARD