1. Dese G's Avatar
    I bought a Lumia 630 a year ago in bangalore, India.
    Since then the phone was awesome. But, from the last 4-5 months, it's failing to recognise 3G networks and always ends up connecting to 2G network despite of superb network coverage. I also use moto e running lollipop 5.1 which always connects to 3G on the same sim. I thought it might be some bug in the os and upgraded the phone to windows phone 8.1 update. But, its no use. I use manual APN option, despite the automatic option being (which doesn't work). I tried everything from soft reset to hard reset and nothing helped. Please if someone know anything ragarding this matter i would be greatful for your help.
    01-20-2016 08:34 AM
  2. Malhar Deshmukh's Avatar
    Did you install configuration settings from your carrier?on Which carrier do you face this ? Is that phone single sim?
    02-22-2016 11:32 PM

Similar Threads

  1. Album and artist not showing up in car bluetooth
    By nynamyna in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 01-23-2016, 03:02 PM
  2. How to copy files from a default folder?
    By WPCentral Question in forum Nokia Lumia 822
    Replies: 2
    Last Post: 01-21-2016, 07:08 AM
  3. My Nokia Lumia 520 is switching on and totally blank, how can I fix it?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 1
    Last Post: 01-20-2016, 08:30 AM
  4. T-mobile Lumia 435 on sale for $39.99 at Best Buy [Expired]
    By libra89 in forum Expired & Archived Deals
    Replies: 0
    Last Post: 01-20-2016, 07:46 AM
  5. How can I fix a wifi connectivity issue on my Lumia 730?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 0
    Last Post: 01-20-2016, 06:44 AM
LINK TO POST COPIED TO CLIPBOARD