08-30-2013 03:32 PM
42 12
tools
  1. Bearach's Avatar
    Deleted.
    Last edited by Bearach; 07-08-2013 at 09:26 PM.
    10-05-2012 12:38 AM
  2. redrotors's Avatar
    I was going to ask if you had MAC address filtering on. It would seem you've already turned it off during your diagnostics. I do remember some people were having issues with the MAC address changing on their Windows Phone devices, hence why it could have been a problem.
    !!??, How the heck does a MAC address change itself ??!! I let the phone connect the first time w/filtering off to capture the MAC the device is reporting then save it to the allow list and turn filtering back on. In any case it's not the issue since w/filtering on it connects fine if the SSID is unhidden.

    These other hidden networks are using different routers completely?
    Yes.
    The business was WPA2-Enterprise?
    Not positive re that. If I had to guess I'd say yes.
    10-05-2012 12:45 AM
  3. Bearach's Avatar
    Deleted.
    Last edited by Bearach; 07-08-2013 at 09:26 PM.
    10-05-2012 12:50 AM
  4. palandri's Avatar
    SSID is the network ID. It is required for a WiFi network, and can't be turned off. However it can be hidden. There is little security benefits from it though. The devices communicating with the AP still broadcast the SSID and thus it can be found with the right tools. A good password and change of passwords is the only security that helps most.
    Like I said, I am not a network expert or a network geek.

    A couple of years ago a neighbor couldn't connect to a NetGear WiFi router he bought. As I recall, he was running Windows Millennium. I thought I was able to turn SSID off on his router and just set a password.

    It was a couple of years ago. I maybe way off base here.

    Maybe you are thinking about the MAC address?

    Usually expressed like this
    00:00:00:00:00:00
    where the 0's can be numbers or letters.
    AFAIK every wifi device is assigned a unique MAC.

    A wifi router security feature is MAC address filtering. I added the MAC address of my phone to the allow list on my router. I use MAC address filtering but I also turned that off during attempts to get the 710 to connect.

    The other hidden networks I tried to connect to one uses filtering one is "allow any".
    No it wasn't a MAC address. I thought it was a SSID password I turned off, but it was a couple of years ago.

    Interesting thread. i''ll keep reading and learning from you network guys that know what you are talking about. :)
    10-05-2012 12:57 AM
  5. redrotors's Avatar
    It was to do with the firmware that brought Internet Sharing to devices. Anyway, you might need to check with your admin, find out if they use WPA2-Enterprise EAP-TLS. If so, Windows Phone isn't (at this point) capable of connecting to them networks (as far as I know). Having said that, it doesn't explain your issue at home.

    What router are you currently using?
    Mine is a USR (US Robotics) 5461 and friends is an older Linksys, not sure of the model but they are one of the older (old reliable) common as dirt ones here in the USA.

    Edit - friends is one of the variants of this one
    http://homesupport.cisco.com/en-us/s...routers/WRT54G
    10-05-2012 12:58 AM
  6. redrotors's Avatar
    Like I said, I am not a network expert or a network geek.

    A couple of years ago a neighbor couldn't connect to a NetGear WiFi router he bought. As I recall, he was running Windows Millennium. I thought I was able to turn SSID off on his router and just set a password.

    It was a couple of years ago. I maybe way off base here.



    No it wasn't a MAC address. I thought it was a SSID password I turned off, but it was a couple of years ago.

    Interesting thread. i''ll keep reading and learning from you network guys that know what you are talking about. :)
    I only know enough to be dangerous ;)
    palandri likes this.
    10-05-2012 01:05 AM
  7. redrotors's Avatar
    I guess it wouldn't hurt to add that I just recently SIM unlocked this phone. T-mo / Nokia supplied SIM unlock PIN, nothing fancy or aftermarket hacked. All the Wifi issues remain as before the SIM unlock.
    10-05-2012 01:08 AM
  8. Bearach's Avatar
    Deleted.
    Last edited by Bearach; 07-08-2013 at 09:14 PM.
    10-05-2012 01:09 AM
  9. redrotors's Avatar
    They're pretty reliable routers.. And they're working with other devices perfectly. Did you get the device from a store?
    No, actually it was a week old hand-me-down from a relative who HATED it and went screaming back to her beloved iPhone :rolleyes: but I have all the sales records / receipts.
    Does your operator have a store you can go to?
    No, T-mo only has non-company kiosk type dealers near me. Nearest company store is 2hrs. away.
    Are you able to get them to test the devices ability to connect to hidden WiFi with you there?
    No
    Do you have access to a N router?
    No, but I'll look into it to see if anyone i know has one AND will let me play around w/it - doubtful.
    The only thing that could be said about both routers is they're old, which I don't believe the problem is, but its something to test too.
    From what you've said here, you've done some very extensive troubleshooting and it's looking highly likely there is an issue with your phone (especially if it doesn't work with other routers) and perhaps you should push for a replacement.
    My last conversation w/Nokia didn't go very well in that regard. :(

    Thanks for taking all the time to run through this w/me. At least it reaffirms that I am not missing something basic. Some "experts" at a local AT&T wireless store said this was a known issue w/WP but when I asked for some info. / reference links or material none was given.
    10-05-2012 01:26 AM
  10. Bearach's Avatar
    Deleted.
    Last edited by Bearach; 07-08-2013 at 09:14 PM.
    10-05-2012 01:43 AM
  11. redrotors's Avatar
    Well if I don't resolve this it looks like this might go in the drawer to become a backup / loaner phone.

    I am still looking for suitable SIP / Voip support or app to use Localphone Voip and an app like GrooveIP or Talkatone to use Google Voice w/o using mobile min.

    Much as I really like some of the features of this phone, not the least of which is that it has excellent signal strength vs. most other phones (nearly as good as the e71), if I can't resolve these issues and needs I will have to move on from this phone. I travel in many areas w/no or marginal signal coverage (was actually better in some areas in the old CDMA analog days but that's another story) so I appreciate a strong signal phone but I use SIP / Voip to both save $ and in areas w/no cell coverage. Some of the areas i travel I have no cell coverage but know where to stop to grab an open wifi signal to make a quick call.
    10-05-2012 01:44 AM
  12. redrotors's Avatar
    Windows Phone before 7.5 was unable to connect to hidden WiFi networks. It had no option to type in a SSID. I suspect that is what the at&t reps were thinking about. There are no issues with hidden networks other than the EAP-TLS that I said earlier - which is more a missing feature. You could always try putting one of your other devices into AP mode? Any WiFi dongles would work with creating a WiFi AP. You don't need to bridge the connection to see if it will actually connect. Have you any WiFi devices that can be put into AP mode?
    I do have a USB wifi dongle, from the "cantenna" days. Would that work? I will look into what you suggest. Bridging or AP mode is not something I have done before or know about but I will study up, learn something, play around and report back. May take me a few days though. For now I'm going to sleep, getting way too late here.
    10-05-2012 01:48 AM
  13. thed's Avatar
    I know you said you have no control over this, but it's kind of sad that people still think that hiding the SSID provides any sort of security. 802.11 wasn't even designed to accomodate hiding it. I wish routers wouldn't even provide the option.
    10-05-2012 10:02 AM
  14. redrotors's Avatar
    I know you said you have no control over this, but it's kind of sad that people still think that hiding the SSID provides any sort of security. 802.11 wasn't even designed to accomodate hiding it. I wish routers wouldn't even provide the option.
    Well, I have control over it at home but I can't or won't go telling other people what to do w/their signal. My friend knows but we both do it (or in my case DID it) because it just keeps the network "off the radar screen" to a casual passerby. Probably don't need to worry about them, the ones to worry about would probably sniff out the SSID. It's kind of funny because most of private networks in my area the owners don't even bother having any security or password enabled.
    10-05-2012 12:02 PM
  15. scruffj's Avatar
    I have the exact same issue. As soon as i show the SSID the phone connect with no prompting. I use MAC filtering, WPA (Personal) encryption.
    It used to work but just recently i got a new router and upgraded my wp7 with the latest patches - both close together unfortunately. I have had to unhide the ssid. I have a HTC Mozart so you can count out the phone. I was using different encryption on my older router, so that is one possibility. I am more inclined to think the Microsoft patch changed something. Not worth the hassle of restoring the phone to find out considering the statements about the small benefit of hiding the SSID.
    05-30-2013 01:41 AM
  16. redrotors's Avatar
    I never resolved the issue, even after forcing WP7.8 onto the 710. Between this issue and the fact that there is still no SIP VoIP apps (for WP8) that I know of yet WP phones have just become a curiosity for me. I like the UI. I like the Nokia build quality. I like the standalone GPS on Nokia's but WP7 & 8 don't do what I need, yet anyway.
    05-30-2013 08:18 AM
  17. namcp's Avatar
    Hi redrotors,

    I don't know if you already tried this, but just now I had the same problem with my Nokia Lumia 900 WP 7.8. This occurred when I added a new MAC to my routers Wi-Fi WLAN filtering list. My phones MAC address was by some mysterious reason gone and after re-entering it even the security on the router was changed to something else and my phone could not connect to the network. Tried everything you did with the router but to no avail. Only setting SSID to visible resolved my problem. Then I stumbled on a site that showed how to disconnect a wifi connection in a way I never did before. So this is what I did:

    - While connected to the unhidden wifi ap go to settings -> wi-fi and tap-hold the network your connected to.
    - The network disconnects, but because the SSID is still visible it will stay on (probably) top of the list (at least in my case it was).
    - Then I turned the SSID on my router to hidden and on my phone the network disappeared from the list (as should be).
    - Scroll to the bottom and tap the advanced button.
    - Tap + and enter the name of the now hidden SSID.
    - Tap add and enter the security key and tap done.
    - The phone goes back to the network list and you should be able to see your hidden network.
    - Tap connect and it should be working.

    This is what worked for me. I think it has something to do with old settings in the phone that messed up the security check preventing it to connect to the hidden network.
    My router has the following settings, much as your own router i believe:

    - Hidden SSID
    - WPA-PSK/WPA2-PSK security
    - WPA pre-shared key
    - WPA encryption TKIP+AES

    Hope this works for you too.
    08-30-2013 03:32 PM
42 12
LINK TO POST COPIED TO CLIPBOARD