1. hazqeel's Avatar
    3G network available but unable to use 3G need help
    Attached Thumbnails wp_ss_20140507_0002.jpg   wp_ss_20140507_0003.jpg  
    05-07-2014 12:06 PM
  2. Madn355's Avatar
    If your phone is on roaming u will have to select your sim card's country option!
    Then also check if you have sufficient balance for your net pack!
    hazqeel likes this.
    05-07-2014 03:55 PM
  3. saadmubeen's Avatar
    I was having this problem with my lumia 520. I am also from Pakistan. First of all check if the APN is configured correctly for your network. Next call the service center and make sure that 3G is activated against your number. I am on ufone.

    Sent from my Nexus 7 using Tapatalk
    hazqeel likes this.
    05-07-2014 05:55 PM
  4. saadmubeen's Avatar
    It also depends on the strength of the signals. In my case, my cellphone keeps on shifting b/w 2g and 3g network depending on the signal it receives.

    Sent from my Nexus 7 using Tapatalk
    hazqeel likes this.
    05-07-2014 05:59 PM
  5. OzRob's Avatar
    3G network available but unable to use 3G need help
    Your phone will only switch to 3G if the signal is strong enough. Perhaps you're in a marginal signal area for 3G and the phone is dropping back to 2G.

    BTW, I'd turn off data roaming unless you plan give free access to network roaming, otherwise you might be in for some 'bill shock'.
    hazqeel likes this.
    05-07-2014 07:00 PM
  6. hazqeel's Avatar
    3g signals were weak
    05-08-2014 07:02 AM
  7. Silverape's Avatar
    It happens the same. I do not think the problem is the strength of the 3G signal.
    I have two 620, with the same company, same settings, etc.. The only difference is the leading software installed. I have tried many different firmwares and all possible configurations and does not work. Although the original does not work again. My SIM works in my other phone, but not vice versa.
    Last edited by Silverape; 08-31-2014 at 11:28 AM.
    05-12-2014 02:47 PM

Similar Threads

  1. Microphone not working
    By iain_h in forum Nokia Lumia 720
    Replies: 5
    Last Post: 05-30-2014, 03:33 PM
  2. Replies: 1
    Last Post: 05-09-2014, 09:54 PM
  3. Hard reset dev. 8.1 worked for me!
    By mofoliar in forum Windows Phone 8.1 Preview for Developers
    Replies: 17
    Last Post: 05-09-2014, 09:58 AM
  4. Help with switching to a new phone and updating to WP 8.1
    By dby2011 in forum Windows Phone 8.1 Preview for Developers
    Replies: 1
    Last Post: 05-07-2014, 02:56 PM
  5. Official Snapdeal app gets much-needed refresh, now offering an immersive shopping experience
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-07-2014, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD