1. shiva sunil's Avatar
    I am using l720 for past10 months..few days back I had a problem with my battery.it was at 9%when I plugged in for charging..after 30mins it was still showing 9%.them I did a soft rest and after that it was just showing red battery symbol..even after charging for3hrs it was still showing the same.then I did a search on the web and many of them having same pblm.then I used Nokia software recovery tool and reinstalled the os.my phone started properly and charging was fine.but after that again same pbllm.the wierd thing battery percentage is decreasing while charging.if I started charging at50% aftr 15 mins its showing 40%.what shud I donow.i worried.can someone suggest me something. Is battery replacement good enough...
    09-12-2014 02:22 PM
  2. Wastelands's Avatar
    Maybe you put USB plug with wrong side?
    09-15-2014 04:45 AM

Similar Threads

  1. Bluetooth - text message notifications. Strange problem.
    By HomeyJay in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 3
    Last Post: 09-18-2014, 04:41 AM
  2. Hiring fresh folks, a society problem
    By ShinraCorp in forum The "Off Topic" Lounge
    Replies: 10
    Last Post: 09-14-2014, 09:55 PM
  3. Am I missing something about wireless charging?
    By shann123 in forum Ask a Question
    Replies: 11
    Last Post: 09-14-2014, 10:37 AM
  4. XBM problem
    By RMT1979 in forum Ask a Question
    Replies: 0
    Last Post: 09-12-2014, 02:19 PM
  5. 720 start up problem
    By Sharath Rajkumar in forum Ask a Question
    Replies: 0
    Last Post: 09-12-2014, 12:56 PM
LINK TO POST COPIED TO CLIPBOARD