1. preetesh pathak's Avatar
    I casually switched off my lumia and now its not starting up. while starting its vibrating and displaying "nokia" (as usual). but always there is a black screen with Power( or Lightning symbol ) and setting icons 2706. its been 2 days.. plzz need assistance.
    Note: I already tried soft reset.
    01-20-2015 11:29 PM
  2. gpobernardo's Avatar
    I casually switched off my lumia and now its not starting up. while starting its vibrating and displaying "nokia" (as usual). but always there is a black screen with Power( or Lightning symbol ) and setting icons 2706. its been 2 days.. plzz need assistance.
    Note: I already tried soft reset.
    If you're seeing what looks like an empty battery symbol with a lightning symbol, then the battery of your phone has insufficient power to boot your phone up (please post a screenshot (a photo of the screen, since you obviously can't take a screenshot with your phone) if possible). Charge your phone fully for around two hours before attempting to turn your phone on again. Also, it would be best not to turn your phone again before charging, as this will drain your battery further. Draining your battery completely can seriously impact its performance and longevity.
    preetesh pathak likes this.
    01-21-2015 12:38 AM
  3. LTTG's Avatar
    Try these:
    Power button + volume down
    OR
    Power button + volume down + camera button
    OR
    Power button + volume up
    OR
    Power button + volume up + camera button
    01-31-2015 08:47 PM

Similar Threads

  1. Why won't my email account die?
    By Kupuna in forum Ask a Question
    Replies: 1
    Last Post: 01-21-2015, 03:51 AM
  2. [L1020] Camera has a very long load up time?
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 01-21-2015, 12:49 AM
  3. Replies: 2
    Last Post: 01-20-2015, 11:34 PM
  4. Replies: 2
    Last Post: 01-20-2015, 11:27 PM
  5. Replies: 1
    Last Post: 01-20-2015, 11:04 PM
LINK TO POST COPIED TO CLIPBOARD