1. Windows Central Question's Avatar
    I recently installed Ubuntu on my laptop in a bid to get acquainted to the linux platform. The version that I installed is Ubuntu 14.04.2 LTS.

    I ended up having trouble when I realized that My windows Phone (Nokia Lumia 730 WP8.1) is not getting detected when I connect it to my laptop using data cable. I cannot believe that there is no fix for this issue. I dont want to go back to using WIndows 7 again for now atleast.

    Can anybody here suggest me any solution to make my windows phone work with Ubuntu?

    Thanks in Advance.

    Satyajit.
    06-22-2015 11:36 PM
  2. noersetiawan's Avatar
    It should have work out of the box as MTP device, just like my 520 on 15.04. Not sure why but your best bet would be to make sure your Ubuntu installation is updated, or hit askubuntu.com and post your question there.

    Note that you have to unlock your phone lock screen.
  3. noersetiawan's Avatar
    It should have work out of the box as MTP device, just like my 520 on 15.04. Not sure why but your best bet would be to make sure your Ubuntu installation is updated, or hit askubuntu.com and post your question there.

    Note that you have to unlock your phone lock screen.
    06-22-2015 11:50 PM
  4. thescratchlad's Avatar
    I have already tried all the things that you have mentioned. I plugged my windows phone in unlocked mode and also have tried installing mtp-tools package to make it work for me, but it didn't budge any.

    I will try once more today evening (IST).

    Thanks for the help!
    noersetiawan likes this.
    06-23-2015 12:27 AM
  5. thescratchlad's Avatar
    Hey Hi,

    I gave it a one more try. But I failed. Do u have anything else in mind that I could try out?
    06-23-2015 11:13 PM
  6. noersetiawan's Avatar
    Hi. Give Vivid a try. I know 9 months of support is not long but you can always upgrade.
    06-24-2015 05:47 AM
  7. teckris's Avatar
    You may have to add mount point for the device.

    Also if it shows cannot open RM-**** just keep trying to connect and disconnect till phone asks the password..
    06-27-2015 04:35 AM
  8. Arpit Dubey's Avatar
    Try without memory card!!
    10-15-2015 11:29 PM
  9. Ivan Major1's Avatar
    Had the same problem with my Lumia 535 Dual Sim with Ubuntu 14.04 LTS. What worked for me was to plug the phone in and then restart the computer with the phone still plugged in and it then it detects it properly and you will have access to the built in memory on the phone as well as the SD card.
    01-13-2016 08:27 PM

Similar Threads

  1. Why is there no Clash of Clans in the Windows app store?
    By Windows Central Question in forum Applications
    Replies: 18
    Last Post: 11-22-2018, 05:34 AM
  2. Replies: 3
    Last Post: 06-23-2015, 10:25 PM
  3. question about windows 10 insider getting upgraded to RTM
    By Arthur Oechsler in forum Windows 10
    Replies: 2
    Last Post: 06-22-2015, 11:52 PM
  4. Replies: 0
    Last Post: 06-22-2015, 11:15 PM
  5. Windows-powered basic & smart-ized basic phones
    By asyl15 in forum General Phone Discussion
    Replies: 0
    Last Post: 06-22-2015, 11:13 PM
LINK TO POST COPIED TO CLIPBOARD