1. dwoodlock's Avatar
    New guy here, last two devices have been android but Googles nexus 4 availability fiasco ended that.

    I love my 810 so far, but it seems to be switching between 2g and 3/4g on a continual basis. I did some searching and found out how to disable the 2g band, which has definitely made an improvement. I was curious if anyone here can relate to my issue.
    01-13-2013 09:08 AM
  2. pankaj981's Avatar
    Network switching completely depends on the cellular network reception. I have this issue when I am driving in country areas
    01-13-2013 06:39 PM
  3. dwoodlock's Avatar
    Yes, I believe the issue stems from the fact that I have about an equal signal for the 3g, and 2g band. I come from android where there are often times multiple radio's available, I did'nt know if there was something similar in this community that perhaps can help remedy the situation.
    01-13-2013 08:45 PM
  4. MrTofu's Avatar
    How DO you switch off the 2g band? And I've never seen '3g' on my phone it switches between 2g and 4g. Am I doing something wrong here? I would always see 3g with my Nokia e73.
    01-13-2013 10:10 PM
  5. pankaj981's Avatar
    You can't switch off the 2G band but force the phone to use 3G only
    01-13-2013 10:29 PM
  6. MrTofu's Avatar
    If I force the phone to use 3G, does this mean that it will not utilize 4G? Is it worth the tradeoff, in your opinion?
    01-15-2013 12:01 AM
  7. pankaj981's Avatar
    Yes it wont use HSPA+ or 4G. In my opinion leave it as is and let the phone decide what's best unless you don't have an option. I was on $50 prepaid plan which had 1st 100MB on 4G, after that 2G. In this case I could force the phone to use 2G only to save battery after 100MB is utilized.
    01-15-2013 08:21 AM
  8. dwoodlock's Avatar
    Dont quote me on this, but I believe your not going to hinder your data speed by turning it to only 3G, our phones dont actually have a true 4g, its just faster 3g. When i set the setting to "3g only" my screen still shows a 4g connection. Maybe its because there is no 3g graphic on the phone, which I could see, but then again there is really no difference between the two, tmobile is just more of a ramped up version of 3g.

    try it and see is the best reccomendation I can make.
    01-15-2013 09:45 AM
  9. MrTofu's Avatar
    I've tried to find just how to switch it to 3G manually but can't find the info. Do u guys have any links u could share w me? I'd be glad to try it out!
    01-15-2013 05:22 PM
  10. pankaj981's Avatar
    I've tried to find just how to switch it to 3G manually but can't find the info. Do u guys have any links u could share w me? I'd be glad to try it out!
    Your phone will never show 3G (I can bet my money on this). International versions will show 3.5G or HSPA+ as H, only 3G signals will shows as 3G. Now the case with the L810 firmware is its for US carriers and here all carriers make their own standards whenever they want to (iPhone 4S users thought they started getting 4G all of a sudden after an IOS update, in reality ATT just changed the icon to 4G for HSPA+ signals)


    I had flashed my T-Mobile Lumia 710 to an international version firmware and it showed HSPA+ as H, previously it used to show 4G.
    So even though you force the phone to use 3G and even if its somehow forced to use 3G frequencies only its still going to show 4G no matter what. I hope it makes sense...
    01-15-2013 06:14 PM
  11. dwoodlock's Avatar
    ##3282# will get you do the menu where you can change these settings.
    01-15-2013 11:48 PM
  12. pankaj981's Avatar
    ##3282# will get you do the menu where you can change these settings.
    if updated to Portico then its ##3282
    01-16-2013 05:40 PM
  13. dwoodlock's Avatar
    todays update, seems to have solved this issue. I am getting considerably better signal in all areas of my house now. Interested to see how it is tomorrow at work. Good Job Nokia/Microsoft+1
    01-16-2013 11:35 PM
  14. CJC_2031's Avatar
    I think you're right about the phone never displaying a 3G signal. I have my 810 unlocked and travel internationally to places where no 4G signal exists, yet the phone only displays either 4G or 2G. I returned the phone back to Nokia complaining about this and some other issues. Nokia claimed all complaints were fixed but nothing has changed. It still displays either 2G or 4G.
    06-15-2013 11:32 PM
  15. metalchick719's Avatar
    I think you're right about the phone never displaying a 3G signal. I have my 810 unlocked and travel internationally to places where no 4G signal exists, yet the phone only displays either 4G or 2G. I returned the phone back to Nokia complaining about this and some other issues. Nokia claimed all complaints were fixed but nothing has changed. It still displays either 2G or 4G.
    That's a typical T-Mobile thing these days. I have the 810 as well but am using an unlocked Rogers Lumia 920 as of early May. It does have 3G listed in the network speeds under Settings, but when I select it, it gives me 4G. I never see 3G appearing on my phone. T-Mobile is weird that way.
    06-16-2013 03:29 PM
  16. Tony_Offends_U's Avatar
    That's a typical T-Mobile thing these days. I have the 810 as well but am using an unlocked Rogers Lumia 920 as of early May. It does have 3G listed in the network speeds under Settings, but when I select it, it gives me 4G. I never see 3G appearing on my phone. T-Mobile is weird that way.
    Mine is the exact opposite. Mine gives me 4G sometimes, but most of the time it says 3G.
    06-17-2013 09:22 PM
  17. shafff's Avatar
    How to switch 2g manually? Im usin lumia 810
    07-14-2013 07:08 PM
  18. shafff's Avatar
    Hi um using lumia 810 unlocked. Um frm sri lanka. How to switch 2g manually?? Please help!!
    07-14-2013 07:09 PM
  19. PB_H's Avatar
    Hi um using lumia 810 unlocked. Um frm sri lanka. How to switch 2g manually?? Please help!!
    You can't with the 810, you get what's out there 2G, 3G 3.75G ( yes) 4G there is not a manual control switch.
    07-14-2013 10:06 PM

Similar Threads

  1. Data Connection (and other) Issues with Quantum
    By zr2s10 in forum LG Quantum
    Replies: 4
    Last Post: 09-30-2011, 01:33 AM
  2. Windows Phone 7 Data Issues
    By MrGarrykf in forum Windows Phone 7
    Replies: 15
    Last Post: 04-13-2011, 08:14 AM
  3. Issues with data connection
    By Redbird1 in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 11-22-2010, 05:35 PM
LINK TO POST COPIED TO CLIPBOARD