1. Yipcanjo's Avatar
    I'm attempting to switch to the Lumia 820 from previous Lumia phones -- the 920 and the 720. Sadly, I'm seeing an issue that is also present on the Lumia 720, i.e.: with an SD card inserted, the camera takes longer to snap the first photo. The proceeding photos are typically snappy, but if you wait too long it seems to lag again. With the SD card removed, all photos snap quickly and consistently.

    Exact issue is described here: micro SD card mounting delay my Lumia 820 to take picture - Microsoft Community

    I've tried several SD cards -- Sandisk 32GB Class 10 (current), Kingston 64GB Class 10, and a Toshiba 4GB Class 4 -- all of them with the same results. The phone is also noticeably more laggy in other areas when the SD card is installed: Settings, Xbox Music, etc..

    Has anyone found a fix for this?
    05-03-2013 06:31 PM
  2. alllies's Avatar
    are those sd cards SDHC or SDXC? the later was advertised to have a faster read/write speed.
    Aren't this the same on android using SD cards?
    05-03-2013 06:58 PM
  3. Yipcanjo's Avatar
    are those sd cards SDHC or SDXC? the later was advertised to have a faster read/write speed.
    Aren't this the same on android using SD cards?
    I've used both SDHC and SDXC -- same issue in both cases. Perhaps more annoyingly, I have my phone set to Save Photos to the Phone and not the External Storage. In other words, it's supposed to be saving to the phone memory and not the SD card. Doesn't seem to matter, though, because simply having the SD card installed --- even if photos are set to save to the Phone Memory -- means that the first photo is slow to capture.
    05-06-2013 11:24 AM
  4. Sanjay Chandra's Avatar
    Well , I am using 64GB Sandisk class 10 card and everything is fine.
    05-06-2013 11:36 AM
  5. Mike RB's Avatar
    Your problem is the same as mine, though I'm using a 620. Even having it save to phone memory gives the same problem.

    Only removing the card resolves.
    05-06-2013 11:39 AM
  6. Yipcanjo's Avatar
    Well , I am using 64GB Sandisk class 10 card and everything is fine.
    Is it?

    With the card inserted, reboot the phone, open the camera, and take a picture. Time the process.

    Now, remove the card, reboot the phone, open the camera, and take a picture once again. Time the process.

    I'm betting the "card removed" photo was faster.
    05-07-2013 06:49 PM
  7. travis_valkyrie's Avatar
    I've been frustrated about this since day 1 I bought it. The native camera app lags as hell, but Proshot only takes its time saving the photo, so the outcome is that the native camera produces blurred photos even after snapping a photo, Proshot does not.
    05-07-2013 07:28 PM
  8. ssapre's Avatar
    Is it?

    With the card inserted, reboot the phone, open the camera, and take a picture. Time the process.

    Now, remove the card, reboot the phone, open the camera, and take a picture once again. Time the process.

    I'm betting the "card removed" photo was faster.
    I noticed that too... took a while when it takes first snap, but for me after first snap it goes pretty smooth.
    05-08-2013 02:00 PM

Similar Threads

  1. Attaching files to an email from the SD card
    By GraemeT in forum Nokia Lumia 820
    Replies: 0
    Last Post: 03-05-2013, 02:47 PM
  2. Replies: 30
    Last Post: 03-05-2013, 10:28 AM
  3. cant seem to get an answer on sd card thingy...
    By Zeroplanetz in forum Microsoft Surface for Windows RT
    Replies: 5
    Last Post: 02-22-2013, 05:54 PM
  4. Screen slow to repond when charging
    By Russell Broadbridge in forum HTC 8X
    Replies: 7
    Last Post: 01-09-2013, 10:49 AM
  5. Lag when saving media to SD Card
    By jiayit in forum Nokia Lumia 820
    Replies: 18
    Last Post: 01-02-2013, 09:37 AM
LINK TO POST COPIED TO CLIPBOARD