1. Chris Lovell Lowe's Avatar
    Hello everyone - I have a Nokia Lumia 820 on Vodafone, and I am really struggling with trying to get my MMS sorted out as I can't receive or send.

    I've spoken to Vodafone, they couldn't help me much but suggested I joined the Vodafone forum with my query - I did that - and someone wrote back asking that I post it to their customer services - I did that - someone got back to me, and I did as he asked - in turning phone off and taking SIM out and putting it all back. But it takes a day or two inbetween our messages because I get the usual standard reply email before he then emails me back!

    I'm still no further in finding out what is wrong - can anyone help here at all please, PLEASE?!!!

    Chris
    06-07-2013 09:28 AM
  2. AndyAndyAndy's Avatar
    Hi Chris,

    Assuming that you're on Vodafone UK it's worth checking your APN settings. To do this go to Settings -> Mobile Network -> Edit MMS APN. My settings are as follows:

    APN: MMS
    Username: wap
    password: wap
    WAP Gateway (URL): [BLANK]
    WAP Gateway Port: [BLANK]
    MMSC (URL): http://mms.vodafone.co.uk/servlets/mms
    MMSC port: 8799
    Maximum MMS Size: [BLANK}
    IP Type: IPv4v6

    I have just tried to send myself a test MMS and I think it's sent ok but I haven't received it yet (maybe that means my settings are bad too?). Write down your settings before changing to mine if they're different so you can always change back. I'm surprised that VF CS haven't tried sending you the message that updates the settings yet. Would've thought that's the easy first option.

    Hope that's of some use,

    Andy

    Edit: Just found this on the Vodafone Website
    You can get your internet (GPRS) and picture messaging (MMS) settings by text. Just text web to 40127
    . I'm going to try it out and will update the settings above if it has an impact. Otherwise assume that it has no effect for me (it might still be worth trying for you though)
    06-19-2013 06:18 AM
  3. AndyAndyAndy's Avatar
    Received my new settings which had no effect but I have found that the MMS didn't send and didn't come through until I had turned on mobile data (even though wifi was connected) so ensure you have mobile data on and available.
    06-19-2013 06:50 AM
  4. Fred P's Avatar
    MMS uses 3G cellular data, i didnt need to setup my MMS APN, made no difference.
    06-23-2013 09:14 AM
  5. skyscanr's Avatar
    I was having the same problem and it was driving me nuts.
    but then I changed the ip type to IPv4 and now MMS works just fine .
    09-01-2014 04:55 PM

Similar Threads

  1. Can't send MMS messages while on wifi
    By Steephill in forum Windows Phone 8
    Replies: 34
    Last Post: 05-02-2015, 08:14 AM
  2. Can send email but can't receive
    By jcar302 in forum Nokia Lumia 900
    Replies: 5
    Last Post: 12-14-2012, 06:03 AM
  3. Can't send MMS. Anyone here on T-Mobile U.K?
    By Retro_uk in forum Windows Phone 7
    Replies: 0
    Last Post: 12-10-2012, 12:45 AM
  4. Can't update or install Apps
    By herronm in forum Applications
    Replies: 5
    Last Post: 07-06-2011, 04:35 PM
  5. Replies: 5
    Last Post: 04-16-2011, 05:22 PM
LINK TO POST COPIED TO CLIPBOARD