1. Martin hfd's Avatar
    So i got this lumia 820...
    when i insert the sim everything works... after a while it shows that it has connection.. but it doesnt i am not reachable, i cannot make phone calls it drops every single one of them....
    what i have tried:
    hard reset, same result
    soft reset, same result
    button reset, same result
    took it to a phone repair shop, nothing
    same sim works good with other phones,
    rom reinstall, same result
    tinkering with network settings, nothing
    downgrade to wp8, nothing
    ------------
    so please i need suggestions on what to try... i dont have warranty and no nokia store nearby
    11-12-2014 07:47 AM
  2. Scienceguy Labs's Avatar
    Have you tried cutting a piece of paper to just smaller than the size of your SIM card and sliding it in behind the card? This might add some pressure to the card and keep the contacts against it. I had to do that a while back with my 920. It worked for me. Just a thought.
    Martin hfd likes this.
    11-12-2014 07:56 AM
  3. AmGaD-SaLaH's Avatar
    This SIM was working before?
    And try inserting another SIM
    11-12-2014 08:15 AM
  4. Martin hfd's Avatar
    the sim works... behaves exactly the same with other sim
    11-12-2014 08:54 AM
  5. AmGaD-SaLaH's Avatar
    the sim works... behaves exactly the same with other sim
    Maybe the SIM card port is not clean .. Try to make sure it's clean .. And make sure nothing broken inside it
    And try again
    11-12-2014 09:14 AM
  6. Martin hfd's Avatar
    will try that
    11-12-2014 09:24 AM
  7. Martin hfd's Avatar
    everything clean and in perfect order .. tnx anyways
    11-12-2014 09:25 AM
  8. Martin hfd's Avatar
    will try that tonight @scienceguy
    11-12-2014 09:26 AM
  9. Martin hfd's Avatar
    Have you tried cutting a piece of paper to just smaller than the size of your SIM card and sliding it in behind the card? This might add some pressure to the card and keep the contacts against it. I had to do that a while back with my 920. It worked for me. Just a thought.
    I cannot believe that the solution was that simple... (i feel like a dumbass hehe) i am writing this from my nl820 with working 3g connection for the last 10 hours.. I am happy as a pig in a blanket... Thanks again i owe u guys a beer.. Thanks you :D
    Scienceguy Labs likes this.
    11-12-2014 07:44 PM
  10. Scienceguy Labs's Avatar
    Glad you got your phone back in working order.

    I'll take you up on that beer. :)
    11-12-2014 07:50 PM
  11. Dominic Watts's Avatar
    Glad that fixed it because my son had something similar with a Lumia 920 and sent it back to Nokia. They posted it straight back and said that it was water damaged and wouldn't touch it. He now has one of my old 820s and seems happy.
    11-13-2014 08:44 AM

Similar Threads

  1. On my [L730] Lumia Selfie App, why are pictures mirrored?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 9
    Last Post: 11-14-2014, 12:38 PM
  2. Lumia 820 to 735
    By JimiDiGriz in forum Nokia Lumia 730 & 735
    Replies: 7
    Last Post: 11-12-2014, 06:46 PM
  3. Why don't movies fill entire screen? [Lumia 730]
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-12-2014, 09:35 AM
  4. Microsoft Lumia 535
    By Anand Rangaraj in forum Microsoft Lumia 535
    Replies: 2
    Last Post: 11-12-2014, 06:51 AM
  5. How much will it cost to fix the screen on my Lumia 1020?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-12-2014, 02:36 AM
LINK TO POST COPIED TO CLIPBOARD