1. skugg's Avatar
    I just received back my Lumia 820 after an USB connector replacement (it was jammed and couldn't charge the phone) after I moved to a new flat.

    Ever since then I have no wireless internet access on the phone. I can see the wireless router, can even connect to it and it shows as if it would establish a connection to the Wireless network, but I have no Internet connection on the phone itself.
    I checked the connection on the phone - I get an IP like 169.254.x.x and a mask with 255.255.0.0

    Meanwhile in the router's settings I don't even see the phone listed below the DHCP clients either even though the phone indicates that it is actually connected to the network.

    This IP indicates to me that it is an issue somewhat related to the DHCP service, but I have no useful knowledge regarding this incident.

    The situation is further complicated by the fact that there are 3 other devices (a laptop, a desktop PC and my girlfriend's Lumia 640) connected to the same Wireless Router (all wirelessly) and they all work just fine (getting normal IPs from the DHCP), whilest my Lumia 820 has no internet connection.
    I've tried with my other network at my old flat, got the same issue (IP and mask-wise), no internet either, even though it used to work just fine. I personally did not change anything on the phone, however I do not know what couldd have been changed setttings-wise during the USB repair.

    The network is not limited by MAC Addresses as those devices connected just automatically and they all work fine. And the number of devices connected are also not limited as I've tried disconnecting a device while connecting with my phone - same result.

    The DHCP setting is also enabled as the other devices can connect nomrally - as pointed out earlier.

    I haven't installed any updates or apps on the phone itself. I've just recently updated my PC from Win 7 to Win 10, but it has hardly anything to do with the problem itself.

    I would appreciate any feedbacks or possible solutions as it would be vital for me to be able to read emails on my Phone using WiFi connection.

    Thanks in advance for your input!
    08-31-2015 11:18 PM
  2. gpobernardo's Avatar
    Your phone should still be under warranty of the service center (if that's where you had your phone repaired) - so bring your phone back to them and report the new issue, telling them that it happened only after the repair was done. They should cover the additional repairs, since it seems that they caused the damage this time.
    09-02-2015 10:15 AM
  3. bubbi jamaica's Avatar
    hi, if u have wifi 5ghz, try to disable it and use the 2.4ghz...
    09-25-2015 05:01 AM

Similar Threads

  1. In Windows 10 I get Gmail and Yahoo mail into my mail but not Outlook 2013, why?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 09-05-2015, 10:43 PM
  2. Do Lumia 720 in India get an 8.1 GDR 2 Update???
    By rohandibag in forum Nokia Lumia 720
    Replies: 4
    Last Post: 09-03-2015, 01:16 AM
  3. Why is Viber not working on my Windows 7 pc but is on my phone?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-02-2015, 09:58 AM
  4. Who accessed my OneDrive files?
    By Windows Central Question in forum OneDrive
    Replies: 1
    Last Post: 08-31-2015, 11:09 PM
LINK TO POST COPIED TO CLIPBOARD