1. roguedog's Avatar
    Apologies if this is already answered somewhere. Did try search and didn't find something similar.

    Just received a phone off ebay and seems like when I leave it overnight to charge back up, in the morning (only had it 2 days) the phone is totally dead. Won't power up unless I pull the battery then it seems fine.

    Is this a known issue? Do I need a new battery? If so, any suggestions for replacements?

    Thanks!

    5/6 Update: Renaming thread since the phone seems fine throughout the day but 2 night when it likely goes into sleep mode for a "long" period of time, it seems to power down and then requires a battery pull to come back. Not sure if this is related to the random power down thread..
    Last edited by roguedog; 05-06-2013 at 09:42 AM.
    05-05-2013 11:54 AM
  2. ttsoldier's Avatar
    Was it a brand new phone or used phone off ebay?
    05-05-2013 11:57 AM
  3. AR2186's Avatar
    My girlfriend had an 822 for a week, brand new, and it would just shut off overnight relatively often. I think its a known issue at VZW and is going to get fixed in a firmware update. That said, we returned it and got an 8x
    05-05-2013 12:23 PM
  4. roguedog's Avatar
    Yep. 2nd hand (ebay). I know.. "anything could have happened." This is why I want to find out if it's a known issue or potentially bad battery or whatever else from this community :). After I pull battery it's been fine and normal all day today.
    05-05-2013 11:30 PM
  5. roguedog's Avatar
    Actually .. what seems to be happening is when it sleeps for some long period of time it powers down. Like in this thread.
    05-06-2013 09:39 AM
  6. Nathan Taylor1's Avatar
    Might be your password/pin, if you are using one.
    I had been having a similar issue up until recently. went through 2 or 3 different phones (not sure if I got my old one or a replacement one of the times.) before I finally figured it out.
    Before, I always used a password, and I would occasionaly have to pull my protective case off to pull the battery. Very irritating. Ever since I stopped using a password, I haven't had the issue.
    Don't know why this would happen, but it was the only thing I could think of that was different about my phone vs my wife's phone (same phone bought the same day.), since she hadn't been having that problem.
    Hope this helps, :D
    06-17-2013 12:05 AM

Similar Threads

  1. Can you suggest apps for me? New to WP8
    By Muessig in forum Applications
    Replies: 11
    Last Post: 12-10-2012, 01:13 AM
  2. Replies: 1
    Last Post: 11-20-2012, 11:04 PM
  3. Replies: 4
    Last Post: 02-16-2012, 12:41 PM
  4. Replies: 9
    Last Post: 01-25-2012, 07:15 PM
  5. New to the WP scene.. tell me all!
    By samlilli in forum Windows Phone 7
    Replies: 11
    Last Post: 12-24-2011, 08:18 AM
LINK TO POST COPIED TO CLIPBOARD