1. vriship's Avatar
    Hello,
    Need help from any one having any idea about Nokia care suite flashing.
    Downloaded the .0003 firmware files to downgrade from portico on my lumia 822. Flash started and I got the flash progress bar, but within 30 seconds there was a failed status on NCS and the phone is stuck on NOKIA logo(the one which comes before flashing in the top part of the screen without applying the button combo to enter flash mode) immediately after Verizon logo and wont get detected by NCS anymore. :(

    tried on x64 and x86 based systems both. phone gets detected by windows but device manager says unknown device and every time I try to start the flash process by power + volume down and then volume up after short vibration, NCS repeatedly gives retry option and doesn't detect the phone. Also phone doesn't get reset by the button combo just immediately switches to the NOKIA logo after Verizon logo on every instance I start the phone.

    Any help would be highly appreciated.

    Note: I have used the latest Nokia care suite.
    08-05-2013 12:57 AM
  2. Laura Knotek's Avatar
    What version of Windows are you running?

    Did you install the drivers needed for Nokia Care Suite?
    08-05-2013 01:00 AM
  3. vriship's Avatar
    ^^ windows 8 pro 64 bit. also tried on a windows 7 32 bit system.

    Do i need to download any drivers separately? i installed the ones which come under the care suite folder in program files.
    08-05-2013 01:05 AM
  4. Laura Knotek's Avatar
    ^^ windows 8 pro 64 bit. also tried on a windows 7 32 bit system.

    Do i need to download any drivers separately? i installed the ones which come under the care suite folder in program files.
    I'm not sure about the drivers, but you might want to check out this video.
    08-05-2013 01:14 AM
  5. vriship's Avatar
    i didnt get the winusb x64 drivers setup when i installed the latest care suite. Will give the NCS version used in the link a try, thanks for sharing the link to the video. I hope it works.
    08-05-2013 02:25 AM
  6. vriship's Avatar
    I'm not sure about the drivers, but you might want to check out this video.
    hi,
    i followed the video and installed the drivers for x64 system(winusb) but no luck.. :( same, always gives me retry option. used different cable, port, system but same result. phone directly goes on nokia logo(the one which we get before flash) and windows detects phone but says device not recognized.
    08-05-2013 10:05 AM

Similar Threads

  1. Lumia 920 (Black) - UNLOCKED Pentaband (Works fully on T-Mobile & ATT)
    By AbsoluteZerow in forum Marketplace Archive
    Replies: 12
    Last Post: 08-12-2013, 03:03 PM
  2. Share your Nokia Pro Camera app settings
    By wheelerk in forum Nokia Lumia 1020
    Replies: 4
    Last Post: 08-05-2013, 07:41 AM
  3. rom image of complete phone Lumia 520
    By kaybee327 in forum Nokia Lumia 520
    Replies: 3
    Last Post: 08-05-2013, 03:58 AM
  4. Replies: 3
    Last Post: 08-04-2013, 10:51 PM
  5. phone got dead
    By Ojesh Jain in forum Nokia Lumia 720
    Replies: 2
    Last Post: 08-04-2013, 10:04 PM
LINK TO POST COPIED TO CLIPBOARD