1. senai's Avatar
    Does anyone else have the problem of their Lumia 822 running very slowly or is it just me?
    I have a lumia 822 with the black update. Of late, I have noticed its gotten really bad. I get issues like :-
    - apps taking too long to install
    - apps taking too long to open, sometimes not opening at all(including the start screen)
    - apps randomly exiting out
    - taking long to do things within apps once they open.
    - start screen taking long to load and scroll.

    Just to name afew. Could it be that I have too many apps? Or that my memory is too low? Or my SD card is too slow?. . . I tried deleting things and got upto just above 1gb free memory, but it still didn't help much(especially when installing apps!), but its definitely gotten worse as my free memory decreases.

    Help?
    03-24-2014 03:10 AM
  2. N_LaRUE's Avatar
    Have you tried doing a hard reset? That may be your only option here. It unfortunately erases everything on your phone but you can back up prior to doing it. Game data will be erased however unless the developer enabled backup to OneDrive.

    Hard reset -> Settings -> About -> Reset phone
    03-24-2014 06:42 AM
  3. senai's Avatar
    Have you tried doing a hard reset? That may be your only option here. It unfortunately erases everything on your phone but you can back up prior to doing it. Game data will be erased however unless the developer enabled backup to OneDrive.

    Hard reset -> Settings -> About -> Reset phone
    yea, I did that, but as soon as ai restored everything back. . . It was back at it again. . .
    03-24-2014 10:18 AM
  4. vk1971's Avatar
    After Black update I too noticed that apps take slightly more time to install
    Overall "slowdown" might be caused by your CD card.
    03-24-2014 11:28 AM
  5. senai's Avatar
    After Black update I too noticed that apps take slightly more time to install
    Overall "slowdown" might be caused by your CD card.
    I was suspecting the SD card, but I just didn't see the relation. . . I'll try and take it out and see if there is any change. . .
    My install time isn't just slightly slower though, it takes waaaaaaay toooo long! . . .
    03-24-2014 01:59 PM
  6. senai's Avatar
    Definitely not the SD card. . .
    03-25-2014 03:01 AM
  7. SpaceyO's Avatar
    yea, I did that, but as soon as ai restored everything back. . . It was back at it again. . .
    It was slow again once you had everything restored? Have you looked into any recently installed apps?
    03-25-2014 08:20 AM
  8. senai's Avatar
    It was slow again once you had everything restored? Have you looked into any recently installed apps?
    yeah it was. . . I can't tell coz I have hundreds of apps installed. . .
    03-26-2014 07:29 AM
  9. thomasdtran's Avatar
    Yeah I have noticed it runs really slow while it is installing an app. I can't tell if it is one app causing the issue or if it is the system.
    03-26-2014 07:40 AM
  10. SpaceyO's Avatar
    yeah it was. . . I can't tell coz I have hundreds of apps installed. . .
    If you go to the Windows Phone Store, you can see your apps installed sorted by purchase date. I'd start there and see if you can find the culprit.

    https://www.windowsphone.com/en-us/my/purchase-history
    03-26-2014 10:30 AM
  11. senai's Avatar
    If you go to the Windows Phone Store, you can see your apps installed sorted by purchase date. I'd start there and see if you can find the culprit.

    https://www.windowsphone.com/en-us/my/purchase-history
    the problem started a while back, I can't pinpoint when exactly. And weirdly, sometimes it works ok, but other times it annoyingly slow. . .
    03-27-2014 03:08 AM
  12. senai's Avatar
    And where exactly in the store does it show the apps I've installed by date?

    Edit: never mind, I assumed you meant the store on the phone.
    03-27-2014 03:12 AM
  13. dby2011's Avatar
    Check what you have running in the background too- that can cause a slowdown. It is probably a running app causing issues. You can disable apps one by one to try to figure out what was the issue. If you already did a hard reset the sd card is not the problem.
    03-27-2014 08:03 AM

Similar Threads

  1. Unlocked Nokia Lumia 920
    By Alienhead95 in forum Marketplace Archive
    Replies: 17
    Last Post: 08-12-2014, 02:11 PM
  2. Audio Equalizer update is not working in Nokia Lumia 525
    By SatishMonster in forum Windows Phone 8
    Replies: 4
    Last Post: 04-26-2014, 08:49 AM
  3. Issues on an unlocked lumia 925
    By GOKULKRISHNA in forum Nokia Lumia 925
    Replies: 3
    Last Post: 04-25-2014, 08:02 AM
  4. Hello! I am from Guatemala, and have a new Lumia 625! :)
    By bionicgt in forum New to the Forums? Introduce Yourself Here!
    Replies: 8
    Last Post: 03-25-2014, 04:04 PM
  5. How to speed up scrolling / swiping speed on Nokia Lumia 520?
    By Law or Grace in forum Windows Phone 8
    Replies: 5
    Last Post: 03-23-2014, 12:04 PM
LINK TO POST COPIED TO CLIPBOARD