1. greedo_greedy's Avatar
    Hi guys,

    I figured with the latest build being fine as a daily driver I would finally install Windows 10 on my Lumia 822.

    However, it seems that installation is never successful, I would always get an error after "installation".

    Regardless if I use Fast Ring or Slow Ring.
    07-24-2015 06:57 PM
  2. Laplaz's Avatar
    Do you try reset before update?
    07-25-2015 06:05 AM
  3. EL620's Avatar
    Been using w10 as my daily driver for over a month ( jun 14 - now). Start clean before upgrading.
    07-25-2015 09:14 PM
  4. greedo_greedy's Avatar
    ^ It's difficult to start clean especially when I might lose my game progress.
    Haha
    07-26-2015 01:53 AM
  5. badcat's Avatar
    I have it installed on my 822. I needed to hard reset after I got it installed because it was unusable. It's still kind of slow after the reset, but everything is working and it's the first build I haven't rolled back to 8.1.
    07-26-2015 10:43 AM

Similar Threads

  1. Feedback needed from anyone with L1020 running W10 TP
    By Skamath in forum Nokia Lumia 1020
    Replies: 21
    Last Post: 08-18-2015, 10:22 AM
  2. windows hello and the surface pro 3
    By Jcmg62 in forum Windows Hello
    Replies: 7
    Last Post: 08-04-2015, 04:39 AM
  3. Replies: 10
    Last Post: 07-25-2015, 09:42 AM
  4. Will upgrading to Windows 10 reset my product activation?
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 07-24-2015, 07:36 PM
  5. Replies: 0
    Last Post: 07-24-2015, 05:45 PM
LINK TO POST COPIED TO CLIPBOARD