1. jedivulcan's Avatar
    Unstable Reception:

    I received my device at around 11:30AM this morning and followed my e-mail instructions on how to activate the phone with the online with the IMEI and the ICCID. The SIM card was pre-installed when I received it. The old SIM card on my iPhone 4 suddenly had "No Service" and signal started picking up on my Lumia 900.

    I shouldn't hold my breath.

    At my home, I get 3-4 bars of 2G reception and 1-2 bars of 3G or "4G" normally (from what I see on my iPhone 4 and my sister's iPhone 4S). The coverage map says I'm in an LTE area but so far my Lumia 900 hasn't picked up a signal. I'm almost in a fringe area but my Lumia 900 isn't picking up any signal.

    I'm looking at my phone right now and there's a cross over the reception bars and I can't make/send calls, access data features, or text message.

    That's how it is. If I restart my phone, it'll either have no signal like I described or I'll get one bar of 4G before it drops to 2G EDGE (at around 4 bars), then it'll show a cross over the signal bar.




    I checked my account using the AT&T app on my iPhone 4, the Lumia 900, and on my laptop, and it shows no data plan. I have a selection of data plan options for non-smartphones but nothing is selected. My e-mail when I ordered confirmed a $30 a month Unlimited LTE plan (as an upgrade from my iPhone 4's unlimited data plan).

    I called AT&T and spoke with a Premier CSR. I went through all the troubleshooting steps. Restarted the phone, removed and reinserted the SIM card (a few times), and even had a "manual" reset done. I was able to get a confirmation call and text. Problem solved? Nope. It started doing it again.

    I also asked about my unlimited LTE data. The CSR confirmed multiple times that nothing has changed on my account and the LTE unlimited data plan is there. However, I was literally staring at three other screens on my end that say otherwise.

    Screen Quality -

    The other issue I had is screen quality. Maybe I'm not used to the darker interface or AMOLED displays ... but the moment I started using Internet Explorer, the whites seemed very grainy and the color temperature was very warm. Is that ClearBlack It takes my second to adjust but it still doesn't look very clear. I'm not sure if anyone's had or reported the similar issues or whether I'm being a bit too subjective here.

    Any help or suggestions (particularly on the first part of my post)?

    Missing Gel Case - While I was writing my post, I got a shipping notification for a Nokia Gel Case I'd ordered separately (different order number) on the same day I pre-ordered the Lumia 900 on March 30th. I just checked the tracking number and it's the same one as my phones. I only got the phone in the box, no gel case. Packing slip makes no mention of a gel case.

    Lastly - AT&T didn't charge me for my order yet. My bank account shows no holds or withdraws. Is this normal?

    What the frak is going on?

    I'm thinking about returning the phone. It's a really nice design and feels great in the hand but other than that, it's been kind of a let down ... particularly in the primary functionality of the phone (cell connectivity) and the screen.

    I guess I have nothing to return if I haven't been charged for it? I'm confused. Help!
    04-06-2012 05:12 PM
  2. tekhna's Avatar
    OK Josh. ;)
    jedivulcan likes this.
    04-06-2012 05:15 PM
  3. sting7k's Avatar
    Wierd, my Lumia is getting better reception than my iPhone 4.

    You may want to go to AT&T, sounds like something is off about your data plan. Did you complete the activation?

    Whites looked good on my screen. But browsing the web and resizing pages is a far cry from the resizing and refocusing the iPhone can do; text is quite blurry still in some cases. But I think that is more the lower resolution screen.
    04-06-2012 05:17 PM
  4. tissotti's Avatar
    Yet the cell connectivity and screen quality has exactly been the two things praised everywhere.

    Though on Lumia 900 because of the Windows Phone limitation is quite low resolution. AMOLED is definitely different than LCD.
    04-06-2012 05:19 PM
  5. diegosalinas's Avatar
    I suggest calling or going in person to have someone check out the data plan.

    I had issue with mine and it turned out they didn't switch me to "the smartphone plan that allows LTE" according to the phone rep.

    The screen looks great to me.

    I'm sorry that things are starting off rocky for you. :(
    04-06-2012 05:30 PM
  6. 12Danny123's Avatar
    Unstable Reception:

    I received my device at around 11:30AM this morning and followed my e-mail instructions on how to activate the phone with the online with the IMEI and the ICCID. The SIM card was pre-installed when I received it. The old SIM card on my iPhone 4 suddenly had "No Service" and signal started picking up on my Lumia 900.

    I shouldn't hold my breath.

    At my home, I get 3-4 bars of 2G reception and 1-2 bars of 3G or "4G" normally (from what I see on my iPhone 4 and my sister's iPhone 4S). The coverage map says I'm in an LTE area but so far my Lumia 900 hasn't picked up a signal. I'm almost in a fringe area but my Lumia 900 isn't picking up any signal.

    I'm looking at my phone right now and there's a cross over the reception bars and I can't make/send calls, access data features, or text message.

    That's how it is. If I restart my phone, it'll either have no signal like I described or I'll get one bar of 4G before it drops to 2G EDGE (at around 4 bars), then it'll show a cross over the signal bar.

    Click to view quoted image



    I checked my account using the AT&T app on my iPhone 4, the Lumia 900, and on my laptop, and it shows no data plan. I have a selection of data plan options for non-smartphones but nothing is selected. My e-mail when I ordered confirmed a $30 a month Unlimited LTE plan (as an upgrade from my iPhone 4's unlimited data plan).

    I called AT&T and spoke with a Premier CSR. I went through all the troubleshooting steps. Restarted the phone, removed and reinserted the SIM card (a few times), and even had a "manual" reset done. I was able to get a confirmation call and text. Problem solved? Nope. It started doing it again.

    I also asked about my unlimited LTE data. The CSR confirmed multiple times that nothing has changed on my account and the LTE unlimited data plan is there. However, I was literally staring at three other screens on my end that say otherwise.

    Screen Quality -

    The other issue I had is screen quality. Maybe I'm not used to the darker interface or AMOLED displays ... but the moment I started using Internet Explorer, the whites seemed very grainy and the color temperature was very warm. Is that ClearBlack It takes my second to adjust but it still doesn't look very clear. I'm not sure if anyone's had or reported the similar issues or whether I'm being a bit too subjective here.

    Any help or suggestions (particularly on the first part of my post)?

    Missing Gel Case - While I was writing my post, I got a shipping notification for a Nokia Gel Case I'd ordered separately (different order number) on the same day I pre-ordered the Lumia 900 on March 30th. I just checked the tracking number and it's the same one as my phones. I only got the phone in the box, no gel case. Packing slip makes no mention of a gel case.

    Lastly - AT&T didn't charge me for my order yet. My bank account shows no holds or withdraws. Is this normal?

    What the frak is going on?

    I'm thinking about returning the phone. It's a really nice design and feels great in the hand but other than that, it's been kind of a let down ... particularly in the primary functionality of the phone (cell connectivity) and the screen.

    I guess I have nothing to return if I haven't been charged for it? I'm confused. Help!
    I think you should contact Nokia USA for the problems you are having http://www.nokia.com/us-en/support/contact/
    04-06-2012 05:41 PM
  7. ljkelley's Avatar
    Could be defective. Try an exchange.
    04-06-2012 06:02 PM
  8. ParrotHeadFL's Avatar
    That's how it is. If I restart my phone, it'll either have no signal like I described or I'll get one bar of 4G before it drops to 2G EDGE (at around 4 bars), then it'll show a cross over the signal bar.
    I'm having the same problem with mine. Or at least, I had that problem all day yesterday. I'd go from having 3-4 bars of 3G (actually, the phone said 4G but I don't believe this is a 4G area) down to having 1-2 bars, then it would jump to 4 bars of EDGE, then maybe no signal at all. It dropped a call on me three times in a row.


    At first I thought AT&T was having service issues in the area, but AT&T support said there were no known issues in the area.

    And to make matters worse, the phone is rebooting on me periodically for no obvious reason. I've seen it happen four times. It has probably happened more times when I wasn't looking.

    So today I'll contact AT&T and see about getting a replacement.
    04-10-2012 05:54 AM
  9. Smeadly's Avatar
    Unstable Reception:


    Screen Quality -

    The other issue I had is screen quality. Maybe I'm not used to the darker interface or AMOLED displays ... but the moment I started using Internet Explorer, the whites seemed very grainy and the color temperature was very warm. Is that ClearBlack It takes my second to adjust but it still doesn't look very clear. I'm not sure if anyone's had or reported the similar issues or whether I'm being a bit too subjective here.
    You are not alone with this. Don't get me wrong, I was very impressed with this phone,
    but it was this issue that made me bring the phone back. My eyes tend to be very sensitive to this. It seems it is more of an issue of rendering web pages at the resolution of the display. Everything seems just ever so slightly blurred in IE. While most will not be bothered by this, to me, it's just asking for a headache every time I open IE.

    When Nokia drops a Windows 8 phone with a higher resolution display, i'll be all over it. Nokia Drive is just amazing and don't even get me started about that shuffleboard game (i'm already having withdrawals from it).
    04-10-2012 08:29 AM
  10. Final-MacGyver's Avatar
    I have the same reception issues. I have a Micro Cell in my home, without it I have 1 or 2 bars, with it I have the full 5. I have noticed multiple time now that I have no sevice on the phone when in my house and I have to "try" to make a call before the phone will wakeup and realize that there is service and then it jumps back to the full 5 bars.
    04-10-2012 11:00 AM
LINK TO POST COPIED TO CLIPBOARD