1. BallistaMan's Avatar
    Under what circumstances should the camera button launch the app? I'm finding that I cannot launch the camera using the hardware button while the phone is locked and asleep. It works fine when the phone is in use or if i tap the power button first (even if I don't unlock the device). Is this normal? I've checked through the settings and I believe that it should be working (press and hold to wake is on and accidental launch is off).
    04-08-2012 07:33 PM
  2. kevinrstruck's Avatar
    When I press and hold the camera button for a few seconds when the phone is asleep, it does launch the camera app.
    04-08-2012 08:04 PM
  3. altano's Avatar
    It has been hit or miss for me on my new Lumia as well as my original Focus. I just tested it and it didn't work if I locked and the phone and put it to sleep.

    It doesn't bother me too much since it's so easy to just hit the power button and then the camera button (while still locked and everything).
    04-08-2012 08:11 PM
  4. BallistaMan's Avatar
    @kevinstruck, yeah that's how I figured it was supposed to work.

    @altano, indeed, it's not a big problem by any stretch. Think it's safe to assume that the issue is software/firmware related and not a hardware issue with my device?
    04-08-2012 08:35 PM
  5. jtshorns's Avatar
    Was just noticing this today.....really bothers me. My focus, titan and focus s operate properly, not sure why the Nokia doesn't. Very dissapointing since this is a big feature for this platform......now we're relegated to a firmware update

    Sent from my Lumia 900 using Board Express
    04-08-2012 08:44 PM
  6. RockPaperBFG's Avatar
    Mine works perfectly just like my Samsung Focus did. Make sure "Prevent accidental camera launch when phone is locked" is set to off and "Press and hold camera button to wake up the phone" is set to on under the pictures and camera settings.
    kevinrstruck likes this.
    04-08-2012 08:48 PM
  7. milk242's Avatar
    I believe my Lumia 900 has a hardware glitch. The button is loose compared to the power and volume rocker. I can press mine and feel a click like it is pressing the button, but it doesn't activate the camera, I have to press it further down and I get a second click that activates it. This second click makes the button travel further than I think it should so I will exchange tomorrow morning.

    Other than that, my first experience with WM7 is great.
    04-08-2012 08:55 PM
  8. haleme's Avatar
    I found that if I disable "Press and hold camera button to wake up the phone," power the Lumia off and on, then re-enable that setting, it works again. Have had to do this twice since I got it Friday afternoon.
    04-08-2012 09:01 PM
  9. RockPaperBFG's Avatar
    The camera button is a two stage button (normally for focusing and then taking the pic). You need to press it all the way down to the second stage and hold it for it to wake the phone and bring up the camera app.
    04-08-2012 09:02 PM
  10. BallistaMan's Avatar
    I believe my Lumia 900 has a hardware glitch. The button is loose compared to the power and volume rocker. I can press mine and feel a click like it is pressing the button, but it doesn't activate the camera, I have to press it further down and I get a second click that activates it. This second click makes the button travel further than I think it should so I will exchange tomorrow morning.

    Other than that, my first experience with WM7 is great.
    Yeah mine feels looser than the others too (can be wiggled side to side slightly), though that could be chalked up to the first stage. My issue definitely isn't because I'm not pressing the button enough, the usual "halfway to focus, all the way to capture" works fine any other time, and fully pressing the button any other time will launch the camera app.

    It just won't work when the phone is locked and asleep (screen is off). :dry I did just try the setting changes/reboot trick that haleme mentioned to no avail.
    04-08-2012 09:56 PM
  11. lildrgn's Avatar
    Hmm. Mine appears to be a little erratic as well.

    Sent from my Lumia 900 using Board Express
    04-08-2012 10:29 PM
  12. jhoff80's Avatar
    I'm not half-holding the button, the button is being pressed all the way down, and the settings are correct. Also, my button is solid, and works fine in the camera app every time.

    That being said, the camera waking from sleep sometimes works and sometimes doesn't for me as well.
    04-08-2012 10:53 PM
  13. sj55555's Avatar
    The DVP had this issue, and it turned out that it was tied to the proximity sensor. If you had your fingers or face near the proximity sensor, the phone wouldn't wake through the camera button.
    04-08-2012 11:42 PM
  14. BallistaMan's Avatar
    I think you may be on to something there. I've been able to get it to work by shifting how I hold the top of the phone (left side when using it as a camera). Trying to locate that sensor (is it with the light sensor next to the camera?).
    04-08-2012 11:52 PM
LINK TO POST COPIED TO CLIPBOARD