1. hasasimo's Avatar
    Not sure if this is a glitch, bug, or what, but the batter never goes past 99% when charging. The battery animation on the top right also keeps showing that it's charging. On my Lumia 800 the charging animation would turn into a static icon to show that the battery was 100% charged. Also the battery indicator would read "100%."

    The battery life seems to be fine, so this is no big deal to me, but I find it a bit strange, especially knowing that my other Lumia device does reach 100%. Does anybody else have this issue?
    04-16-2012 10:11 AM
  2. Duvi's Avatar
    Take the usb out and put it right back in to the phone... See if it shows charged after.
    hasasimo likes this.
    04-16-2012 10:14 AM
  3. raruhs's Avatar
    Hi all,
    I have seen that too. I usually charge it overnight and what it seems to be happening is that while the phone reach 100% it stops charging and start to discharge, even it is connected. It is just my appreciation of what could be happening.

    Maybe it is a bug at the charging management, but I do not how to test to see if this is what it is really happening.

    Regards,
    04-16-2012 10:24 AM
  4. mayoo's Avatar
    This is a known issue .. it wont charge to 100% if wifi is ON .. turn wifi off
    hasasimo likes this.
    04-16-2012 10:34 AM
  5. hasasimo's Avatar
    Thanks for the responses. The next time I charge I'll try both suggestions and report back. Good to know its not a defect in my handset. Perhaps a future update will address this.
    04-16-2012 11:15 AM
  6. Duvi's Avatar
    This is a known issue .. it wont charge to 100% if wifi is ON .. turn wifi off
    Not all Lumia devices? I was on wifi when I was charging my device. I did however update my device right out the box when I got home, so maybe it was fixed in the latest update?
    04-16-2012 11:23 AM
  7. mayoo's Avatar
    Sorry for my wording .. i meant its a known issue on mine and i saw many complaining.. i dont know if Nokia knows about this ..
    04-16-2012 12:54 PM
LINK TO POST COPIED TO CLIPBOARD