1. wastegate's Avatar
    So I've had this phone for about a week now and when I plug her in to charge, using the provided charger, it takes 3 - 4 hours for it to charge fully. And this is when the phone has still got about 1/4 to 1/3 of juice still left. Anyone else notice this? This is a concern for me as I can hardly get through the day with one full charge and if it takes forever to charge plugged into a wall, it can tie me down uncessairly. Does the battery life improve with use? Some input would be appreciated. Thanks in advance.
    04-23-2012 06:57 PM
  2. dkp23's Avatar
    Yes, i've noticed..i do not differently as my focus S took forever to charge as well.

    Im assuming normal for WP7 phones,
    04-23-2012 07:05 PM
  3. wastegate's Avatar
    Yes, i've noticed..i do not differently as my focus S took forever to charge as well.

    Im assuming normal for WP7 phones,
    Well, that sucks! Especially since these phones do not have removable batteries. Means that you're stuck waiting or have to leave the phone at home to charge. This might be a deal breaker for me.
    04-23-2012 07:13 PM
  4. CDG's Avatar
    Mine takes about 2-2.5 hours. No different than my Androids did. I have had mine for exactly 2 weeks as of today.
    04-23-2012 07:22 PM
  5. Laura Knotek's Avatar
    I already had a Seidio charging vault before I got my Lumia 900. The Seidio charging vault works great for when I am on the go.
    04-23-2012 08:59 PM
  6. joeaux's Avatar
    About the same as my iPhones and my Atrix 4G. Not too bad.
    -joe-
    04-23-2012 09:48 PM
  7. jimski's Avatar
    Just checked the history in my Battery Status app and I went from 33% at 2:04am to 100% (the first time) at 4:04am. App checks every 10 minutes so the above numbers are +/- 10 min. My experience has been about 3 hours for a full charge, below 10% to 100%. I use a USB backup charger for walking around the house though. Beats being tethered to the wall.

    Sent from my Lumia 900 using Board Express
    04-23-2012 10:24 PM
  8. Duvi's Avatar
    Mine seems to charge pretty fast. Comparing to my Focus S, it's crazy fast.

    My iPhone and BlackBerry can charge up the fastest though.
    04-23-2012 10:27 PM
  9. Laura Knotek's Avatar
    Just checked the history in my Battery Status app and I went from 33% at 2:04am to 100% (the first time) at 4:04am. App checks every 10 minutes so the above numbers are +/- 10 min. My experience has been about 3 hours for a full charge, below 10% to 100%. I use a USB backup charger for walking around the house though. Beats being tethered to the wall.

    Sent from my Lumia 900 using Board Express
    Which app are you using? A Marketplace search for "Battery Status" did not find anything.
    04-23-2012 10:33 PM
  10. jimski's Avatar
    Sorry. Its a homebrew (sideloaded) app available at XDA-Developers. I registered as a Developer last year to access the registry to troubleshoot Live Tiles and endpoints (a long story). Decided to renew my dev registration ($99/year) because the few apps I have sideloaded are essential for me:
    -BatteryStatus - shows battery percent in a Live Tile and includes a graph of battery usage since last restart
    -Screen Capturer - takes screenshot
    -Folders - create folders/hubs on your Start screen to quick access/launch apps.

    These apps are not pemitted in Marketplace as they use APIs that are not allowed. None of these mess with your registry though, so no stability issues.

    Ok, now back on topic.

    Sent from my Lumia 900 using Board Express
    04-23-2012 10:52 PM
  11. The def star's Avatar
    Mine usually takes about 2.5 hours through the wall charger when it's almost depleted and about 4 hours through the USB cable with my computer. Faster than my HD7 but then I had that since launch.
    04-23-2012 11:13 PM
  12. nokia4life's Avatar
    Mine has never taken 2.5 hours to charge via wall charger I would say it was less than an hour. A far as USB that would be a little over 95 Mins and is expected since it does not out out as much power as a wall.charger


    Sent from my Lumia 900 using Board Express
    04-24-2012 01:29 AM
  13. gskimmel's Avatar
    I think mine charges super fast compared to my iPhone.
    04-24-2012 05:21 PM
  14. invertme's Avatar
    Mine charges very fast. Much much faster than my Focus. If I let it charge for about 2 hours from empty it will almost be full again.
    04-24-2012 07:13 PM
  15. For Honor's Avatar
    It uses micro USB and not some proprietary dongle so I'm happy even if it seems to take awhile =)
    04-24-2012 07:18 PM
  16. invertme's Avatar
    Ohh and to the OP, are you charging it through the computer or wall socket? If you do it on the computer it does take forever.
    04-24-2012 07:26 PM
  17. wastegate's Avatar
    Ohh and to the OP, are you charging it through the computer or wall socket? If you do it on the computer it does take forever.
    Always the wall charger. Seems to take way too long via the USB on any computer.
    04-24-2012 07:47 PM
  18. invertme's Avatar
    Always the wall charger. Seems to take way too long via the USB on any computer.
    Well there is always the "Do a hard reset and see if it helps" plan... If it doesn't I'd swap it out.
    04-24-2012 07:52 PM
  19. wastegate's Avatar
    Well there is always the "Do a hard reset and see if it helps" plan... If it doesn't I'd swap it out.
    Not the dreaded HARD RESET!!! LOL I'm going to keep the Lumi. I'm starting to really like her and hope that the battery comes around. :D
    04-24-2012 08:02 PM
  20. MF73's Avatar
    I've had my wireless charger for about three weeks now. Initially I was pretty impressed at the speed, not far off a mains charger, but the last couple of days it is really slow, was on for 3 hours this morning on my desk and put an additional 10% in. Also the phone now seems to be getting hotter than usual when lifting it off the charger. Has anyone else had a problem with the speed of charging slowing right down? Or maybe something in the background is draining my battery quickly, anyway I can check what apps are using my battery?
    03-07-2013 08:58 AM
  21. Lol Dude's Avatar
    It's because the computer doesnt give lots of voltage comparing to the wall socket
    06-02-2014 03:58 PM
LINK TO POST COPIED TO CLIPBOARD