1. carmello2045's Avatar
    Ok, so I got the 900 on 4/6. I had the data issue, ran the update still didn't work. Got it replaced. A few days later, 2nd replacement had data issue and got that replaced. 3rd replacement, worked fine for 4 days then on wifi - could not get to any webpages; network works just fine. A master reset fixed this. Now, I cannot be in an app (Amazing Weather, any games, or news related apps) for more than 1 minute before BING pops up for no reason or voice control pops on and won't let me out of the program without rebooting the phone.

    I went to an AT&T store yesterday and they REFUSED to replace the phone a 4th time stating that the problem was not happening at that moment and it costs them $450 every time the phone is replaced. I stated I could give a damn about what it costs them as it is costing me time to keep dealing with this.

    Any ideas on what to do next short of cancelling service with them?
    04-30-2012 12:20 PM
  2. invertme's Avatar
    Work with Nokia support and explain the issue.
    carmello2045 likes this.
    04-30-2012 12:26 PM
  3. foosball's Avatar
    Try the OEM since they technically warranty the phone.

    Sent from my HTC Arrive using Board Express
    carmello2045 likes this.
    04-30-2012 12:27 PM
  4. rdubmu's Avatar
    after 4 times you had issues. I would honestly get another phone.
    carmello2045 likes this.
    04-30-2012 12:43 PM
  5. CJ Thunder's Avatar
    You can try my capacitive button fix. And by chance are your hands sweating acid 4 phones in a month? Bad batch from same factory? That is interesting.
    carmello2045 likes this.
    04-30-2012 01:02 PM
  6. carmello2045's Avatar
    You can try my capacitive button fix. And by chance are your hands sweating acid 4 phones in a month? Bad batch from same factory? That is interesting.
    What is your button fix?
    04-30-2012 01:04 PM
  7. rdubmu's Avatar
    I had one issue that didn't effect my performance. Top right corner had a clicking noise. For the capacitive buttons, I have noticed they are harder to press and you have to hit them just right.

    The L900 is the best phone i have ever owned.
    04-30-2012 01:05 PM
  8. dkp23's Avatar
    Not sure if you went into the store or called support, but perhaps call again? Not sure if they can deny you a warranty exchange if your phone is defective and you show them that it is defective.
    04-30-2012 02:06 PM
  9. TheDarKnight's Avatar
    same here dude, 3 times replaced the phone, still issues, they refuse to exhange, so I close my account with them and ATT can go to **** and nokia can go with them
    Last edited by TheDarKnight; 04-30-2012 at 03:23 PM.
    04-30-2012 03:13 PM
  10. CJ Thunder's Avatar
    What is your button fix?
    Well I think its hardware, as do many people here. I put it in the software bug list because I thought it was software but...do this at your own risk...

    Push on each button, somewhat hard, you will hear a click. Haven't had any other issues...but do this at your own risk. I didn't want to turn my phone in and get another as I just set up everything to look like my out going Focus.
    04-30-2012 07:44 PM
  11. cckgz4's Avatar
    Very sorry to hear that

    Sent from my Lumia 900 using Board Express
    04-30-2012 09:01 PM
  12. joeaux's Avatar
    The store may not do it but have you called AT&T customer support? They should cover you and the phone for a year. Try calling. I asked my store reps and they said AT&T should send you a new phone, then you ship your bad one back to them. I've replaced mine twice. Two cyans and both had some sort of radio issues. I got a third one (white) and it's perfect. Display, radios, buttons everything. All is good. They told me the next time I'd probably have to go through the company to get it replaced though (assuming I had another problem).
    -joe-
    04-30-2012 09:59 PM
LINK TO POST COPIED TO CLIPBOARD