1. txaggies07's Avatar
    There is a thread for people who got the $100 from AT&T. It seemed like about everyone did get it except for me. This thread is for those to chime in if they have yet to receive the $100 credit from AT&T and have a reasonable expectation to receive the credit. I ordered mine on 4/2 and still have not received my credit.

    Edit:
    Ordered through att.com off contract but logged into my account.
    Did one swap on Sunday since my phone bootlooped after running out of battery.
    Might be an issue with att since they for some reason had my phone listed as Skyrocket in their system.
    Last edited by txaggies07; 05-01-2012 at 10:57 PM.
    05-01-2012 10:31 PM
  2. Duvi's Avatar
    There is a thread for people who got the $100 from AT&T. It seemed like about everyone did get it except for me. This thread is for those to chime in if they have yet to receive the $100 credit from AT&T and have a reasonable expectation to receive the credit. I ordered mine on 4/2 and still have not received my credit.
    Did you exchange your device for any reason? And who did you order it through? What did you pay for the device?
    05-01-2012 10:37 PM
  3. jimski's Avatar
    Have not gotten my bill yet, but myAT&T is showing a balance of something like $30, which would be my monthly charge+activation-credit. So, yeah I think I got mine. Pre-ordered my L900 on 4/1. Picked up on 4/6. No returns


    Sent from my Lumia 900 using Board Express
    05-01-2012 10:41 PM
  4. apoelin's Avatar
    I haven't gotten it either, but I don't know where to look for it anyway. My first bill was due 6 days ago (on the 25th), and there is no credit there. There doesn't seem to be a place, where I can see account activity after the 25th.
    05-01-2012 11:17 PM
  5. chevydudesixty9's Avatar
    I got $200.... $100 for my first Lumia and $100 for the exchange I did....:P

    It didn't really matter where in my billing cycle I was. My bill was due the 30th and it showed up the 29th. Have a $30 credit on my account since my balance was $170 before the credit...
    Last edited by chevydudesixty9; 05-01-2012 at 11:31 PM.
    05-01-2012 11:26 PM
  6. jhoff80's Avatar
    I have no idea if I got my credit, since I still have "Note: This is a new account and billing information is not yet available. Please check back later."

    I got the phone for $0 off that deal that was up for a short time anyway, so I can't complain too much if it takes longer.
    05-02-2012 12:13 AM
  7. anon(5324511)'s Avatar
    My account has 100.00CR, so I am assuming that I have mine!
    05-02-2012 08:59 AM
  8. elvisff's Avatar
    I have NOT gotten my rebate either, but checking my account did just make me realize that they are overcharging me $30 on another one of my phone lines. Glad I looked.
    05-04-2012 02:18 AM
  9. alpinestars1z's Avatar
    I have NOT gotten my rebate either, but checking my account did just make me realize that they are overcharging me $30 on another one of my phone lines. Glad I looked.
    LOL, freakin' AT&T.

    You should thank Nokia for that. They saved you some money in addition to giving you money (soon hopefully)!
    05-04-2012 02:44 AM
  10. EMINENT 1's Avatar
    Got mine this billing cycle!
    05-05-2012 08:38 AM
LINK TO POST COPIED TO CLIPBOARD